-   Fedora (
-   -   FC6 - UDEV hangs at boot / X won't start (

wayno 06-02-2007 03:10 AM

FC6 - UDEV hangs at boot / X won't start
I've been using FC6 with little or no trouble on my IBM R52 for a while now but as of yesterday, I can't boot into X / Gnome. When I power on and Fedora starts loading modules, it hangs on Starting UDEV for about a minute, before giving me an error about hotplugd and then continuing. However, I can only get to a shell, if I try startx, I get an error about The shell works fine, including my wireless drivers, mounting USB NTFS drives and whatever else I need, just no X. Sorry I don't have the exact errors right now, I'm booted to a Mandriva Live CD (proving that the hardware is fine :)). I'll go away and get the exact errors and post them here. I did some Googling and found other people with similar errors but nont of the solutions worked for me - most involved changing /etc/X11/xorg.conf to use the vesa driver. I think this may be the way to resolve this but I'm just a bit stuck and wondering if anyone here has resolved a similar problem?

I tried going into the BIOS and disabling all other hardware devices (sound, network, etc) to see if that helps but it didn't. I tried 'switchdesk KDE' but that made no difference.

IBM R52, Centrino 1.7, 768Mb RAM, Intel i810 graphics, Intel 2945BG wi-fi, FC6 2.6.20-2948.i686

I'm downloading F7 at work over the weekend and might just wait for that if I can't get this to work but it would be a shame to lose all my customisations, etc. I have my files and settings backed up to a USB hard drive.

wayno 06-02-2007 03:51 AM

OK ignore the 'hotplugd' reference, that seems to have gone away. I had done a yum update hotplugd in a bid to fix the problem so maybe that did something?

The actual error that appears is:

/usr/bin/gnome-session symbol lookup error: /usr/lib/ undefined symbol: g_signal_accumulator_true_handled
I have no idea what that means but I noticed this time that haldaemon didn't start either. I tried to start it manually and it just paused for a minute or so (just like at boot time) so I'm guessing this is the root of the actual problem.

I'm pretty sure I haven't loaded any device drivers in the last week or so that would cause this. I did install K3B DVD-burner a couple of days ago and a few dependancies but I don't specifically recall any drivers.

Any ideas?

All times are GMT -5. The time now is 12:33 PM.