-   Fedora (
-   -   FC5 yum repo problem (

reitsma 10-09-2006 07:37 PM

FC5 yum repo problem
Dear All,

I just got round to upgrading my FC4 installation to FC5. All seems well, except that yum will not run. The error:

>yum list
Loading "installonlyn" plugin
Setting up repositories
core [1/3]
Cannot find a valid baseurl for repo: core
Error: Cannot find a valid baseurl for repo: core

I have now spent about a whole day googling this thing and still do not have things working.

So, some things for you to know:

1. My Internet connectivity is fine.

2. I did a fresh install of FC5 on another machine and yum runs fine there. The /etc/yum.conf and /etc/yum.repos.d files are identical on both machines.

3. Firewall settings using 'lokkit' are identical on both machines.

3a. I did a
>yum clean all effect.

4. In the file /etc/yum.repos.d/fedora-core.repo, the line


is (obviously) commented out. Uncommenting it results in:

>yum list
Loading "installonlyn" plugin
Setting up repositories
core [1/3] [Errno 4] IOError: <urlopen error (11, 'Resource temporarily unavailable')>
Trying other mirror.
Cannot open/read repomd.xml file for repository: core
failure: repodata/repomd.xml from core: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from core: [Errno 256] No more mirrors to try.

I tried HTTPing the various URLs listed in /etc/yum.repos.d/fedora-core.repo and my browser shows them just fine.

I'm at the very end of my rope. I tried uninstalling yum using RPM, but here's what I get

>rpm -e yum
yumerror: Failed dependencies:
yum >= 2.5.3 is needed by (installed) pirut-1.0.1-1.noarch
yum is needed by (installed) system-config-kickstart-2.6.6-2.noarch
yum >= 2.4.0 is needed by (installed) anaconda-runtime-11.0.5-1.i386
yum >= 2.5.1-3 is needed by (installed) anaconda-11.0.5-1.i386

One last thing. On my FC4 box (the one I upgraded to FC 5), I had a (working) yum 2.5 installation that I installed with rpm some time ago. I suspect that this rpm 2.5 installation and the new 2.6.0 installation that came from the FC5 install are biting each other (that would perhaps(?) explain why yum runs fine on the fresh FC5 install).

Can you help?


sn68 10-09-2006 09:27 PM

Are you behind proxy by any chance?
if yes add following line to /etc/yum.conf

mazinoz 10-10-2006 04:57 PM

fedora core 5 repo problem
I agree. I had a similar problem and eventually realised that I needed to specify :port for proxy when I setup the network settings.
Once I had entered this - bingo! However this was a fresh intall also.

mazinoz 10-10-2006 04:58 PM

fedora yum repo problem
Sorry that should read proxy:PORT


reitsma 10-10-2006 07:18 PM


You were all correct! It was the proxy server! Took me forever to figure out. The reason that the "other" box yummed along just fine is because it used the wireless network (go figure!). Once I deactivated eth1 on that box, yum would not work anymore either.

What finally tipped me off was that 'wget' would not work on either of the two boxes.

So yeah, setting the

proxy=http://<proxy_server_url>:<port> in /etc/yum.conf did it!

Thanks for your help!!


All times are GMT -5. The time now is 08:08 PM.