-   Fedora (
-   -   FC5-test3 --> FC5-release - Anyone tried it? (

GL1800 03-21-2006 09:01 AM

FC5-test3 --> FC5-release - Anyone tried it?
Folks how about we share experience here. I have a production install of FC5test3 running really good. I do want to go up to the release by means of an "upgrade". What badness might I encounter with such a move? What has been your experience? Thanks, Ray

reddazz 03-21-2006 10:03 AM

I did the upgrade from test3 today and all went well. I downloaded the fedora-release rpm for FC5 from the Fedora Core mirrors, installed that and did "yum upgrade".

GL1800 03-21-2006 10:09 AM

I appreciate that reddazz.

victorh 03-21-2006 11:18 PM

Hi reddazz, I followed your instructions and right now I'm in FC5. But I have some doubts, maybe you can help me to understand it better.

1. I was using FC5 Test3 for some weeks, and I was using Pup to update the system. At this stage I think that Pup used the Development repositories, all the updates went smoothly. Today before following your instructions I ran Pup and did more updates, I notice that the kernel was going to be updated, when it finished I check the boot directory, I found this:

victor@localhost:~$ ls /boot
config-2.6.15-1.1955_FC5 memtest86+-1.65
initrd-2.6.15-1.1955_FC5.img vmlinuz-2.6.15-1.1955_FC5
initrd-2.6.15-1.2064_FC6.img vmlinuz-2.6.15-1.2064_FC6
Why I have a kernel for FC6? :scratch:

I suspect that Pup was still updating from the development repositories. When I check them in /etc/yum.repos.d they look like these:


[root@localhost yum.repos.d]# cat fedora-core.repo
name=Fedora Core $releasever - $basearch
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY
They all depend on the value of the variables $releasever and $basearch, how can I know the value of these variables?

Since I read your post, I think that the package fedora-release correct the value of this variables so that they point now to FC5 and my basearch that is x86-64, is this correct?

I don't want to use Pup for more upgrades until I'm sure that it's pointing to FC5 and not the development repository that now points to FC6.

Any ideas?

reddazz 03-22-2006 04:59 AM

It seems like for some reason pup is still using the development mirrors. Are you sure your Fedora release rpm is from stable. The version on my system is fedora-release-5-5 and when I upgrade or install packages using yum its connecting to the Fedora core 5 repos.

victorh 03-22-2006 04:16 PM

I've reviewed the fedora-release package:

victor@localhost:~$ rpm -q fedora-release
Now I think I'm using the Fedora Core 5 repos.

Thanks reddazz.

All times are GMT -5. The time now is 04:21 PM.