-   Fedora (
-   -   FC5, Help! Browsers Crash at Startup (

scottflyer 05-25-2006 12:43 PM

FC5, Help! Browsers Crash at Startup

Firefox and all the embedded browsers that come with Fedora, like Konqueror, etc. crash at startup. This started recently, as Firefox used to work. Opera runs, however, but when I try to download and save a file through Opera, Opera crashes. DMESG and syslog do not show any problems. FC5, 32-bit on an HP, with Pentium 4 with 512 MB RAM. Can someone suggest how to solve this. Thanks.:eek:

PTrenholme 05-25-2006 05:00 PM

Try starting Firefox, etc, from a terminal window. Any error messages should be displayed in the window.

But, since all the browsers are "crashing," I'd suspect a problem with your Internet connection, not the browser(s). Use dmesg to verify that your connection was set up correctly, and look in /var/log/messages (or elsewhere in /var/log/) to see if you can find some clues there.

scottflyer 05-25-2006 05:29 PM


Thanks very much for your input.

I tried starting firefox from a terminal and no errors are shown, there is just a delay and a new prompt returns. No errors shown in dmesg or syslogs. I looked in the /var/log directory to see if any logs are updated when firefox or konqueror crashes. Networking is working as I am typing this from Opera, which works and IM works - gaim. If I go to a download page in opera and click "Save," opera will also crash. The system seems otherwise stable.

Any other suggestions would be very welcome.:confused:

PTrenholme 05-26-2006 08:51 AM

This is very strange.

Can you describe in more detail what, exactly, you mean when you say the "browser crashes?" Do all of the "crashes" seem similar in some way? If so, what is it? If not, how do they differ?

Have you tried starting the other browsers from a terminal window? Does, for example, konqueror work properly in "File Management" mode. (Use konqueror --help-all to list the available command line arguments. For example, on my system I have this:

$ konqueror --profiles
$ konqueror --profile filemanagement & # <-- to start the filemanager as  a child process


All times are GMT -5. The time now is 10:32 AM.