LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   FC4 Marvell Yukon driver fails on SN95G5 (https://www.linuxquestions.org/questions/fedora-35/fc4-marvell-yukon-driver-fails-on-sn95g5-333768/)

pda 06-15-2005 04:42 AM

FC4 Marvell Yukon driver fails on SN95G5 [SOLVED]
 
Hi.

I have a Shuttle SN95G5 (mb rev. FN95 v 1.3) that's been running FC2 for a while without problems. I installed FC4 and on boot I was was spammed with a looping error msg saying:

Vpd: Cannot read VPD keys
Class: Internal software error
Nr: 0x19e

Have any of you seen this? Is there a fix for it?


UPDATE:
So it seems I have found a solution... A few different posts around the net mention a patch made by Asus for a socket 754 mainboard, K8V ( it was in fact K8V SE DeLuxe), which someone successfully applied on an SN95G5 since they have the same onboard nic appearantly. After some hunting for the patch due to invalid links I found it and tried it - with luck. Simply a few id updates it seemed.

Make a dos bootdisk and put the files on it. Boot it and run the program like this
Code:

vpdwrite -P as_vpd.raw
Get the patch here (valid link on june 15). [Updated june 22 to reflect url change]


Br,

Roger

equinox 06-15-2005 05:57 AM

can you "modprobe sk18lin"?

jeb-c4 06-19-2005 04:16 AM

Link down on June 19th (4am CST).

If you still have it, would you please email it to me at jebc aatt c4solutions ddoott net.

s/aatt/at s/ddoott/dot/

Thanks if you can or can't (I know how much time it takes to look for this patch).

Jeb Campbell

BKCH 07-23-2005 09:47 AM

Update link 24/07/05: http://dlsvr01.asus.com/pub/ASUS/mb/sock754/k8v_se_dx/vpd_patch.zip

This fix worked for the same problem on my Shuttle SB83G5M :)

dstienek 04-24-2006 10:09 AM

As of 2006-04-24, also available at

ftp://ftp.asus.com/pub/ASUS/mb/sock7.../vpd_patch.zip instead.

(The above got ...'ed, the full ftp path is ftp.asus.com/pub/ASUS/mb/sock754/k8v_se_dx/vpd_patch.zip)

Happy hunting!


All times are GMT -5. The time now is 11:02 PM.