-   Fedora (
-   -   FC4 install errors, "diabling IRQ #10" "nobody cares" error message??? (

A6Quattro 07-15-2005 08:55 PM

FC4 install errors, "diabling IRQ #10" "nobody cares" error message???
I have a very strange message when I try to install FC4 on my one machine. I get to the install screen and hit enter for a new installation. it runs for about 5 secs and starts to hang. it keeps displaying the following message:

hdc: lost interrupt
irq 10: nobody cared!
There are 2 mores sections or so of this and it keeps repeating itself for about 5 mins.

IT then goes into anaconda installer init version starting
mounting /proc filesystem.... done
creating /dev filesystem.... done
mounting /dev/pts (unix98 pty) filesystem.... done
mounting /sys filesystem.... done
cound not set new controlling tty
Trying to remount root filesystem read write.... done
mounting /temp as ramfs.... done
running install....
running /sbin/loader
Disabling irq #10
Disabling irq #10
Disabling irq #10
Disabling irq #10
Disabling irq #10
Disabling irq #10....... It just repeats this over and over.

Any ideas?

It does something similar with FC3 as well but it goes throught the entire process about 15x faster. It actually gets to the "media test" screen on FC3. I select skip and have a blue screen with "disabling IRQ #10" coming up over and over again down the left hand part of the screen.

Has anyone experiened anything like this before?

linuxLuser 07-17-2005 02:53 PM

Well, first thing I'd check is settings in your BIOS, since it's a setup problem with IRQs and whatnot. I really can't think of much else right now. You'll need to check and make sure that nothing's explicitly using IRQ10 or that you have some "funky" setting (sorry, I can't really define that word).

Here's a list of IRQs that I got from this site:

IRQ0 timer tick
IRQ1 keyboard
IRQ2 I/O channel
IRQ5 LPT2, network card, sound card
IRQ6 diskette controller
IRQ7 LPT1, network card, sound card
IRQ8 real-time clock
IRQ9 software redirected to IRQ2
IRQ10 reserved
IRQ11 reserved
IRQ12 reserved
IRQ13 math coprocessor
IRQ14 primary hard disk port
IRQ15 secondary hard disk port

I hope that gives some direction. Did you check the ISO images and everything when you download them? Or did you did a CD integrity test before installing?

-- the duDEMAn

A6Quattro 07-17-2005 04:11 PM

It is a manufactured CD and I've used it on about 30 diff computers with no probs. It was from Linux Magazine.

I tried disabling IRQ 10 in the Bios but it didn't really do anything.,

linuxLuser 07-17-2005 04:37 PM

I've checked around, googling and whatnot, and nobody seems to have a solution. Some have passed "noacpi" or "acpi=off" or "pci=routeirq" or "acpi=noirq" or some combination of them as kernel parameters on startup (I couldn't tell you what they all do!). Others have upgraded kernels to fix it, claiming it's a kernel bug. I don't know what to say about it. I'm not a kernel expert by any means.

I looked here and they suggested that a workaround was to pass "noirqdebug=1" to the kernel. Try that and see. I don't see how it'd hurt <<SHRUG>> :confused:

Let me know.


A6Quattro 07-17-2005 04:47 PM

Thank you for your reply. I'll check the link out. This Linux thing has got my anxiety level so high, it's almost as bad as having blue screen errors!!!:mad:

A6Quattro 07-18-2005 10:07 PM

IRQ 10 is designated for onboard IDE and onboard USB. How can I disable these? When I run FC3 It tells me that

"disabling IRQ #10" " Nobody cared" "Screaming interupt?"

it shows this many times, I think this is a pretty strange message. Amyone have any ideas?

A6Quattro 07-20-2005 12:49 PM

I updated my Bios on my MSI MOBO and it seemed to take care of the problem!

All times are GMT -5. The time now is 08:55 PM.