LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 12-15-2005, 03:07 PM   #1
Daedalus_i
LQ Newbie
 
Registered: Dec 2005
Posts: 10

Rep: Reputation: 0
FC4 crashes after installing Nvidia Drivers


Hello Everybody!
I'm having FX5500 256Mb and I'm also getting a blank screen after installing the drivers. I've already tried too many things, and still haven't done it, to work OpenGL and/or the TV-out.

Please help me. I'm not a newbie on linux, but i can't fix this shit with the Nvidia FX5500.

I'm having a FC4
I disabled SElinux
And as i install either the kernel-module-nvidia* from livna
and the nvidia-glx (from livna too),
the computer crashes when trying to open X

I also tried to install the drivers that i've download from nvidia's site,
i've changed also the xorg.conf as i read on many many forums, but still the same CRASH!

I could try it from the begining with sombody helping me..

I'm thinking that maybe the FX5500 with 256Mb, unlike the FX5500 with 128Mb, is not compative with linux OpenGL at all...

Any suggestions?

Last edited by Daedalus_i; 12-15-2005 at 06:07 PM.
 
Old 12-15-2005, 08:14 PM   #2
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
I have an FX5200-256 video card and I have no trouble at all with the drivers. I get the driver package directly from NVIDIA; I don't use an rpm from livna or anywhere else, although lots of other people have good luck with rpms.

I have to rebuild the Nvidia drivers after each kernel upgrade. You must have the kernel-devel rpm installed for the current version of your kernel.

Prerequisite: SELinux must be disabled.

1. Edit inittab to default runlevel 3.
# gedit /etc/inittab
Change "id:5:initdefault:"
To "id:3:initdefault:"

2. Reboot. X won't start. Use the terminal command line.

3. Login as root, then run the driver install script as follows. Follow the script's directions. You'll have to make choices; know what you're doing. Read the nvidia readme that comes with the driver package. I keep my Nvidia stuff in /opt/src/nvidia.
# cd /opt/src/nvidia
# ./NVIDIA-Linux-x86_64-1.0-8174-pkg2.run

4. Make a copy of xorg.conf and save it.
# cd /etc/X11
# cp xorg.conf xorg.conf.save
# gedit xorg.conf

Here's my xorg.conf. Yours might look different.
Code:
[jcliburn@osprey X11]$ cat xorg.conf
# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath     "unix/:7100"
EndSection

Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
#       Load  "dri"
        Load  "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#       Option  "Xleds"         "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#       Option  "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#       Option  "XkbModel"      "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#       Option  "XkbModel"      "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#       Option  "XkbLayout"     "de"
# or:
#       Option  "XkbLayout"     "de"
#       Option  "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#       Option  "XkbOptions"    "ctrl:swapcaps"
# Or if you just want both to be control, use:
#       Option  "XkbOptions"    "ctrl:nocaps"
#
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "LCD Panel 1280x1024"
        HorizSync    31.5 - 67.0
        VertRefresh  50.0 - 75.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        VendorName  "Videocard vendor"
        BoardName   "NVIDIA GeForce FX (generic)"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     16
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "1280x1024" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "DRI"
        Group        0
        Mode         0666
EndSection
5. Edit inittab to default runlevel 5.
# gedit /etc/inittab
Change "id:3:initdefault:"
To "id:5:initdefault:"

6. Reboot. X should start up. You're done.
 
Old 12-16-2005, 09:40 AM   #3
Daedalus_i
LQ Newbie
 
Registered: Dec 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Thank you very much for your reply.

Ok, everything you say is very easy.
I know how to change the inittab(already used it many times), and already done these steps..

Well, just two questions, before i start over again:

1. Why in your xorg.conf settings you're having:
BoardName "NVIDIA GeForce FX (generic)" ????
Mine has:
BoardName "NVIDIA GeForce FX 5500"
as it recognises the card from the begining(when i first installed Fedora4)

2. First you're installing the drivers and after you change the xorg.conf, as you say...
If after these I run "modprobe nvidia" (that is already done from the installation of the driver) and then run to "init 5", without changing the inittab(just to test if drivers work) is it wrong?
And should I reboot before I go on init 5?

I'll try it now, exactly as you said, if i see that the next post reply, is delayed!

What about the glx? I need to install glx too (to work on Maya7)

Oh there's and another thing...
in your xorg.conf you're having -Load "dri"- disabled and then after that you have -Load "dri"- again and enabled! Are you sure that glx is working properly? Can you perhaps, play any game that rewuired OpenGL? (just to try your settings...

Last edited by Daedalus_i; 12-16-2005 at 09:45 AM.
 
Old 12-16-2005, 11:22 AM   #4
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
Sounds like you know much more about all this than I do. I saw the dri entry in my xorg.conf, too. I have no idea how it got there. I suppose I should remove it. I don't have any GL games to try. At one time I had UT2004 (is that glx?), but I got bored with it pretty quickly and deleted it. Guess I'm not much of a gamer... Is there something else I could use to test glx?

The FX Generic board name must've been placed there by default when the OS detected my video card.

You shouldn't *have* to reboot before going to init 5, since the nvidia installer already modprobed the driver. I suppose you could verify the driver by using lsmod, but you've probably already done that. I feel as though I have better luck with reboots in situations like these, that's all. It's a matter of personal preference.

Sounds like you're doing pretty much everything right. Have you asked your question at the nvidia linux forum?
 
Old 12-16-2005, 11:22 AM   #5
Daedalus_i
LQ Newbie
 
Registered: Dec 2005
Posts: 10

Original Poster
Rep: Reputation: 0
well, i c that you're in now...

I just tried it. I saw that when I inserted the option -Load "dri"- and rebooted, it started loading normal, but when going to show me the log-in screen, it got blank again and the system stopped responding...

Hmm, i think there should be something to do, wih the udev...

After that crash, i rebooted the system by pressing the reset button on the tower and, it didn't work like before. I gave me a black screen just after checking for devices... storage network audio

I haven't tried the nvidia forum, but i've sent an email to nvidia's support team, and got no reply...

I'm not a gamer either, but this is a way to try the nvidia-glx (openGL) if it's working properly.
You could try TUX RACER (ppracer)

Last edited by Daedalus_i; 12-16-2005 at 11:26 AM.
 
Old 12-16-2005, 05:54 PM   #6
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
Quote:
Originally Posted by Daedalus_i
I'm not a gamer either, but this is a way to try the nvidia-glx (openGL) if it's working properly.
You could try TUX RACER (ppracer)
Tux Racer (ppracer) works. <shrug>
 
Old 12-16-2005, 06:21 PM   #7
Daedalus_i
LQ Newbie
 
Registered: Dec 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Hmmm.
I still believe that my Nvidia FX5500 256Mb will never work on linux...

Thanks a lot jcliburn,
i hope that somebody else who has the same card and made it work, read and reply my Thread...

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
screensaver crashes. nvidia drivers maybe? doralsoral Linux - Software 3 02-18-2007 10:38 AM
Problems installing nvidia drivers on FC4 monkiidansu Fedora 7 10-05-2005 03:26 PM
Wolfenstein: ET Crashes After Installing ATI Drivers ThomasJ Linux - Games 12 08-28-2005 08:13 AM
FC4 Nvidia Drivers garbo73 Linux - Hardware 4 08-20-2005 05:27 PM
WindowMaker crashes after installing nVIDIA drivers Tim2000 Linux - Software 2 10-17-2003 06:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 12:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration