-   Fedora (
-   -   FC3 Up2date Says I'm Updated But It's Not. (

harley51 12-01-2004 06:56 PM

FC3 Up2date Says I'm Updated But It's Not.
Here's my problem I noticed that there were updates and I started the process. It hung getting the headers so I stopped up2date and restarted it and it says I'm fully updated now and there is 18 updates out there. The only headers that it pulled in the /var/spool/up2date folder was alsa-lib-1.0.6-5 and alsa-lib-devel-1.0.6-5. Is there someplace else that it thinks that I updated these packages. No packages were downloaded just two headers. Any Help???

reddazz 12-02-2004 06:44 AM

try using apt or synaptic to upgrade your packages. I only use up2date to check whether there are updates and then update using apt.

Basslord1124 12-02-2004 07:13 AM

I didn't think apt or synaptic were in Fedora Core....I thought those commands were for Debian based distributions. The text update tool is called yum. Pull up a command line and make sure you are logged in as root or su to root and type: yum update.

Much better and quicker than up2date IMO.

reddazz 12-02-2004 08:13 AM

there is apt/synaptic for RPM based distros such as Redhat/Fedora, Conectiva, Mandrake, Yoper etc. These tools were ported over from Debian by Conectiva a long time ago. YUM is another good package management tool and so is Mandrakes urpmi.

Skyline 12-02-2004 08:14 AM


I didn't think apt or synaptic were in Fedora Core....I thought those commands were for Debian based distributions
There is actually a "version" of apt for Fedora, but yes, YUM is the native option for Fedora and is certainly favoured over up2date.

Engmar 12-02-2004 01:20 PM

I was just checking to see if anyone had posted a problem similar to mine.

I had noticed updates available, listed at Fedora News.
I ran a yum update, which hung while reading repositories.
I did a "yum clean all," the another update - which seemed
to run properly. However, I noticed that a newer version
of bash is availabe which was not updated on my system.

Further cleanings and updates have not solved the problem.

indy1979 12-02-2004 01:25 PM

I'm having the same problem with mine as well. Up2date says there are 20 updates available. I try using up2date and it says the system is already updated. Yum doesn't ask to download or install anything and I've got the other repositories setup. Synaptic still has the old file versions listed. Is the system just stupid?


harley51 12-02-2004 06:18 PM

Now this guy has the answer that worked for me. What I did was cut them to a temp
folder and reran up2date and every thing worked again. I also cut them back when I was done. End of problem.

remove all the files in /var/spool/up2date and run up2date -u again. This should take care of things.



All times are GMT -5. The time now is 12:01 PM.