LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 03-21-2005, 09:41 AM   #1
wswartz
Member
 
Registered: Nov 2003
Posts: 56

Rep: Reputation: 15
FC3 - Keep losing default route


Hi,

About two weeks ago I upgraded my system to FC3; the installation was very simple and at first was the best Linux experience I've ever had - everything just worked!

But over the weekend my machine started doing something weird. Upon boot up, it didn't get a default route. I can put one in manually but that's rather silly. Then, about every 10 minutes or so, the default route disappears. I then have to do another "route add default" command to get it back. As you can imagine, this is getting rather old.

I know it's FC3 and not anything external to my machine because I also use VMware with a Win2K guest system and it works fine.

Any ideas?

WS
 
Old 03-22-2005, 02:05 AM   #2
Harlin
Member
 
Registered: Dec 2004
Location: Atlanta, GA U.S.
Distribution: I play with them all :-)
Posts: 316

Rep: Reputation: 30
Hi wswartz,

Are you using dhcp to set up your IP Address? If so, would you mind posting the contents of your /etc/dhcpd.conf file?

When you do the manual route add default xxx does your internet/network connection begin immediately?

Thanks,

Harlin Seritt
 
Old 03-22-2005, 06:40 AM   #3
wswartz
Member
 
Registered: Nov 2003
Posts: 56

Original Poster
Rep: Reputation: 15
I rely on a dhcp address from our firewall so I'm not using dhcpd (I also checked; it's not running). It's happened at home, at work, and at another site so I don't think it's the firewall and I'm pretty sure nothing has changed in these dhcp servers to cause this to happen.

Yes, when I run "route add default gw x.x.x.x" my internet connection takes right off. Indeed, I can ping anything in my local network all day long, I'm just not getting a default gw on boot up.

I discovered why the default gw would go away every 10 minutes or so. It was because the lease on my dhcp address was expiring and it was requesting a new one (actually every 20 minutes or so). I've hard coded my IP address as a workaround until I get this figured out. I don't have to do the "route add default" every 20 minutes but I did have to do it again this morning when I booted up :-(

Thanks,
WS
 
Old 03-24-2005, 07:03 AM   #4
wswartz
Member
 
Registered: Nov 2003
Posts: 56

Original Poster
Rep: Reputation: 15
Anyone? I'm thinking I need to reload my system if I can't figure this out.

WS
 
Old 03-24-2005, 09:40 AM   #5
jeffk42
Member
 
Registered: Mar 2005
Location: Orlando, FL USA
Distribution: Fedora Core 13 x86_64 / RHEL 5.3
Posts: 76

Rep: Reputation: 15
I'm having the same problem at work. The first day I brought my laptop in, everything was fine until about lunchtime. From then on, every time I restart the machine, I have to do another route add.

I know I had been working to get the XP drivers for my WPC54G working through ndiswrapper. I wonder if the problem is a result of something I did there. I have no idea. This is my first full-time linux machine.

me ==
 
Old 04-01-2005, 02:49 PM   #6
ranceramos
LQ Newbie
 
Registered: Oct 2004
Location: Brooklyn
Distribution: FC2
Posts: 4

Rep: Reputation: 0
Lightbulb My solution, hope it helps

Well I had a long rant about how I had this same problem all typed up before I realized that I neglected to check my network config scripts. Now, I'm by no means an expert (although I have been using Linux for some time now) so if what I'm saying is wrong, please let me know.

Most of your network related configurations can be found in the following locations (on default installs at least)
/etc/sysconfig/networking
/etc/sysconfig/network-scripts

You don't really want to add configuration specifics to the files in network-scripts because this will generally cause annoying errors at startup, but more importantly, these scripts are used to read configuration files in order to setup your network configs, so the configuration files are where you should make your changes.

Here's what to do to fix the routing problem (ie. where you can access the Linux box on the lan but cannot get to the internet):
0. Become root (login as root or use su)
1. First identify your active device name (ie. eth0, eth1, wlan0, wlan1, etc.)
2. Navigate to /etc/sysconfig/networking/profiles/default
3. Identify the ifcfg file associate with your device name (for me, ifcfg-eth0)
4. The file should look something like this:
# Intel Corp.|82557/8/9 [Ethernet Pro 100]
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:D0:B7:B1:A3:81
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
PEERDNS=yes
IPV6INIT=no
NETMASK=255.255.255.0
IPADDR=192.168.0.32
GATEWAY=192.168.0.1

The key here is the gateway. For those of you with little or no networking knowledge, your gateway lets your computer know how to access networks outside of your LAN (ie. other lans, WANs, the Internet). Anyway, the problem I had was that the gateway was set to the loop back device (127.0.0.1), which basically tell the computer to handle it's access to the internet. (I'm not sure if a recently yum update that upgraded the kernel did this or if dhclient was upgraded and edited this file) This is ok if your computer is acting as a router for your LAN, but most of you will be using this box to access the internet through some other router (ie. wireless router, the LANs router, etc). So, what you have to do is set the gateway to the ip address your actual router. In this case, my wireless NAT router is at ip 192.168.0.1 so that's the setting I'm using. (I believe this is generally set to the netmask of the router, but don't hold me by that....this way worked fine for me and has all along)

I tried to make this as easy as possible, hope it helps.
 
Old 04-03-2005, 10:32 PM   #7
websaber
LQ Newbie
 
Registered: Apr 2005
Posts: 1

Rep: Reputation: 0
route

It might have something to do with your routing. Try the route command
[root@localhost ~]# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
default 192.168.0.1 0.0.0.0 UG 0 0 0 eth0

if you don't have a default route that might be your problem.

FC3 is supposed to have a service called NetworkManager that is suppose to auto update your default route but it doesn't seem to work to well. That might be why people are losing their default route, disable it and it seems to work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
c++ default route bassdemon Programming 1 02-06-2005 10:29 AM
Uninstalling FC3 w/out losing XP Phaen Ilda Linux - Newbie 13 01-10-2005 10:32 PM
Route to subnet exists but I get "Network unreachable" when adding default route fciuffani Linux - Networking 4 08-18-2004 02:11 PM
Keep losing route and DNS. nerdbebo Linux - Networking 2 07-15-2004 06:08 AM
Route dialup modem packets back through dialup instead of default route cable modem jogress Linux - Networking 1 10-21-2003 03:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 01:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration