-   Fedora (
-   -   FC3/Firefox question (

brainfry 04-03-2005 04:55 PM

FC3/Firefox question
Hi. I've reinstalled FC3 today, updated via Up2date and everything seems fine.
I'm running kernel 2.6.10-1.770_FC3 on an i686, KDE 3.3.1-2.9.FC3 RED HAT and Firefox version 1.0.2.

The problem I've just come up against is that I use a mobile phone site for web based email at and can't access it due to the following message:

"Browser Upgrade Netscape

You are using an old version of your current web browser, don't worry, this is easily remedied by simply upgrading your current web browser using one of the following link: [Opens in a new window]

This will help improve your overall experience of the world wide web by allowing you to load web pages faster, use more interactive features and view the web in a way the creators intended you to. To find out more about why you have been redirected to this page please read our technical explanation. " (The technical explanation is just as funny)

I know I'm a 'noob', but I was under the impression that Firefox was more up to date than Netscape

I've also tried to get on under Gnome on the same system with the same result. If I boot into XP (which I don't like doing much anymore) where I'm using Firefox 1.0, I can access the O2 site.

The funny thing is that I can also access the site using Konqueror (I prefer Firefox though which is why I'm posting)

Has anyone else had any experience with this or something similar?


Pete M 04-03-2005 05:08 PM


The only reason I can think of is that you may not have any plugins installed such as Flash ?

I can access the site using Suse 9.2 and Firefox


brainfry 04-03-2005 05:11 PM

Hi Pete

I installed the flash 7 plugin the same time I downloaded the Nvidia driver. It's the first time it's happened to me.

Thanks for the quick reply though


Pete M 04-03-2005 05:32 PM

Java ?


reddazz 04-03-2005 05:36 PM

I am an O2 customer and that site was definitely working with Firefox a week or so ago. Mozilla doesn't work either. I will try it from Slack using Firefox and Konqueror and give you feedback.

brainfry 04-03-2005 05:41 PM

Looking at the web features under preferences, both 'enable Java & enable Javascript' are checked, so I'm guessing it isn't Java related (though I'm frequently wrong

:D )

It's just a bit strange that I've not come up against it in other versions. It's one of the reasons I'm enjoying using Linux, it makes you think more :study:



reddazz 04-03-2005 05:43 PM

Its definitley an FC3 problem, because it works fine in Slack. I have all the plugins installed in FC3 so its not a problem with those. All I can think is that the version of Firefox in Fedora sends out a string thats being identified as an old browser by the O2 website.

brainfry 04-03-2005 05:48 PM

Thanks reddazz. It makes sense as Pete says in an earlier post that he can get on using Suse 9.2 and Firefox.

snecklifter 04-04-2005 09:08 AM

Filthy, its doing it in Mozilla too.

snecklifter 04-04-2005 09:25 AM

Okay, *fixed*. This is a problem with the fedora browser compile so just download an original version from and you'll be laughing.

reddazz 04-04-2005 09:33 AM

I wondered why it was working in CentOS but not in FC3. Anyway in CentOS, I use an rpm I created myself using the packages from

brainfry 04-04-2005 12:40 PM

Nice one. Thanks a lot, I'll go and download it now.



brainfry 04-04-2005 01:12 PM

Heh, heh, 'tis all sorted now. Just downloaded 1.0.2 from the Firefox site and installed it and everything is good again.

Thanks again everyone.


All times are GMT -5. The time now is 10:21 PM.