LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 06-15-2004, 03:57 PM   #1
justinian1978
Member
 
Registered: Mar 2004
Location: Missouri
Distribution: Various
Posts: 47

Rep: Reputation: 15
FC2 sound issues


Ok so I did a fresh install of FC2 on my system and I'm not getting sound. I'm getting it perfectly in windows so I know it's hooked up correctly. I've read the threads and gotten some useful information, but I was wondering what to do next. So far, I've opened KMix and unmuted the master gains and such to no avail, still can't hear sound. In that process I did mute the mic input and that got rid of a lot of the status, but I am still hearing some. I was reading another thread and it suggested editing the modprobe.conf file, but I don't know how to do that, or if it's something I need to do. I have a Sound Blaster 128 PCI card and the ALSA docs say that there are 3 different ALSA drivers for different versions of that card.

Here's the output of my /sbin/lspci:

[root@justinian downloads]# /sbin/lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]
00:0b.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 04)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 SE] (rev 01)
01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200 SE] (Secondary) (rev 01)

Here's the output of my cat /etc/modprobe.conf:

[root@justinian downloads]# cat /etc/modprobe.conf
alias eth0 via-rhine
alias snd-card-0 snd-ens1371
install snd-ens1371 /sbin/modprobe --ignore-install snd-ens1371 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-ens1371 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-ens1371
alias snd-card-1 audio
install audio /sbin/modprobe --ignore-install audio && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove audio { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove audio
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd

Thanks in advance for any help, guys!

-Brent
 
Old 06-15-2004, 04:35 PM   #2
kaloyer
Member
 
Registered: Jun 2004
Location: Tucson, AZ, USA
Distribution: Arch Linux 0.7
Posts: 52

Rep: Reputation: 15
i used to use fedora, and because it uses alsa, i can tell you how to fix this. turn up EVERYTHING in KMIX, i think XMMS and Rythmbox use PCM, so you should do that one first, then keep going. If it's a driver issue, (which, in fedora is rare), try running
Code:
alsaconf
that really helps. if it STILL doesn't work, try running
Code:
modprobe XXX
where XXX is your sound driver(alsaconf will tell you this, eg mine is snd-ymfpci). that's all I got, google around if nothing works.
 
Old 06-15-2004, 04:52 PM   #3
justinian1978
Member
 
Registered: Mar 2004
Location: Missouri
Distribution: Various
Posts: 47

Original Poster
Rep: Reputation: 15
Ok I turned everything up in KMix and no sound still. When I type alsaconf in terminal, it gives:

[root@justinian home]# alsaconfig
bash: alsaconfig: command not found

Am I doing something wrong?

-Brent
 
Old 06-15-2004, 05:00 PM   #4
kaloyer
Member
 
Registered: Jun 2004
Location: Tucson, AZ, USA
Distribution: Arch Linux 0.7
Posts: 52

Rep: Reputation: 15
the command is
Code:
alsaconf
no IG on the end, try it again
 
Old 06-15-2004, 05:28 PM   #5
justinian1978
Member
 
Registered: Mar 2004
Location: Missouri
Distribution: Various
Posts: 47

Original Poster
Rep: Reputation: 15
Here's alsaconf:

[root@justinian home]# alsaconf
bash: alsaconf: command not found

Anything else I should try?

-Brent
 
Old 06-15-2004, 06:07 PM   #6
kaloyer
Member
 
Registered: Jun 2004
Location: Tucson, AZ, USA
Distribution: Arch Linux 0.7
Posts: 52

Rep: Reputation: 15
I googled a liitle and found this
its an rpm that includes alsaconf just su to root and type
Code:
rpm -ivh alsa-utils*
that will install it. then do alsaconf again, no wonder there was no sound.
 
Old 06-15-2004, 09:47 PM   #7
justinian1978
Member
 
Registered: Mar 2004
Location: Missouri
Distribution: Various
Posts: 47

Original Poster
Rep: Reputation: 15
I downloaded that and attempted to install. Here's the output:

[root@justinian downloads]# rpm -ivh alsa-utils*
warning: alsa-utils-1.0.5-0_9.rhfc2.at.i386.rpm: V3 DSA signature: NOKEY, key ID 66534c2b
Preparing... ########################################### [100%]
file /usr/bin/aconnect from install of alsa-utils-1.0.5-0_9.rhfc2.at conflicts with file from package alsa-utils-1.0.3-1
file /usr/bin/alsamixer from install of alsa-utils-1.0.5-0_9.rhfc2.at conflicts with file from package alsa-utils-1.0.3-1
file /usr/bin/amidi from install of alsa-utils-1.0.5-0_9.rhfc2.at conflicts with file from package alsa-utils-1.0.3-1
file /usr/bin/amixer from install of alsa-utils-1.0.5-0_9.rhfc2.at conflicts with file from package alsa-utils-1.0.3-1
file /usr/bin/aplay from install of alsa-utils-1.0.5-0_9.rhfc2.at conflicts with file from package alsa-utils-1.0.3-1
file /usr/bin/aplaymidi from install of alsa-utils-1.0.5-0_9.rhfc2.at conflicts with file from package alsa-utils-1.0.3-1
file /usr/bin/arecordmidi from install of alsa-utils-1.0.5-0_9.rhfc2.at conflicts with file from package alsa-utils-1.0.3-1
file /usr/bin/aseqnet from install of alsa-utils-1.0.5-0_9.rhfc2.at conflicts with file from package alsa-utils-1.0.3-1
file /usr/bin/iecset from install of alsa-utils-1.0.5-0_9.rhfc2.at conflicts with file from package alsa-utils-1.0.3-1
file /usr/sbin/alsactl from install of alsa-utils-1.0.5-0_9.rhfc2.at conflicts with file from package alsa-utils-1.0.3-1
file /usr/share/man/man1/arecordmidi.1.gz from install of alsa-utils-1.0.5-0_9.rhfc2.at conflicts with file from package alsa-utils-1.0.3-1

It looks like 1.0.3 is installed and it's conflicting with the package that I'm trying to install. What should I do now?

-Brent
 
Old 06-15-2004, 10:02 PM   #8
kaloyer
Member
 
Registered: Jun 2004
Location: Tucson, AZ, USA
Distribution: Arch Linux 0.7
Posts: 52

Rep: Reputation: 15
run it with the --force argument, like this
Code:
rpm -Uvh --force alsa-utils*
that should make it work

it's telling you these conflicts because your upgrading files, don't worry about them and do the force, it WILL work, if it doesn't you can still try
Code:
rpm -Uvh --force --replacepkgs alsa-utils*
that will replace your old version and update it

Last edited by kaloyer; 06-15-2004 at 10:07 PM.
 
Old 06-15-2004, 11:21 PM   #9
justinian1978
Member
 
Registered: Mar 2004
Location: Missouri
Distribution: Various
Posts: 47

Original Poster
Rep: Reputation: 15
Here's the output of that:

[root@justinian downloads]# rpm -Uvh --force alsa-utils*
warning: alsa-utils-1.0.5-0_9.rhfc2.at.i386.rpm: V3 DSA signature: NOKEY, key ID 66534c2b
Preparing... ########################################### [100%]
1:alsa-utils ########################################### [100%]
[root@justinian downloads]# alsaconf
bash: alsaconf: command not found
[root@justinian downloads]# rpm -Uvh --force --replacepkgs alsa-utils*
warning: alsa-utils-1.0.5-0_9.rhfc2.at.i386.rpm: V3 DSA signature: NOKEY, key ID 66534c2b
Preparing... ########################################### [100%]
1:alsa-utils ########################################### [100%]
[root@justinian downloads]# alsaconf
bash: alsaconf: command not found

It looks like it's installing the RPM just fine, but for some reason it's not recognizing that alsaconf command. Any suggestions?

-Brent
 
Old 06-16-2004, 11:32 AM   #10
kaloyer
Member
 
Registered: Jun 2004
Location: Tucson, AZ, USA
Distribution: Arch Linux 0.7
Posts: 52

Rep: Reputation: 15
ok, i gave you the wrong rpm . this rpm contains alsaconf EXCLUSIVELY. that means all you get is alsaconf

here it is-------------->CLICK HERE <---------------------------

then do the
Code:
rpm -Uvh alsaconf*
I'm POSITIVE this one will work.
 
Old 06-16-2004, 11:46 AM   #11
justinian1978
Member
 
Registered: Mar 2004
Location: Missouri
Distribution: Various
Posts: 47

Original Poster
Rep: Reputation: 15
Ok that one worked, but I'm running into different troubles now. Here's what happens after I configure my card:

Loading driver:
/usr/bin/alsaconf: line 913: start: command not found
Setting the PCM volume to 100% and the Master output volume to 50%
amixer: Unable to find simple control 'PCM',0

Could not initialize the mixer, the card was probably
not detected correctly.

I've tried about 3 different card types and nothing works. According to the ALSA docs, it should be a snd-ess1370, 71, or 73. I've tried all three. When I run alsaconf, it asks me for the card type, then askes me for bitrate between 4-128. I've tried selecting 64 and 128 to no avail. Any suggestions?

-Brent
 
Old 06-16-2004, 01:44 PM   #12
kaloyer
Member
 
Registered: Jun 2004
Location: Tucson, AZ, USA
Distribution: Arch Linux 0.7
Posts: 52

Rep: Reputation: 15
this is just a guess, but you could try
Code:
modprobe snd-ess137x
where x is one of the three cards. i'm not sure tho, cuz modprobe doesn't work sometimes...
 
Old 06-16-2004, 09:07 PM   #13
justinian1978
Member
 
Registered: Mar 2004
Location: Missouri
Distribution: Various
Posts: 47

Original Poster
Rep: Reputation: 15
Yeah, modprobe evidently isn't recognized. Here's what I get:

[root@justinian brent]# modprobe snd-ess1371
bash: modprobe: command not found

Wow, this is frustrating!

-Brent
 
Old 06-16-2004, 10:30 PM   #14
flyfishin
Member
 
Registered: Aug 2003
Location: KC, MO
Distribution: CentOS, RHEL, SuSE, Fedora
Posts: 243

Rep: Reputation: 30
1. The first rpm you had was the correct one, it was for FC2 and it provides alsaconf. The second one you downloaded was for Turbo Linux. I personally would not install an rpm built for another distro unless I was positive I wouldn't have problems.
2. The reason the first rpm didn't work was because you issued -ivh to the rpm command. You told rpm to install the rpm. Since it was already installed, it told you it couldn't simply install a new rpm. Instead of using the -ivh options use -Uvh. That tells rpm to either upgrade installed rpms with this new one or if they don't already exists just install it. The -Fvh option will only upgrade rpms, it won't install the new rpm if an old version isn't already installed.
3. Fedora has tons of system utilities for configuration. The one for sound cards is system-config-soundcard
4. If you don't have the modprobe command you need to install the modutils rpm.
5. Go here http://dag.wieers.com/home-made/apt/ and install apt. That will let you use apt-get to install over 1200 rpms made for Fedora Core 2.

Try fixing your rpm and running system-config-soundcard and see what happens.
 
Old 06-17-2004, 07:55 AM   #15
justinian1978
Member
 
Registered: Mar 2004
Location: Missouri
Distribution: Various
Posts: 47

Original Poster
Rep: Reputation: 15
I will try those when I get home from work! Thanks for the advice!

-Brent
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FC2 Sound issues UmneyDurak Fedora 1 02-04-2005 01:11 PM
sound issues FC2 zoings Linux - Hardware 2 10-31-2004 06:14 PM
FC2 sound issues Scrotonomous Fedora 4 10-27-2004 12:44 AM
FC2: Sound Card (SiS SI7012) Detect But Donot Play Sound rajanaeem Linux - Hardware 0 10-22-2004 04:41 PM
Need to run system-config-sound after every boot too make sound work in FC2 jrbiochem Linux - Hardware 11 08-04-2004 08:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 02:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration