LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 03-10-2005, 01:41 PM   #1
Trio3b
Member
 
Registered: Oct 2004
Location: Texas, USA
Distribution: MDV 2008.1, PCLinuxOS,
Posts: 315

Rep: Reputation: 30
FC2 - Kppp dialer


Curious about FC2- removed MDK 10.0 on PC w/ext ser. dialup modem(that was working fine). Configured Kppp in FC2 same as in MDK. Modem connects, but browsers (konq,moz) cannot find connection. Closed that and tried FC2 internet conf wizard, setting up new modem connection. Cannot activate device (error 6 or 8) and modem does not show up in hdwr brwsr.
OK.here's what's new. Kppp still connects but browsers will not. But....I deleted the "-" in the ISP phone # in the FC2 internet configuration wizard and am now able to activate the ext. ser modem and both browsers are now able to connect (am posting thru this connection). The modem still does not show in the hdwr browser, but I am online.
1. Is the network device the default dialer for FC2, and should I just leave Kppp out of the equation?
2. Now that my curiosity is up, why won't the Kppp work. This PC, Kppp dialer, modem, phoneline combo was working with MDK 10.0 installed last week.
Here is the resolv.conf while connected

j[root@localhost etc]# cat resolv.conf

nameserver 209.244.0.3
nameserver 209.244.0.4
[root@localhost etc]#

Here is the fstab:

[root@localhost etc]# cat -n fstab
1 LABEL=/ / ext3 defaults 1 1
2 LABEL=/boot /boot ext3 defaults 1 2
3 none /dev/pts devpts gid=5,mode=620 0 0
4 none /dev/shm tmpfs defaults 0 0
5 none /proc proc defaults 0 0
6 none /sys sysfs defaults 0 0
7 /dev/hda3 swap swap defaults 0 0
8 /dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
9 /dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
[root@localhost etc]#

hope this helps
thanks
 
Old 03-10-2005, 02:05 PM   #2
sandgroper
Member
 
Registered: Jul 2004
Location: Perth , Western Australia
Distribution: Fedora Core 5 , Mint 9
Posts: 118

Rep: Reputation: 15
Re: FC2 - Kppp dialer

Quote:
Originally posted by Trio3b
Curious about FC2- removed MDK 10.0 on PC w/ext ser. dialup modem(that was working fine). Configured Kppp in FC2 same as in MDK. Modem connects, but browsers (konq,moz) cannot find connection. Closed that and tried FC2 internet conf wizard, setting up new modem connection. Cannot activate device (error 6 or 8) and modem does not show up in hdwr brwsr.
OK.here's what's new. Kppp still connects but browsers will not. But....I deleted the "-" in the ISP phone # in the FC2 internet configuration wizard and am now able to activate the ext. ser modem and both browsers are now able to connect (am posting thru this connection). The modem still does not show in the hdwr browser, but I am online.
1. Is the network device the default dialer for FC2, and should I just leave Kppp out of the equation?
2. Now that my curiosity is up, why won't the Kppp work. This PC, Kppp dialer, modem, phoneline combo was working with MDK 10.0 installed last week.
Here is the resolv.conf while connected

jthanks
Have a read of this article , I wrote it last week when I had problems with kppp , this is the way I got kppp working in Gnome and it works well.
( it's a first draft so the formatting could be a bit messy )

http://203.59.24.225/~steveray/linux/kpppconfig.txt

If you can connect but have problems resolving ip addresses in the browsers , then you have your default gateway set to something else other than the ip address of your ISP.

Issue the command
route -n
to check if you have 2 entries for ppp0 , one for the destination address and the other for the gateway address.
 
Old 03-11-2005, 12:12 AM   #3
Trio3b
Member
 
Registered: Oct 2004
Location: Texas, USA
Distribution: MDV 2008.1, PCLinuxOS,
Posts: 315

Original Poster
Rep: Reputation: 30
Kppp

here is output:

[mark@localhost mark]$ route -n
bash: route: command not found
[mark@localhost mark]$ su
Password:
[root@localhost mark]# route -n
bash: route: command not found
[root@localhost mark]#

someone asked me to post this is output while i am online.


[root@localhost etc]# cat resolv.conf

nameserver 209.244.0.3
nameserver 209.244.0.4
[root@localhost etc]#

why would both browsers find my ISP with the conf wizard but not the Kppp dialer?

Also, kudzu mysteriously appeared during boot today and found the zoom modem (it has never found it before) and asked if I wanted to configure. I answered yes....it did its thing....said it was adding it to etc/fstab, then continued booting. If I open fstab, the modem is not listed.

Do you know which is the default dialer for FC2? internet conf wizard OR Kppp or are they interdependent. Since the wizard is now working, I'm inclined to leave Kppp alone but for curiosity.
thanks
 
Old 03-11-2005, 08:01 AM   #4
sandgroper
Member
 
Registered: Jul 2004
Location: Perth , Western Australia
Distribution: Fedora Core 5 , Mint 9
Posts: 118

Rep: Reputation: 15
Re: Kppp

Quote:
Originally posted by Trio3b
here is output:

[mark@localhost mark]$ route -n
bash: route: command not found
[mark@localhost mark]$ su
Password:
[root@localhost mark]# route -n
bash: route: command not found
[root@localhost mark]#

someone asked me to post this is output while i am online.


[root@localhost etc]# cat resolv.conf

nameserver 209.244.0.3
nameserver 209.244.0.4
[root@localhost etc]#

why would both browsers find my ISP with the conf wizard but not the Kppp dialer?

Also, kudzu mysteriously appeared during boot today and found the zoom modem (it has never found it before) and asked if I wanted to configure. I answered yes....it did its thing....said it was adding it to etc/fstab, then continued booting. If I open fstab, the modem is not listed.

Do you know which is the default dialer for FC2? internet conf wizard OR Kppp or are they interdependent. Since the wizard is now working, I'm inclined to leave Kppp alone but for curiosity.
thanks
Firstly with the route -n command , it won't work in user mode , you will have to use it in /root mode.

Secondly , to change into /root mode at a terminal use the command
su -
# note the "-"

This places you in /root's home directory , just issuing su without the "-" places you in the users directory.

To use the route -n command after just using su , you need to direct the command to the right directory by using the command
/sbin/route -n

Another command the you can use to get the same output is to use
netstat -r
( or /bin/netstat -r )

This displays the kernel routing table.

Try using one these commands and post your results.


The default dialer for FC is /etc/wvdial which is used by system-config-network.

The internet configuration wizard adds a device entry into system-config-network Device Tab .



As long as you have got the hardware entry for the modem in system-config-network , then you can configure kppp for your dial up connection.

kppp can be a bit awkard to set up at times , but it is a whole lot better than using the default dialer.

Wvdial is too primative , cryptic error messages , doesn't display anything when are connected , can't display any connection speeds and takes awhile to disconnect , even if you add a modem command to make it disconnect quicker.

You are half way there at getting kppp to work , so you might as well try and get it going properly.
 
Old 03-12-2005, 01:28 AM   #5
Trio3b
Member
 
Registered: Oct 2004
Location: Texas, USA
Distribution: MDV 2008.1, PCLinuxOS,
Posts: 315

Original Poster
Rep: Reputation: 30
FC2 browsers not working

Here is the output of route -n while online:

[mark@localhost mark]$ su -
Password:
[root@localhost root]# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
63.215.26.181 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 lo
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 63.215.26.181 0.0.0.0 UG 0 0 0 ppp0
[root@localhost root]#

Followed directions in your post and in your Kppp setup document..............no luck.
browsers still not responding. Again, if I connect using the int conf wizard, I can use the browsers.
This one has me stumped. I spent a while getting Kppp to work in Mandrake 10.0, but, that was because I was using drivers for an internal PCI modem and it required lots of messing around with the init strings, but as far as the DNS addressing and other configuration, MDK 10 figured it all out by default.
 
Old 03-12-2005, 10:46 AM   #6
sandgroper
Member
 
Registered: Jul 2004
Location: Perth , Western Australia
Distribution: Fedora Core 5 , Mint 9
Posts: 118

Rep: Reputation: 15
Re: FC2 browsers not working

Quote:
Originally posted by Trio3b
Here is the output of route -n while online:

[mark@localhost mark]$ su -
Password:
[root@localhost root]# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
63.215.26.181 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 lo
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 63.215.26.181 0.0.0.0 UG 0 0 0 ppp0
[root@localhost root]#

Followed directions in your post and in your Kppp setup document..............no luck.
browsers still not responding. Again, if I connect using the int conf wizard, I can use the browsers.
This one has me stumped. I spent a while getting Kppp to work in Mandrake 10.0, but, that was because I was using drivers for an internal PCI modem and it required lots of messing around with the init strings, but as far as the DNS addressing and other configuration, MDK 10 figured it all out by default.
Your routing table looks good , can you get this after you dial in using kppp ?
( before you even try to use your web browser )

You may have to recheck the settings in the DNS Tab of kppp ,
kppp -> Configure -> Accounts Tab --> <ISP account> ---> Edit --> DNS Tab
Check that you have
Domain Name : <your computer name / alias >
Config : Manual
DNS Address : < Your ISP dns server IP address
Uncheck : Disable Existing DNS Server During Connection

If you have your Domain Name set to your ISP , then it will cause problems.

You will also have to check in the Network Device Control to see if you have set your host name , Primary DNS in the DNS Tab.
 
Old 03-13-2005, 12:06 AM   #7
Trio3b
Member
 
Registered: Oct 2004
Location: Texas, USA
Distribution: MDV 2008.1, PCLinuxOS,
Posts: 315

Original Poster
Rep: Reputation: 30
Kppp dialer

These are terminal outputs under various conditions

connect using Int. conf .wiz .route table

after connect - before browser


[mark@coppernet mark]$ su -
Password:
[root@coppernet root]# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
63.215.26.180 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 lo
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 63.215.26.180 0.0.0.0 UG 0 0 0 ppp0
[root@coppernet root]#

after browser connect

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
63.215.26.180 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 lo
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 63.215.26.180 0.0.0.0 UG 0 0 0 ppp0
[root@coppernet root]#


Kppp
after connect - before browser

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
63.215.26.181 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 lo
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 63.215.26.181 0.0.0.0 UG 0 0 0 ppp0
[root@coppernet root]#

no browser connect

I then reset DNS tab in Kppp to the .180 setting and this showed in the terminal

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
63.215.26.213 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 lo
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.063.215.26.213 0.0.0.0 UG 0 0 0 ppp0
0.0.0.1
no browser connect

The browser windows open up, but either the window remains blank or receive "could not connect to..........error"
appreciate your time, however I may have to move on to other things. Kppp on my MDK 10.0 PC is working fine and just for curiosity, setup dialup internet connection and connected on my Wxp PC in exactly 77 seconds (timed it).
Would like to try FC2 but the following may turn me away.
Requiring root for almost everything (nice for security, but using it as default for initial setup is no good). If it's taking this long to get Kppp to work, I wonder how long it will take to change permissions and/or add users for mundane tasks.
The network device conf. took 2 or 3 days to get working and never really did figure out why
The Kppp dialer should not be this difficult
Also tried to dual boot with MDK 10.0 Grub and LILO could never play nice. It could be me, but I read several articles about FC2 changing the hard drive geometry and causing dual boot problems.
Mozilla browser will not retain bookmarks.
These are configurations that should be taken care of in the default installation. I never had any of these issues in MDK 10.0 or Wxp.
Unfortunately, I use my PC's for business and can only allot a certain slice of time for each project. Thanks for your help. I may continue this in the near future.


new edit
OK.....just finished checking RedHat bugzilla reports. This problem has been identified in Red Hat AND FC2 ............SINCE 1999!!!! ........................can you believe it !!!!!!!!!
The techs answer is.....its been fixed, The techs NEVER give the workaround, they just acknowledge there is a bug and that it has been fixed in the upcoming release, then a new release comes out and there's more bug reports. Apparently Kppp saves the DNS address to a different file than what the browsers are looking for even if you choose the manual setting. Like I said, I got Wxp dialup in 77 secs. and have now spent two days in FC2 dialup. ( no DSL around here). This tells me all I need to know about FC2. If you think we can fix this IN A FEW MINUTES, then I would be willing to try.......otherwise it's GOODBYE!! to FC2.

Someone in another thread suggested copying the
/etc/resolv.conf into the /etc/ppp/ folder. Am very new to CL. Does this sound viable?

Thanks for your help

Last edited by Trio3b; 03-13-2005 at 02:39 AM.
 
Old 03-13-2005, 02:11 PM   #8
sandgroper
Member
 
Registered: Jul 2004
Location: Perth , Western Australia
Distribution: Fedora Core 5 , Mint 9
Posts: 118

Rep: Reputation: 15
Re: Kppp dialer

Quote:
Originally posted by Trio3b
These are terminal outputs under various conditions

no browser connect

I then reset DNS tab in Kppp to the .180 setting and this showed in the terminal

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
63.215.26.213 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 lo
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.063.215.26.213 0.0.0.0 UG 0 0 0 ppp0
0.0.0.1
no browser connect

The browser windows open up, but either the window remains blank or receive "could not connect to..........error"
appreciate your time, however I may have to move on to other things. Kppp on my MDK 10.0 PC is working fine and just for curiosity, setup dialup internet connection and connected on my Wxp PC in exactly 77 seconds (timed it).
Would like to try FC2 but the following may turn me away.
Requiring root for almost everything (nice for security, but using it as default for initial setup is no good). If it's taking this long to get Kppp to work, I wonder how long it will take to change permissions and/or add users for mundane tasks.
The network device conf. took 2 or 3 days to get working and never really did figure out why
The Kppp dialer should not be this difficult
Also tried to dual boot with MDK 10.0 Grub and LILO could never play nice. It could be me, but I read several articles about FC2 changing the hard drive geometry and causing dual boot problems.
Mozilla browser will not retain bookmarks.
These are configurations that should be taken care of in the default installation. I never had any of these issues in MDK 10.0 or Wxp.
Unfortunately, I use my PC's for business and can only allot a certain slice of time for each project. Thanks for your help. I may continue this in the near future.


new edit
OK.....just finished checking RedHat bugzilla reports. This problem has been identified in Red Hat AND FC2 ............SINCE 1999!!!! ........................can you believe it !!!!!!!!!
The techs answer is.....its been fixed, The techs NEVER give the workaround, they just acknowledge there is a bug and that it has been fixed in the upcoming release, then a new release comes out and there's more bug reports. Apparently Kppp saves the DNS address to a different file than what the browsers are looking for even if you choose the manual setting. Like I said, I got Wxp dialup in 77 secs. and have now spent two days in FC2 dialup. ( no DSL around here). This tells me all I need to know about FC2. If you think we can fix this IN A FEW MINUTES, then I would be willing to try.......otherwise it's GOODBYE!! to FC2.

Someone in another thread suggested copying the
/etc/resolv.conf into the /etc/ppp/ folder. Am very new to CL. Does this sound viable?

Thanks for your help
Your routing table looks OK , the problem must be with kppp itself.
The file /etc/resolv.conf is the same as /etc/ppp/kppp/resolve.conf , so yeah , try copying it accross .

To see if the file /etc/ppp/resolve.conf is actually being used by kppp , open up that file after you connect , you should see a temporary entry inserted in it by kppp , the same also goes fo /etc/resolve.conf , there should be a temporary entry in the file for kppp when you are connected.

If the file /etc/ppp/resolve.conf doesn't reflect the same contents as /etc/resolve.conf , then you can create a link to link the files together so that if one is updated , then the other one also gets updated.

Yeah , Linux can at times be easy to configure , but if there is a problem , then it can take a lot to get it all figured out and working.
With kppp , I spent a week trying to figure out how to get it going properly , I finally did and I am glad because kppp is a lot better interface to use than using the Network Device Control interface.

Anyway , good luck.
 
Old 03-15-2005, 02:09 AM   #9
Trio3b
Member
 
Registered: Oct 2004
Location: Texas, USA
Distribution: MDV 2008.1, PCLinuxOS,
Posts: 315

Original Poster
Rep: Reputation: 30
/etc/resolv.conf

OK here is resolv.conf after logging onto net with net conf tool:

[mark@coppernet etc]$ cat resolv.conf
domain localdomain
domain localdomain

nameserver 209.244.0.3
nameserver 209.244.0.4
nameserver 63.215.26.213

The only address that is one of three that the ISP uses is the 63.215.26.213.
I don't know where the others came from

Being new to CL.....how do I edit this file and what should go in here
Thanks
 
Old 03-15-2005, 11:10 AM   #10
sandgroper
Member
 
Registered: Jul 2004
Location: Perth , Western Australia
Distribution: Fedora Core 5 , Mint 9
Posts: 118

Rep: Reputation: 15
Re: /etc/resolv.conf

Quote:
Originally posted by Trio3b
OK here is resolv.conf after logging onto net with net conf tool:

[mark@coppernet etc]$ cat resolv.conf
domain localdomain
domain localdomain

nameserver 209.244.0.3
nameserver 209.244.0.4
nameserver 63.215.26.213

The only address that is one of three that the ISP uses is the 63.215.26.213.
I don't know where the others came from

Being new to CL.....how do I edit this file and what should go in here
Thanks
Now we are getting somewhere ,
Do you have those 209.244.0.X IP address anywhere in your network ? , are they left over from a previous install or configuration ?
Check the file /etc/hosts to see if you have these entries , if so and they are no longer used the remove them from the file.


Also check in Network Configuration Tool --> DNS Tab to see if those IP addresses isn't entered in the Primary and Secondary DNS boxes , if they are then remove them.

The only entry that should be in the Primary DNS is your ISP's DNS of 63.215.26.213
Also while you are there , enter your machine host name in the Host Name box.
( it it localdomain ? )

Then open up kppp --> Configure --> Accounts --> <ISP Name> --> Edit --> DNS Tab
And then check your entries
Domain Name < your machine name >
Configuration Manual
DNS IP address 63.215.26.213

The files that are involved are
/etc/hosts
/etc/hosts.conf
/etc/resolve.conf
/etc/ppp/resolv.conf

The file /etc/hosts.conf should only have in it the entries :
order, hosts,bind

All these files are plain text files so all you need to do is open them up in a text editor like gedit ( in /root mode ) and then edit and save the files.

Post back the contents of /etc/hosts file if things don't work our so that I can see what's in your network setup.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KPPP Dialer in FreeBSD Live CD?? unixfreak *BSD 6 09-11-2004 03:58 PM
Kppp dialer under Madrake 9.1 mobassir Linux - Software 2 10-07-2003 05:57 AM
KDE Kppp Dialer mdss Linux - Newbie 2 11-30-2002 07:04 AM
kppp dialer woes Mr Bit Linux - Newbie 1 11-26-2002 12:05 PM
Kppp dialer Vs. Everything else! briancof Linux - Newbie 4 12-17-2001 01:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 05:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration