LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 02-10-2005, 02:23 PM   #1
screwage
LQ Newbie
 
Registered: Jan 2005
Posts: 21

Rep: Reputation: 15
Fc2->fc3


I finally got the upgrade FC1->FC2 to work, and was moving onto FC2->FC3 and ran into this problem:

[root@localhost root]# yum list updates
Traceback (most recent call last):
File "/usr/bin/yum", line 6, in ?
import yummain
File "/usr/share/yum-cli/yummain.py", line 23, in ?
import yum
ImportError: No module named yum
[root@localhost root]#

I'm following the instructions at http://www.brandonhutchinson.com/Upg..._with_yum.html

[root@localhost root]# rpm -Uvh fedora-release-3-8.i386.rpm yum-2.1.11-3.noarch.rpm

Preparing... ########################################### [100%]
file /etc/sysconfig/rhn/sources from install of fedora-release-3-8 conflicts with file from package up2date-4.1.21-3
[root@localhost root]#
[root@localhost root]# rpm -Uvh --force fedora-release-3-8.i386.rpm yum-2.1.11-3.noarch.rpm
Preparing... ########################################### [100%]
1:yum warning: /etc/yum.conf created as /etc/yum.conf.rpmnew
########################################### [ 50%]
2:fedora-release ########################################### [100%]
[root@localhost root]#

Anyway, I installed the new RPMs of fedora-release-3-8.i386.rpm and yum-2.1.11-3.noarch.rpm, and as that site says may happen, I had to force the install due to an up2date conflict. Any ideas?
 
Old 02-12-2005, 10:28 AM   #2
hob
Senior Member
 
Registered: Mar 2004
Location: Wales, UK
Distribution: Debian, Ubuntu
Posts: 1,075

Rep: Reputation: 45
As the page you linked to says, this isn't guaranteed to work as well as the official upgrade option (which isn't guaranteed either).

If you can get a working version of yum then it can probably sort things out by downloading and installing whatever is required. The man page for yum advises that you are better using "yum upgrade" rather than "yum update" for system upgrades.
 
Old 02-13-2005, 02:37 AM   #3
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,084

Rep: Reputation: 54
Re: Fc2->fc3

Quote:
I finally got the upgrade FC1->FC2 to work,
No. It only seemed to work. The result was not a good upgrade. Look at the error you got.
Quote:
[root@localhost root]# rpm -Uvh fedora-release-3-8.i386.rpm yum-2.1.11-3.noarch.rpm

Preparing... ########################################### [100%]
file /etc/sysconfig/rhn/sources from install of fedora-release-3-8 conflicts with file from package up2date-4.1.21-3
up2date-4.1.21-3 is not an FC2 package. FC2 includes up2date-4.3.19-1.

Quote:
[root@localhost root]# rpm -Uvh --force
With --force you only make it worse.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FC1 vs FC2 vc FC3 etc... wizhuff Fedora 4 08-26-2005 12:04 PM
FC2 to FC3 maximus1u2 Fedora 1 03-17-2005 08:58 AM
FC2 or FC3 work on anything? Brian Knoblauch Linux - Hardware 8 02-09-2005 08:16 AM
How to yum my way from FC2 - FC3 pembo13 Fedora 7 11-27-2004 08:01 AM
FC3 looks like FC2 babyphil Fedora 2 11-18-2004 06:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 05:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration