LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 11-08-2004, 01:51 AM   #1
unsem
LQ Newbie
 
Registered: Nov 2004
Location: Ankara
Distribution: Fedore Core 2
Posts: 2

Rep: Reputation: 0
FC2 can not start alone (in non-interactive mode)


Greetings,

I have installed Fedora Core 2 on a new pc. Installation was smooth. At the first boot, I thought that machine can not boot since there was no response after message 'Grub loading stage 2...'. After scratching everything for two days, I learnt that I had to be patient for 20 seconds. :(
Anyhow, now fedora can boot but here's another problem.

Fedora can not start alone.

After interactive menu prompt, if I let the system go on alone, the screen switches to 1024x768 resolution (monitor says that) and hangs up there. No mouse cursor, hdd activity, ctrl+alt+del etc.

On the other hand, if I enter to interactive mode, by pressing 'i', GUI starts (I don't know if that gui is part of X) and asks questions of interacitve mode. I just let it continue and all the [OK]'s and system works fine.

I need this machine as a server and it should be booting itself.

What should I do to make the machine start alone?

How can I see what the machine is trying to do when it hangs up?

Any help is appreciated.

Thanks,

Unsem
 
Old 11-08-2004, 01:57 AM   #2
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
Check your /etc/grub and remove any reference to 'rhgb'.
 
Old 11-09-2004, 12:59 AM   #3
unsem
LQ Newbie
 
Registered: Nov 2004
Location: Ankara
Distribution: Fedore Core 2
Posts: 2

Original Poster
Rep: Reputation: 0
Removing 'rhgb' from grub.config worked. System comes up with no X. Thanks.

But now, when I 'startx' the same thing happens. System hangs up and needs hard reset.

When I 'xdm', everything seems ok.

Is this a bug or what? Shall I report it?

Good day,

Unsem
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fc2-gnome : Applications dont start / very slow to start nox104 Linux - Software 0 08-18-2004 08:53 PM
getting rid of interactive mode in MDK 10 howto? Lleb_KCir Linux - Software 10 04-21-2004 02:58 PM
permanant interactive mode stand Linux - General 1 04-19-2004 05:21 AM
not able to get into interactive mode when linux is booting up? anekkan Linux - Newbie 1 09-06-2003 10:06 PM
SuSE 8.1 - Is there an interactive mode during load? gracecourt Linux - Newbie 3 12-24-2002 10:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 02:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration