LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
LinkBack Search this Thread
Old 06-28-2012, 03:30 AM   #1
jot
LQ Newbie
 
Registered: Aug 2004
Location: Singapore
Distribution: Ubuntu and Fedora
Posts: 25

Rep: Reputation: 0
Question FC17 gnome 3: problem with typing same character repeatedly


kernel-PAE-3.4.3-1.fc17.i686
gnome-shell-3.4.1-5.fc17.i686
on DELL Dimension E520


Hi,

What can I try to solve the following keyboard problem:

Am able to type anything as fast as I want - as long as I do not hit the same key twice.

Eg. if I try to type "www", the 2nd and following "w" would be blocked and I would just hear a warn tone every time I hit 'w'. However, if I type very slowly, about half a second between every stroke, I face no problems. This is especially annoying for the BACKSPACE key, where I cannot quickly delete, let's say, 3 characters.

Continuously holding a key correctly starts the automatic repetition - no problem there.

Hardware setup:
- standard PS2 keyboard
- PS2 mouse
- PS2-based KVM switch
- combined PS2-to-USB adapter for keyboard and mouse

Further facts:
- no typing problem outside of the GUI (if I switch to text terminal)
- no typing problem on an older Linux box attached to same KVM switch
- no problem with the mouse
- no typing problem on older Linux on same machine previously

Any hints welcome! Thanks
 
Old 06-28-2012, 10:35 PM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
Go to System Settings, Universal Access, and make sure 'bounce keys' is turned off.
 
Old 06-28-2012, 10:50 PM   #3
jot
LQ Newbie
 
Registered: Aug 2004
Location: Singapore
Distribution: Ubuntu and Fedora
Posts: 25

Original Poster
Rep: Reputation: 0
Lightbulb solved!

Hi macemoneta

Thank you so much - that was it! Am not sure why it was enabled, must have been me when I tested each and every feature of the interface.

Though, I keep wondering: in what situation would someone want this setting to be enabled?

Cheers!
Jot
 
Old 06-28-2012, 10:57 PM   #4
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
The universal access settings are to assist those that are physically challenged in some way. Some folks have illnesses like Parkinson's disease which cause tremors, making typing difficult.
 
Old 06-28-2012, 11:04 PM   #5
jot
LQ Newbie
 
Registered: Aug 2004
Location: Singapore
Distribution: Ubuntu and Fedora
Posts: 25

Original Poster
Rep: Reputation: 0
Oh, I see. Yes, that makes sense.
 
  


Reply

Tags
fedora 17, gnome 3, keyboard, typing


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Evolution lost folders/emails after upgrading from FC14+GNOME to FC17+KDE kaza Linux - Software 1 06-11-2012 03:06 PM
[SOLVED] HOWTO: enter "special character" while typing SaintDanBert Linux - Software 3 01-26-2011 12:36 PM
Typing in Japanese in GNOME Micro420 Linux - General 1 07-16-2008 11:34 AM
Wrong character when typing rutayia Linux - Laptop and Netbook 1 05-28-2006 10:20 PM
gnome-terminal and character encoding problem guillaume31 Linux - Software 0 03-13-2006 09:09 AM


All times are GMT -5. The time now is 08:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration