LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 05-09-2005, 07:41 AM   #1
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,677

Rep: Reputation: 55
Fail to start KPPP and network


Hi folks,

Fedora Core 3

After playing around to setup KPPP following functions failed to response

Remark:
Login as "USER" either on KDE destop OR on Gnome desktop

KStart -> Internet -> KPPP
KStart -> System Settings -> Network
both failed to start allowing me to keyin password

I must login as "root" to start
KStart -> Internet -> KPPP
KStart -> System Settings -> Network

Kindly advise where can I rectify these problems

TIA

B.R.
satimis
 
Old 05-10-2005, 02:33 AM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
What is your modem?

The kppp Handbook
Dial-up Networking Configuration Using KDE's Kppp
 
Old 05-10-2005, 11:33 AM   #3
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,677

Original Poster
Rep: Reputation: 55
Hi fancypiper,

Tks for your links

Quote:
What is your modem?
External modem. The modem and its cable have no problem. I tested them on a FC2 box which also has an external modem of same model. I exchanged them. Both modems worked on FC2 without problem.

I was trying to solve the problem of unable to dial ISP and came to this dead knot. Before I can start KPPP as USER on KDE desktop

KStart -> Internet -> KPPP
popup for password. After keying password, KPPP login screen started. I can query modem but failed to dail. I tried more than 3 days without a solution.

Now even
KStart -> System Settings -> Network
failed to popup request for password

B.R.
satimis
 
Old 05-10-2005, 10:13 PM   #4
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
There are 2 types of external, usb, which can be winmodems and require drivers, others are serial port modems.

External Modems

Serial port connect to (Windows com 1) /dev/ttyS0 and (Windows com 2) /dev/ttyS1. The symbolic link /dev/modem should point to which port it is attached to.

You should have a program called wvdial installed, I think.

su - to become root and try this command:

wvdialconf /etc/wvdial.conf

Is the modem found and configured? Examine the file /etc/wvdial.conf and put the information for your isp in that file and save. Then the command, as root,

wvdial

should connect you if your /etc/resolv.conf has the proper nameserver numbers in it.

# Red Hat & Fedora links
FedoraNEWS.ORG
The Fedora HOWTO explains the different software managers.
Maximum RPM
rpmfind
Easier software management: apt4rpm
ATrpms - installation instructions
Fedora Core 1 Tips and Tricks
Fedora Core 2 Tips and Tricks
Fedora Core 3 Tips and Tricks
apt, yum, and up2date repository settings (configuration files) for Fedora Core 3
# Handling NTFS
New Technology FileSystem (NTFS) HOWTOs
Linux NTFS project
 
Old 05-11-2005, 03:07 AM   #5
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,677

Original Poster
Rep: Reputation: 55
Hi fancypiper,

Tks for your advice and URLs

This is not my first time to setup KPPP. I did it several times before but never coming to this deadknot.

The external modem is connected to Com1. This PC has another mobile HD running M$WinXP. I just tested the modem on M$WinXP. It worked without problem, dialing and connected to ISP finally.

On Fedora Core 3
KPPP started, modem initialized but failing to dial. The login screen was just hanging there without dialing and finally closed automatically.

Quote:
You should have a program called wvdial installed, I think.
# rpm -qa | grep wvdial
wvdial-1.54.0-3
# rpm -qa | grep libwvstreams
libwvstreams-3.75.0-2

Quote:
su - to become root and try this command:

wvdialconf /etc/wvdial.conf

Is the modem found and configured?
# wvdialconf /etc/wvdial.conf
Code:
Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 -- OK
ttyS0<*1>: ATQ0 V1 E1 Z -- OK
ttyS0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyS0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyS0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyS0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyS0<*1>: Modem Identifier: ATI -- 56000
ttyS0<*1>: Speed 4800: AT -- OK
ttyS0<*1>: Speed 9600: AT -- OK
ttyS0<*1>: Speed 19200: AT -- OK
ttyS0<*1>: Speed 38400: AT -- OK
ttyS0<*1>: Speed 57600: AT -- OK
ttyS0<*1>: Speed 115200: AT -- OK
ttyS0<*1>: Max speed is 115200; that should be safe.
ttyS0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyS1<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS1<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS1<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Port Scan<*1>: S2   S3   S4   S5   S6   S7   S8   S9
Port Scan<*1>: S10  S11  S12  S13  S14  S15  S16  S17
Port Scan<*1>: S18  S19  S20  S21  S22  S23  S24  S25
Port Scan<*1>: S26  S27  S28  S29  S30  S31  S32  S33
Port Scan<*1>: S34  S35  S36  S37  S38  S39  S40  S41
Port Scan<*1>: S42  S43  S44  S45  S46  S47  S48  S49
Port Scan<*1>: S50  S51  S52  S53  S54  S55  S56  S57
Port Scan<*1>: S58  S59  S60  S61  S62  S63  S64  S65
Port Scan<*1>: S66  S67  S68  S69  S70  S71  S72  S73
Port Scan<*1>: S74  S75

Found a modem on /dev/ttyS0.
Modem configuration written to /etc/wvdial.conf.
ttyS0<Info>: Speed 115200; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
Quote:
Examine the file /etc/wvdial.conf and put the information for your isp in that file and save. Then the command, as root,

wvdial
cat /etc/wvdial.conf
Code:
[Dialer Defaults]
Modem = /dev/ttyS0
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
; Phone = 12345678
; Username = xxy
; Password = abc
# wvdial
Code:
--> WvDial: Internet dialer version 1.54.0
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Configuration does not specify a valid phone number.
--> Configuration does not specify a valid login name.
--> Configuration does not specify a valid password.
# cat /etc/resolv.conf
Code:
nameserver 202.123.77.197
nameserver 202.123.77.213
They are IP address of broadband.

I tried stoping the broadband and comment out both of the them. But situation remained unchagned unable to dail. The lights of modem were blinking. ISP phone number, login and password rechecked and found correct.

B.R.
satimis
 
Old 05-11-2005, 10:38 AM   #6
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
In your /etc/wvdial.conf, remove the semicolon and put the correct username, password and telephone number needed for your ISP account
Quote:
Originally posted by satimis



Code:
; Phone = 12345678
; Username = xxy
; Password = abc
The semicolons in /etc/wvdial.conf may be your problem.

Once that is corrected and the correct dial up numbers for your ISPs nameservers are in /etc/resolv.conf, then the command wvdial as root should connect.

Make a symbolic link to point to /dev/ttyS0

ln -s /dev/ttyS0 /dev/modem

Then the redhat-config-network utility in the Gnome gui should set it up so the user can bring dialup up and down.

Last edited by fancypiper; 05-11-2005 at 10:40 AM.
 
Old 05-11-2005, 12:32 PM   #7
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,677

Original Poster
Rep: Reputation: 55
Hi fancypiper,

Your advice worked for me. Tks

Steps performed as follows;
Quote:
In your /etc/wvdial.conf, remove the semicolon......
Removed all semicolons.

# cat /etc/wvdial.conf
Code:
[Dialer Defaults]
Modem = /dev/ttyS0
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
Phone = 12345678
Username = xxy
Password = abc
# wvdial
Code:
--> WvDial: Internet dialer version 1.54.0
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT30018600
--> Waiting for carrier.
ATDT30018600
CONNECT 115200
--> Carrier detected.  Waiting for prompt.
CC CISCO-TPC-C3
User Access Verification
Username:
--> Looks like a login prompt.
--> Sending: xyz
xyz
Password:
--> Looks like a password prompt.
--> Sending: (password)
~Entering PPP mode.}-}*Async interface address is unnumbered (FastEthernet0/0/0)}-}*Your IP address is 219.76.20.aaa. MTU is 1500 bya}7~~tes}-}*}-}*[14][0e]~~[7f]}#@!}!e} }4}"}&} }*} } }%}&};[06][1c]5}'}"}(}"[1b]L~
--> PPP negotiation detected.
--> Starting pppd at Thu May 12 07:50:50 2005
--> pid of pppd: 4680
--> Using interface ppp0
--> local  IP address 219.76.20.aaa
--> remote IP address 218.102.30.bbb
--> primary   DNS address 218.102.32.xxx
--> secondary DNS address 203.198.23.yyy
ISP connected

# cat /etc/resolv.conf
Code:
nameserver 202.123.77.xxx
nameserver 202.123.77.yyy
still DNS of the broadband displayed. But it has been disconnected already

<Ctrl> + c
Code:
Caught signal #2!  Attempting to exit gracefully...
^F--> Terminating on signal 15.
--> Disconnecting at Thu May 12 07:52:29 2005
disconnected ISP

Quote:
ln -s /dev/ttyS0 /dev/modem
done. Now
# ls -al /dev/modem
lrwxrwxrwx 1 root root 10 May 12 07:55 /dev/modem -> /dev/ttyS0

Logout and relogin

Gnome Desktop
Applications -> System Tools -> Red Hat Network
and
Applications -> System Settings -> Red Hat Network Configuration
No response

Could not discover "redhat-config-network utility"

Tks

B.R.
satimis
 
Old 05-11-2005, 12:48 PM   #8
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
At least you can now connect through a root x terminal.

The networking commands may not be installed (you can pick and choose with the expert install, sometimes the default doesn't install things I expect to have) and there may have been some initial bugs in the install, so I suggest that you now:

Check the Fedora site and see if there is an erratta or change in their networking stuff (I still use core 1).

Check out the Fedora Core 3 Tips and Tricks and make sure you are fully updated and how they now do their network stuff. FC1 had an "internet connection wizard" in something called "start here" with the nautilus file manager.

1. Configure your software managers and some simple commands will update, install software with dependency resolution, etc. Personally, I like a combination of up2date and yum the best as they seem to have more stuff available and they just out performe the apt-get.

Good luck and now enjoy some new and awesome power.

Last edited by fancypiper; 05-11-2005 at 12:56 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fail to start apache with ssl kaon Linux - Software 2 07-07-2005 01:05 PM
kde fail to start eddy98 SUSE / openSUSE 1 03-07-2005 03:15 AM
Fail to start Gnome satimis Fedora 1 07-30-2004 11:30 AM
Can I gett KPPP to start when I start a browser on a network machine? duffboygrim Linux - Networking 0 03-25-2004 05:49 PM
Fail to start KDE satimis *BSD 2 02-26-2004 09:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 09:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration