-   Fedora (
-   -   F18 gnome3 boot = monitor sleeps (triboot, nvidia, res. out of range) (

diptenkrom 10-17-2012 12:42 PM

F18 gnome3 boot = monitor sleeps (triboot, nvidia, res. out of range)
First a little background. i have a gateway GM5472 desktop. it came with vista on it. i have added an nvidia 7800gt PCI-E graphics card. have run many different versions of linux, crunch, ubuntu, older fedora, tested arch and elementary luna. all of the above worked. i have 3 hdd's in the machine. Primarily a 500gb with win xp/7 both loaded, a 250gb data drive, and a 100gb drive with fedora 18 G3 installed (i have to manually select this HDD to boot F18). i have a KVM switch, and have tried 2 of the same USB style one and an older ps/2. the ps/2 didn't support high enough resolutions, according to the installer. and the USB ones did. i installed F18 with it hooked to the KVM, took it to a different location and did some playing, tweaking, updating. and it all worked. had some issue with the newer KVM and both windows installs.

I did some troubleshooting and figured out that the resolutions were off, and i had a bad DVI-VGA adapter. with new DVI-VGA (evga brand) adapter i successfully got all 3 operating systems to boot and work at one location, but when i set it back up at home, i only can get windows xp/7 to come up. i also tested stuff direct to dvi and vga monitors to try to narrow down what was going on just trying to eliminate what the problem was.

The monitor says no signal when i boot fedora, which is what it originally did with all 3 OSes. the cables and switches are the same thing in both locations, the only difference i can determine at this point is the default res on monitor (20") at the other location is 1600x1024 (i think) and the monitor (19") at home is 1440x900.

i searched and can't find anything that works. i just want to be able to get into it someway to be able to tell it to use "1440x900_60.00" but i cant get anything. i do not want to reinstall, because the system wasn't very stable until i had to remove packagekit and run updates, and a few other settings. it was just time consuming.

i also have another desktop connected to the same KVM running F17 LXDE spin. and it works, just with a low res because of unichrome graphics that suck.

BTW i typed this from win7 on the same computer in question. no probs in windows now.

GlennsPref 10-17-2012 06:17 PM


just want to be able to get into it someway to be able to tell it to use "1440x900_60.00" but i cant get
I'm guessing that this happends before X is loaded(?), when the kernel boots from grub.

There are some commands you can insert on the boot cli.

If you get a grub menu....

F2 or F3, to stop the timer and enter the boot cli

You can ignore the options by pressing ESC, will bring you back to the cli.
the commands are "space separated", append the vga=...

        640x480 800x600 1024x768 1280x1024 1600x1200 Ask user at boot
8 bits        vga=769 vga=771 vga=773  vga=775  vga=796  vga=ask
16 bits vga=785 vga=788 vga=791  vga=794  vga=798  vga=ask
32 bits vga=786 vga=789 vga=792  vga=795  vga=799  vga=ask

Generally I use vga=794, my screen is 1920x1080. (I'm satisfied with a screen, not perfect graphics at boot)
remove "splash quiet" so you can see the text as the kernel loads.

If this is an X problem you might try the key combinations to reduce or increase the res...

ctrl+alt++ #(num-pad +) increase res (i think it will cycle all the way through)

ctrl+alt+- #(num-pad -) decrease the x resolution.

remember over driving your monitor may damage it. (let the smoke out)

Cheers Glenn

TobiSGD 10-17-2012 08:27 PM

This behavior most likely is caused by the kernel mode setting in the video drivers. The vga= option is deprecated for those drivers, use the video= option, like


diptenkrom 10-18-2012 10:12 AM

more info.

i have tried removing rhgb and quiet from the boot and i get about 3-5 secs of scrolling text, too fast to discern what is going on, and then it goes blank and monitor goes to sleep. vga= and video= did not seem to have an effect. if i do not remove rhgb it goes dead before the fedora "orb" shows up. also <ctrl> <alt> +/- did not seem to do anything.

GlennsPref 10-18-2012 11:22 PM

Hi, could be a kernel driver thing, agp, agpgart,

But if those other distros work, You might need to reinstall the fedora kernel(the entire OS, in your case).

You may have a corrupt fedora cd iso, md5sum work ok?

With out seeing it, I'm at a loss, because you get text scrolling, that stage of the boot process works, Then boot process fails for some reason to hand over, or take controll of the graphics.

caps-lock, Num-lock LEDs change when black screen?

Regards Glenn

diptenkrom 10-19-2012 02:23 PM

well, i can't get the live boot to come up either... same thing, gets to a point and then the screen goes dead. i hate this damn thing. i have never had this much trouble with any video issue. usually i have to get the right resolution to work, but i have graphics. this time nothing.

as for the ISO i have dl'ed it 3 times, used it from dvd, and from usb.

EDIT: i have also tried to boot the fedora 17 XFCE spin disc i have and it did the same thing, monitor shuts off...
tried removing the rhgb and quiet flags and also tried video=1024x786 and vga=794 (separately of course) to no avail.
also loaded the dics that came with my KVM switch to see if there is a way to hard code the resolution it gives the vidcard, and there is not.

diptenkrom 10-19-2012 05:46 PM

i reluctantly pulled out my 7800gt vid card, and plugged the vga to the internal 6150se on the mobo. this got my fedora build to boot, in 1024x786. now i have to try to get higher res back, but the performance of the onboard is not as good. i may try to find a newer vid card with native vga on it. that is the only other thing i can think to do at this point. maybe an 8400gs. they are not that good but stable and cheap...

i did this because i could not get any live discs to work that were from the last 2 years except aptosid, and i dont really like debian sid as much, plus i am trying to learn more fedora as i have been in the debian/ubuntu world for a while.

THANKS for all the help!!!

GlennsPref 10-19-2012 07:02 PM

I remember using a ps2 kvm in 2004.

I had to setup the os's without the kvm, and then patch it together.

this kvm did not allow the system to pickup the resolution (EDID?) chart from the monitor.

The 7800 has native vga, as default.

I've fixed a few M$Win machines with onboard graphics chips, but never owned one myself.

I found it difficult to disable completely the onboard chip and it's memory reservations.

Bios update?

I wonder if the kernel can accept a command to use a particular pci device as the graphics port. pci=

try pci=nobios and pci=bios



Force the use of the PCI BIOS by not accessing the hardware directly. This means that the kernel should trust the BIOS, which is not the standard thing to do (as BIOSes are known to lie more than they are known to be valid.) Use this only if your machine has a non-standard PCI host bridge and the normal boot method is not working properly.

Do not use the PCI BIOS, but access the hardware directly instead. This is the default method of probing for PCI devices in all kernels after 2.6.13.

All times are GMT -5. The time now is 01:18 AM.