-   Fedora (
-   -   f11 x86_64 kernel boot problem (

drang007 08-28-2009 09:45 AM

f11 x86_64 kernel boot problem
Hello im new to linux on my 4th day. I got into it because my mothers laptop crashed and the win eom restore didnt work so i loaded on her machine. I was impressed so i set up a multi boot on my machine. making multiple partitions and using easyBcd main os 125g vista 30g debian 30g mandriva 30g suse and 30g f11. all linuxOS's with root on there own partition and no change to mbr. f11 worked the best except for install to partitions forcing an install to ext4 and boot to ext3 so i just made a 200 mb partition in win and used it /boot and on the 30g /

It worked with my new machine well except for the Nvidia card which i compiled after reading many articles in init3

it worked great now. got the 3d desktop working customized the desktop, and software ect. and booted many times

i then went to win and set up the rest of my logical drive partitions 200g linux share and 400g media.not touching any other drives

when i logged back on fed11 now my main os - same set up just top on eBcd list
the kernel locks up with 2 lines that i can see r8169 eth0 linkup
however boots fine im on it now. just not the same desktop color but icons widgets all the same.

i alwaays loaded on the 217.2.16 untill i made logical drives also my last session in 2.16 had some updates

im running a core 2 quad q8200 2.33ghz
nvidia g100
7gb ram
750g platter hd

forrestt 08-28-2009 09:55 AM

First of all, welcome to LQ and the wonderful world that is Linux.

I'm just taking a wild guess here, as you have described quite a bit, but not necessarily the pertinent pieces (no worries, we'll ask if we need them). When you set up your nvidia card, did you set it up with the rpmfusion repo or did you compile it? If you compiled it, then you will need to recompile it for the new kernel and every new kernel you get (the come out fairly often). If you installed it from the rpmfusion repo, then this is not likely the problem and we need some more info. If you didn't install it from rpmfusion, then you may prefer to do so. It can be done by installing the rpm's listed at their site and then running the command:


yum -y install kmod-nvidia
Let us know if this fixes things or not,


drang007 08-28-2009 10:16 AM

I compiled it using binutils and gcc in init 3 on the 2.16 system. this driver was released just recently and is the only one that i have found to work a problem most ppl on linux have with this card. from tty2 i think
i booted at least 5 time without problem after compiling

forrestt 08-28-2009 10:22 AM

I understand that. All five of my computers have nvidia cards. However, the driver is specific to the version of the kernel that it was compiled for. Every time a new kernel comes out, you have to do what you did to get it working again OR you can install it from the rpmfusion repo and yum will update it automatically every time the kernel gets updated. I'm not saying that the rpm method is what you want to do (it IS what I prefer to do), but you at least need to address the issue that the driver needs to be updated to match your new kernel.



p.s. this is the reason it is working for one kernel and not the other.

drang007 08-28-2009 10:30 AM

i installed the rpms and ran the yum line and it worked perfect boots very fast now thank you

All times are GMT -5. The time now is 06:15 AM.