-   Fedora (
-   -   eth0 device not found (

starkhorn 09-04-2007 10:25 PM

eth0 device not found

I'm a newbie to Linux and I'm having a bit of trouble installing Fedora 5 on a desktop PC with a built-in ethernet port. I initially had quite a few problems as the PC had a SATA drive and I had to use the option linux all-generic-ide noapic nolapic" in order to have my hard disk detected by the Fedora installer.

Now I've completed the installation but don't see eth0 when I do a ifconfig -a. What is sit0 ?

Now lspci and lspci -n seems to show a silicion Ethernet Adapter as below and my /etc/modprobe.conf has an entry for eth0 with driver sis190 and lsmod has an entry for sis190.

A dmesg | grep eth doesn't return anything.
Nearly doesn modprobe e1000 or e100 or eth0 or sis190.

Any ideas? See below output from my system of the above commands.


# ifconfig -a

lo: Disabled Privacy Extensions
IPv6 over IPv4 tunneling driver
lo        Link encap:Local Loopback 
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

sit0      Link encap:IPv6-in-IPv4 
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

# lspci

00:00.0 Host bridge: Silicon Integrated Systems [SiS] Unknown device 0671
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] Unknown device 0968 (rev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter (rev 02)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] Unknown device 1183 (rev 03)
00:06.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:07.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Unknown device 7502
00:1f.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] Unknown device 6351 (rev 10)

# lspci -n
00:00.0 0600: 1039:0671
00:01.0 0604: 1039:0003
00:02.0 0601: 1039:0968 (rev 01)
00:02.5 0101: 1039:5513 (rev 01)
00:03.0 0c03: 1039:7001 (rev 0f)
00:03.1 0c03: 1039:7001 (rev 0f)
00:03.3 0c03: 1039:7002
00:04.0 0200: 1039:0191 (rev 02)
00:05.0 0101: 1039:1183 (rev 03)
00:06.0 0604: 1039:000a
00:07.0 0604: 1039:000a
00:0f.0 0403: 1039:7502
00:1f.0 0604: 1039:0004
01:00.0 0300: 1039:6351 (rev 10)

# lsmod

Module                  Size  Used by
ipv6                  246433  12
video                  18885  0
button                10577  0
battery                13253  0
ac                      8901  0
lp                    16265  0
parport_pc            29413  1
parport                38281  2 lp,parport_pc
floppy                61829  0
nvram                  12617  0
ehci_hcd              33229  0
ohci_hcd              23901  0
snd_hda_intel          21329  0
snd_hda_codec        116033  1 snd_hda_intel
snd_seq_dummy          7749  0
snd_seq_oss            33345  0
snd_seq_midi_event    11073  1 snd_seq_oss
snd_seq                52401  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device        12877  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            49105  0
snd_mixer_oss          20417  1 snd_pcm_oss
snd_pcm                81093  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
sis190                24005  0
mii                    9281  1 sis190
snd_timer              26693  2 snd_seq,snd_pcm
snd                    55109  9 snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              13345  1 snd
snd_page_alloc        14537  2 snd_hda_intel,snd_pcm
dm_snapshot            19949  0
dm_zero                6081  0
dm_mirror              23825  0
dm_mod                54233  6 dm_snapshot,dm_zero,dm_mirror
ext3                  121417  2
jbd                    56917  1 ext3

# cat /etc/modprobe.conf

alias eth0 sis190
alias snd-card-0 snd-hda-intel
options snd-card-0 index=0
options snd-hda-intel index=0
remove snd-hda-intel { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-hda-intel

Pearlseattle 09-05-2007 05:51 AM

What do you get from dmesg after unloading "modprobe -r sis190" and reloading it "modprobe sis190"?

I get a "sit" when I start VMware which generates bridges and fake network cards, but I have no clue what it is exactly.
I had to create eth0/1/2 manually after installing the network card & kernel modules.
Do you get something back when you do...

ls /etc | grep -i net
If yes, try to create eth0 (create as well 1 and 2, just to be sure and eventually delete them afterwards if they're not used) manually, reboot and see what happens:

cd /etc
ln -s net net.eth0

Sorry, this is all I know.

Pearlseattle 09-05-2007 05:54 AM

Sorry: the path wasn't "/etc" but "/etc/init.d"
And after that try starting eth0/1/2 with "/etc/init.d/net.eth0 start" and see what kind of messages you get... .

starkhorn 09-05-2007 11:39 PM


Originally Posted by Pearlseattle (Post 2881826)
What do you get from dmesg after unloading "modprobe -r sis190" and reloading it "modprobe sis190"?

I get the below message. Hmmm, can not find ISA bridge....any ideas on that one?


sis190 Gigabit Ethernet driver 1.2 loaded.
PCI: Enabling device 0000:00:04.0 (0000 -> 0003)
ACPI: PCI Interrupt 0000:00:04.0[A] -> Link [LNKD] -> GSI 3 (level, low) -> IRQ 3
PCI: Setting latency timer of device 0000:00:04.0 to 64
0000:00:04.0: Read MAC address from APC.
0000:00:04.0: Can not find ISA bridge.
ACPI: PCI interrupt for device 0000:00:04.0 disabled
sis190: probe of 0000:00:04.0 failed with error -5

Pearlseattle 09-06-2007 03:05 AM

Mmmhhh..., by "googling" I saw that this guy had exactly the same problem. His solution: use a different network card.:)
This guy describes the following change in the source file sis900.c of the linux kernel:

change line 263 from
if ((isa_bridge = pci_find_device(0x1039, 0x0008, isa_bridge)) == NULL
if ((isa_bridge = pci_find_device(0x1039, 0x0018, isa_bridge)) == NULL
Here there is again one more possible solution, again by changing the kernel source file.
Have a look at the details of the solution, as it might be that you'll need to set a different code for your own card:study:
You have to experiment a little bit with those variants... .

starkhorn 09-18-2007 04:42 PM

I tried the 2nd solution of changing the kernel source code but I got the below error which I can't understand.

sis190: version magic '2.6.18-1.2798.fc6 SMP mod_unload 686 REGPARM 4KSTACKS gcc-4.1' should be '2.6.18-1.2798.fc6 SMP mod_unload 586 REGPARM 4KSTACKS gcc-4.1'
FATAL: Error inserting sis190 (/lib/modules/2.6.18-1.2798.fc6/kernel/drivers/net/sis190.ko): Invalid module format

It looks to me that all my problems stem from not having the proper linux drivers for the ASUS P5S-MX SE motherboard. It says it's a SIS671FX chipset but the CD that I got only has drivers for Windows.

Any ideas on how/where I can get the proper drivers for this motherboard....I've found nothing on the ASUS website.

starkhorn 09-18-2007 05:28 PM

Well I've made some progress, I've found how the SIS180 drivers which I can use during the Fedora install by using "linux updates dd". However my PC doesn't have a floppy disk drive.....arrgghhh!

Any ideas how during a linux installation I can get the installer to look at the sis180.img file on a CD or memory stick

starkhorn 09-18-2007 06:20 PM

I'm getting really confused now.
The .img that is on the CD that came with the motherboard is not openable with the undisker or winimage! A redhat image file can be opened but not the FC6.img.

The CD has:- sis18x_v1-fc6.img which I cannot open with unknown file-system error. When I burn an image onto a removeable disc and do the linux updates dd, it can see the image but it cannot mount...again with unknown filesystem error!

I've tried to find the above .img on the web but google returns empty for sis18x_v1-fc6. I'm beginning to go insane here now..... :)

Pearlseattle 09-20-2007 05:10 AM

And what happens if you try to mount the image without "dd"ing it to the floppy?
mount -v -o loop,ro <yourimage.img> </mnt/yourmountpoint>
If it's not able to mount it, it might be that you don't have the support for that particular filesystem compiled. Try to download a livecd like knoppix, burn it to CD, boot with it and try again to mount it - Knoppix should have all possible filesystems compiled...

Ryptyde 09-20-2007 09:24 PM

Is there any reason that you chose FC5 which is no longer supported instead of perhaps Fedora 7. You could download a Fedora 7 LiveCD or any other live Linux distro and see if your card works from there.

All times are GMT -5. The time now is 06:39 PM.