LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   /etc/fstab & Pb With Windows & Cd (https://www.linuxquestions.org/questions/fedora-35/etc-fstab-and-pb-with-windows-and-cd-273217/)

guilhem_mdg 01-03-2005 03:23 AM

/etc/fstab & Pb With Windows & Cd
 
Hi , (sorry for my bad english, im french)

I have installed FC 3 and my /etc/fstab file is:

# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
LABEL=/home /home ext3 defaults 1 2
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda6 swap swap defaults 0 0
/dev/sda /mnt/cle vfat rw,noauto,user,owner 0 0
/dev/sda1 /mnt/camera vfat rw,noauto,user,owner 0 0
/dev/hda4 /mnt/windows vfat defaults,uid=500 0 0
/dev/hdc /media/cdrecorder auto pamconsole,ro,exec,noauto,managed 0 0
/dev/hdb /media/cdrom auto pamconsole,ro,exec,noauto,managed 0 0
/dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0

What do u think about this ? I cannot write in my vfat partition and cannot mount my cdrom (hdb & hdc)... How can I do ?

Thank a lot for your help !

Guilhem.

fancypiper 01-03-2005 01:43 PM

I think you might have to be root to write on fat32 partitions. You can always mount/dismount devices as root, but additional parameters may be added to /etc/fstab to automount and let users mount.

I can't seem to make my drives work like I want
# Managing drives
LNAG - Accessing my drives
Rute - Device Mounting - Automatic Mounts: fstab

See:
man fstab
info fstab
man mount
info mount

These should show the options you need to add to /etc/fstab to allow the user to mount drives.

Code:

# Duron tinwhistle /etc/fstab file
/dev/hda8      /              ext3            defaults                1 1
/dev/hda1      /boot          ext3            defaults                1 2
none            /dev/pts        devpts          gid=5,mode=620          0 0
/dev/hda9      /home          ext3            defaults                1 2
none            /proc          proc            defaults                0 0
none            /dev/shm        tmpfs          defaults                0 0
/dev/hdb1      /pub            ext3            defaults                1 2
/dev/hda2      swap            swap            defaults                0 0
/dev/cdrom      /mnt/cdrom      udf,iso9660    noauto,owner,ro  0 0
/dev/fd0        /mnt/floppy    auto            noauto,owner      0 0
#/dev/hdc1      /mnt/backup    ext3            defaults                1 2
#/dev/hdc1      /mnt/wav        ext3            defaults                1 2
#/dev/hdc1      /mnt/fat32      vfat            defaults                0 0



All times are GMT -5. The time now is 09:18 PM.