-   Fedora (
-   -   error while loading shared libraries: (

iNvIsIbLe HaNd 09-18-2007 02:03 PM

error while loading shared libraries:
"error while loading shared libraries:"
when i want install RealPlayer this massege appears to me then i write this command " yum install " but he toald me "Metadata file does not match checksum"
how now i installed ""

Lenard 09-18-2007 02:23 PM

Use the power of yum correctly; yum whatprovides

Then do something like; yum install compat-libstdc++-33 compat-libstdc++-33.i386 (if you are 64-bit)

iNvIsIbLe HaNd 09-18-2007 06:50 PM

still not work
[root@localhost iNvIsIbLe]# yum whatprovides
fedora 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 2.4 kB 00:00
Error: requested datatype primary not available
yum install compat-libstdc++-33
Error: requested datatype primary not available
yum install compat-libstdc++-33.i686
Error: requested datatype primary not available
what i do nooooooow plz

Lenard 09-19-2007 05:36 AM

What version of Fedora do you have installed???

iNvIsIbLe HaNd 09-19-2007 12:36 PM

fedora 7 ????????????

Lenard 09-19-2007 01:23 PM

Then you can directly download / install the rpm package, a direct install command run as root;

rpm -Uvh

iNvIsIbLe HaNd 09-19-2007 01:32 PM

thanxxxx very mutch its work noow
thanx to Lenard

bipedal42 08-04-2015 11:00 PM

getting "" to work
to install "" I used Synaptic Package Manager and searched for "libstdc++" by just the name and not the description. The results were files like libstdc++6 and libstdc++5 without the .so.5 or .so.6 at the end. It showed that I already had libstdc++6 installed, so I checked to install libstdc++5, saw that it didn't negatively affect my computer by un-installing anything else, and approved it. After the installation my program instantly found and worked just fine -- Hope this helps.

John VV 08-05-2015 08:52 PM

hi bipedal42

you do know this thread was deceased it was 8 years old
the last post was in September of 2007

and for a very old and very out of date version of Fedora Fedora 7 fedora is now at fedora 22

next this is FEDORA a rpm based OS
it is not a Debian based os and dose not use Ubuntu's synaptic

All times are GMT -5. The time now is 10:47 AM.