LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 07-17-2007, 06:24 AM   #1
the nazgul
LQ Newbie
 
Registered: Jul 2007
Posts: 1

Rep: Reputation: 0
error resolving dependencies !!!


hey, i have fedora 7, when i was updating my packages, it was resolving dependencies, then i got this:

Code:
Missing Dependency: samba-common = 3.0.25-2.fc7 is needed by package samba-client
Missing Dependency: dbus = 1.0.2-4.fc7 is needed by package dbus-x11
Missing Dependency: httpd = 2.2.4-4 is needed by package mod_ssl
Missing Dependency: gnome-panel = 2.18.0-9.fc7 is needed by package gnome-panel-devel
Missing Dependency: httpd = 2.2.4-4 is needed by package httpd-manual
Unable to satisfy dependencies
Package samba-client-3.0.25-2.fc7 needs samba-common = 3.0.25-2.fc7, this is not available.
Package dbus-x11-1.0.2-4.fc7 needs dbus = 1.0.2-4.fc7, this is not available.
Package mod_ssl-2.2.4-4 needs httpd = 2.2.4-4, this is not available.
Package glibc-devel-2.6-3 needs glibc-headers, this is not available.
Package httpd-manual-2.2.4-4 needs httpd = 2.2.4-4, this is not available.
Package gnome-panel-devel-2.18.0-9.fc7 needs gnome-panel = 2.18.0-9.fc7, this is not available.
any help will be appreciated, thank you !
 
Old 07-17-2007, 06:28 AM   #2
theYinYeti
Senior Member
 
Registered: Jul 2004
Location: France
Distribution: Arch Linux
Posts: 1,897

Rep: Reputation: 63
There's probably a repository that you should have and you don't.
I don't know what the Fedora equivalent to Mandriva's Easy-Urpmi is, but you should probably use such a tool.

Yves.
 
Old 07-17-2007, 07:06 PM   #3
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 394

Rep: Reputation: 52
Quote:
Originally Posted by the nazgul
hey, i have fedora 7, when i was updating my packages, it was resolving dependencies, then i got this:

Code:
Missing Dependency: samba-common = 3.0.25-2.fc7 is needed by package samba-client
Missing Dependency: dbus = 1.0.2-4.fc7 is needed by package dbus-x11
Missing Dependency: httpd = 2.2.4-4 is needed by package mod_ssl
Missing Dependency: gnome-panel = 2.18.0-9.fc7 is needed by package gnome-panel-devel
Missing Dependency: httpd = 2.2.4-4 is needed by package httpd-manual
Unable to satisfy dependencies
Package samba-client-3.0.25-2.fc7 needs samba-common = 3.0.25-2.fc7, this is not available.
Package dbus-x11-1.0.2-4.fc7 needs dbus = 1.0.2-4.fc7, this is not available.
Package mod_ssl-2.2.4-4 needs httpd = 2.2.4-4, this is not available.
Package glibc-devel-2.6-3 needs glibc-headers, this is not available.
Package httpd-manual-2.2.4-4 needs httpd = 2.2.4-4, this is not available.
Package gnome-panel-devel-2.18.0-9.fc7 needs gnome-panel = 2.18.0-9.fc7, this is not available.
any help will be appreciated, thank you !
Make sure you have the following repos in /etc/yum.repos.d/

fedora-development.repo
fedora-updates-testing.repo
fedora.repo
fedora-updates.repo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error resolving dependencies mcanallyd General 1 02-11-2007 10:37 PM
Auto Resolving Dependencies John_Emad SUSE / openSUSE 2 06-16-2005 04:39 AM
yast2 resolving dependencies swan2925 SUSE / openSUSE 7 05-09-2005 03:17 AM
Need help resolving some dependencies. obelxi Linux - General 2 03-16-2005 02:57 PM
Resolving dependencies Calcutec Linux - Software 4 09-08-2002 03:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 03:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration