-   Fedora (
-   -   Error Reboot ing FC9 (

usdave 10-03-2008 11:46 AM

Error Reboot ing FC9
First, Im a linux newbie.

I rebooted this morning after a YUM update and GRUB threw an Error 15: file not found on the following line:

kernel /vmlinuz- ro root =/dev/VolGroup00/LogVo100 rhgb quiet

I used the rescue disk to look for the file but could only find it in usr/src/kernels and lib/modules, both without the 'vm-linuz-' prefix.

Prior GRUB command was root (hd0,0) wihch yielded 'Filesystem type is ext2fs, partition type 0x83' if that is of any help.

I tried to rerun YUM but it looks like the website names are not resolving.

Can anyone point me in the right direction on what to do?

billymayday 10-04-2008 04:50 AM

Does grub give the option to boot an earlier kernel? You may need to hit a key when it says it will boot in x seconds.

Once done, post the output of "ls /boot"

usdave 10-04-2008 07:52 AM

Thanks Billymayday.

Yes, grub gave me 3 choices, but I found that /boot was empty, so somehow all the kernels had been purged. (Incidently, the yum log said the kernels had been installed.)

I used the Rescue disk to rescue the existing system with network support, chrooted to the old system, added the DNS info directly to resolv.conf file and was able to get to external sites so that I could rerun yum. I ran 'yum remove kernel' and then 'yum install kernel' to get a new kernel loaded, which it did with an error. Then I used the rescue disk's system upgrade option to build a new loader (updating grub did not work), and was finally able to reboot.

Now, I'm missing network support, but am working to resolve that.

All times are GMT -5. The time now is 06:43 PM.