LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 05-28-2004, 03:05 PM   #1
tcn03u
LQ Newbie
 
Registered: Apr 2004
Location: Nottingham
Distribution: Redhat 9, Fedora Core 2, Mandrake 10, Mandriva 2005-2008, chinhnt2k3
Posts: 26

Rep: Reputation: 15
Error activating XKB configuration + 2 other questions


First question:
I've just upgraded from Redhat Linux 9 to Fedora Core 2. When I logged in, I got this error:
Quote:
Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60700000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
This is the result of the first command:
Quote:
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "gb", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "gb", "", ""
And the second:
Quote:
layouts = [gb]
model = pc105
overrideSettings = false
options = []
My keyboard is Generic 105-key (Intl) PC, United Kingdom
Please tell me how to fix it! Is this really a bug?

Second question:
When I double clicked on a rpm file, I got this message:
Quote:
There is no action associated with "kdelibs-3.2.2-6.i386.rpm".
You can configure GNOME to associate applications with file types. Do you want to associate an application with this file type now?
But I can't choose the program to run this. I can only run it using terminal. Please help me!

Third question:
How can I open a directory in the same window? In Redhat 9 I can deselect "Open actived item in a new window from Edit/Preference->Behavior, but in Fedora Core 2 there is no such thing!

Please help me! Thanks!
 
Old 05-28-2004, 07:41 PM   #2
jonas73
LQ Newbie
 
Registered: Mar 2004
Posts: 6

Rep: Reputation: 0
answer to Q1:
remove the line: Option "XkbRules" "xfree86" from your /etc/X11/xorg.conf (or maybe it's Xfree86.conf, don't remember and don't have fedora access at the moment)
 
Old 06-01-2004, 07:45 PM   #3
tcn03u
LQ Newbie
 
Registered: Apr 2004
Location: Nottingham
Distribution: Redhat 9, Fedora Core 2, Mandrake 10, Mandriva 2005-2008, chinhnt2k3
Posts: 26

Original Poster
Rep: Reputation: 15
Thanks for your answer! But it doesn't work!
Help me please!
 
Old 06-01-2004, 10:02 PM   #4
Linner
Member
 
Registered: May 2004
Distribution: Fedora
Posts: 71

Rep: Reputation: 15
Quote:
Originally posted by tcn03u
Thanks for your answer! But it doesn't work!
Help me please!
it happened to me also, upgraded from fc1 to fc2, i tried all the supposed to be solutions from this problem but still wont worked, the error is embeded on the screen like a logo tsk tsk.

a fresh install is the best solutions (i think, which i did) from these kind of problem like no sound, other softwares is not working etc etc.
 
Old 06-16-2004, 09:07 PM   #5
sabunimb
LQ Newbie
 
Registered: May 2004
Location: New Jersey
Posts: 1

Rep: Reputation: 0
I just used the suggestion to remove the line:
Option "XkbRules" "xfree86"

The only difference was that I commented the line instead of deleting the line.

I restarted X using cntrl+Alt+Backspace

It worked well.
 
Old 06-18-2004, 12:02 PM   #6
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
A1) Change the following (in /etc/X11/XF86Config)
from
Option "XkbRules" "xfree86"
to
Option "XkbRules" "xorg"

A2) No idea

A3) Go to GConf editor (Applications->System Tools->Configuration Editor), drill down apps->nautilus->preferences and tick the 'always_use_browser'.

Last edited by wiraone; 06-18-2004 at 12:08 PM.
 
Old 06-18-2004, 12:12 PM   #7
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
BTW, answers for the above questions can be found in www.fedorafaq.org ..
 
Old 06-19-2004, 07:15 PM   #8
tcn03u
LQ Newbie
 
Registered: Apr 2004
Location: Nottingham
Distribution: Redhat 9, Fedora Core 2, Mandrake 10, Mandriva 2005-2008, chinhnt2k3
Posts: 26

Original Poster
Rep: Reputation: 15
I'm such a newbie! I've already changed to Mandrake and everything works fine! But I still prefer Fedora, I feel something better from it...
 
Old 06-20-2004, 12:00 PM   #9
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
Quote:
Originally posted by tcn03u
I'm such a newbie! I've already changed to Mandrake and everything works fine! But I still prefer Fedora, I feel something better from it...
Most probably because of the GNOME instead of KDE windowing environment? Does Mandrake has GNOME option? Anyway, tried many distributions before but I like RedHat much better .. I've no idea why tho'.
 
Old 06-28-2004, 12:36 AM   #10
charley101
LQ Newbie
 
Registered: Jun 2004
Location: Andorra
Distribution: Debian testing
Posts: 9

Rep: Reputation: 0
I had a similar error message to these, error activating XKB. I fixed it like this,

Remove the line,
"xkbrules" "xfree86"
from /etc/X11/XF86Config-4 Or XF86Config, Im using debian. This line, as I understand it, is included by a setup script when it doesnt need to be.

This didn't fix it straight away, the error stopped after I had 'jiggled' my keyboard layouts in 'Desktop preferences' > 'Keyboard'

I added US, then removed both, then changed back to UK. I dont know why this worked, but it seemed to for me.
Then i logged out and presses ctrl-shift-backspace to restart the x server and the error was gone.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error activating XKB configuration ----- Probably internal X server problem. w0lv3rin3 Linux - Software 13 07-03-2011 03:27 PM
error activating XKB configuration fails Linux - Software 18 07-18-2010 05:41 AM
Error activating XKB configuration Pulka Linux - General 0 08-13-2004 01:42 PM
Error activating XKB message on Desktop on FC2 beachkid Fedora 2 06-18-2004 07:15 AM
error activating xkb configuration in XFree86 4.3 bfay Linux - Software 0 12-29-2003 12:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 12:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration