-   Fedora (
-   -   Editing /etc/fstab in Fedora 8 (

Dailan 06-24-2008 07:33 PM

Editing /etc/fstab in Fedora 8
Evening all! :)

I have something of an embarrassing question regarding editing the filesystem table (/etc/fstab) and I would be grateful for any assistance. I've done a search of the forums and I haven't found an answer that works for me, hence this post.

I have a hard drive partition (created through custom partitioning during installation) set aside for storage and I wish to make it writable for my ordinary user account.

It's been years since I've edited /etc/fstab by hand and it seems my Unix-fu has grown weak with disuse. I cannot get it right, thus my embarrassment.

Herewith the contents of /etc/fstab:


LABEL=/1                /                      ext3    defaults        1 1
LABEL=/stuff            /stuff                  ext3    defaults        1 2
LABEL=/home1            /home                  ext3    defaults        1 2
LABEL=/boot12          /boot                  ext3    defaults        1 2
tmpfs                  /dev/shm                tmpfs  defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                  /sys                    sysfs  defaults        0 0
proc                    /proc                  proc    defaults        0 0
LABEL=SWAP-sda2        swap                    swap    defaults        0 0
LABEL=SWAP-sda21        swap                    swap    defaults        0 0

I've highlighted the relevant entry (it's the "/stuff" one). I'm sure it's got something to do with adding specific options where "defaults" currently lives, but nothing seems to work. I presume the answer is humiliatingly obvious. ;)

Many thanks in advance,


billymayday 06-24-2008 07:43 PM

I have my storage mounted with 0 0, but 1 2 should be OK.

What are ther permissions of /stuff (ie ls -l /stuff)?

Dailan 06-24-2008 08:02 PM


Originally Posted by billymayday (Post 3194064)
I have my storage mounted with 0 0, but 1 2 should be OK.

What are ther permissions of /stuff (ie ls -l /stuff)?

Awww jeeez. How did I miss that? :)

You were spot on Billy. I didn't have write permission set for the mount point. A quick "chmod 777 /stuff" has everything chugging along nicely.

Thank you very much. ;)


billymayday 06-24-2008 09:24 PM

Sometimes it helps to have some new eyes on even the simplest problems.


All times are GMT -5. The time now is 03:13 PM.