-   Fedora (
-   -   During boot process FC4 hangs after Hal deamon? (

Scotsguy101 02-19-2007 08:40 AM

During boot process FC4 hangs after Hal deamon?
Problem when booting FC 4


I am new to linux but am keen to improve my knowledge of this OS. I have a problem and hope someone can assist me.

I recently installed FC 4. Everything was running smoothly. I installed a particular piece of software and it to seemed to be running ok. To allow additional features of this software to run i added additional lines to my environment variables file. After amending the file I also sourced the file, i did this in different shell types, csh, sh and bash, as i was'nt sure which was the correct way to do it.

I thought this was all hunky dory until i switched on my computer today to find that during the boot process but after the line:

Starting up Hal daemon [ok]

The computer hangs.

The files that i edited lie in


I managed to get into the file structure through GRUB, but i could'nt access etc/profile as it said /profile was not a directory, i find this strange.

I am assuming the problem i have is a result of either editing the files or sourcing the this possible? If i am barking up the wrong tree please let me know.

Any possible lines of attack to solve this problem would be most welcome.

Thank you

Scotsguy101 02-19-2007 09:59 AM

My mistake

In response to my own earlier post. I should have known profile is a file and not a directory. I am going to attempt to edit this file using vi. Fingers crossed, i hope that will solve the problem.

Any responses from other users would be greatly appreciated.


Scotsguy101 02-19-2007 10:33 AM

Problem solved
Yeah, that worked.

By editing the kernel boot tag, appending "single" to the boot line i was able to get into my file structure.

There i edited the file with the problematic line using vi

After editing the file i sourced it in bash, I dont know if this was necessary.

I guess i should be more careful about how i edit files but i feel a little bit further up the learning curve now.


All times are GMT -5. The time now is 09:09 PM.