-   Fedora (
-   -   Dual boot, two disk Fedora Windows only opens Windows (

Javkin 10-19-2006 01:18 AM

Dual boot, two disk Fedora Windows only opens Windows
I tried to set up a dual-boot system with Windows XP on one disk and Fedora 5 on the other. For some reason, the installation DVD doesn't install GRUB. When I try to install Grub via the Repair mode or the Rescue CD, it explicitly tells me that the Kernel wasn't written, and that Grub won't go in.

The strangest thing is that other distributions (Debian and Ubuntu) installed GRUB with no difficulty. When I tried to install GRUB using one of these and then installing Fedora, the system simply hung when I tried to boot.

The most frustrating thing is that I can't get into Fedora to install GRUB manually.

I would prefer to use the Fedora distribution, because the hardware installs more easily than Debian, and it has much more flexibility than Ubuntu.

Answers to similar posts didn't solve this problem for me.

(I'm experienced with using Linux, but not with installing it.)

mickyg 10-19-2006 04:45 AM

Can I just clarify, you say other distros (debian and ubuntu) have been able to install grub successfully, so does this mean that your current bootloader is grub and your problem is getting grub to boot your fedora installation?

If this is the case have you tried manually setting up grub, i.e. when the system boots and you get grub hit the esc key and go in to the text mode where you can edit the boot options grub is trying to use to boot.

If you haven't got grub installed and are currently booting using the windows bootloader, then you could try using knoppix to install grub.

Javkin 10-20-2006 04:47 AM

Thank you. I was finally able to get Fedora to install GRUB by putting Fedora on the first disk drive. I think the problem was that I specified that the first disk drive would not be written to. The other installations were set to override this when writing GRUB to the boot sector.

When I tried to mount GRUB manually, I did something wrong, in specifying the version of Linux, or the logical drive, or something, so it wouldn't work.

Thanks again.

All times are GMT -5. The time now is 01:14 PM.