-   Fedora (
-   -   Does anyone understand why the audio works, but will not come through my TV? (

maestro52 12-15-2009 05:02 PM

Does anyone understand why the audio works, but will not come through my TV?
This is very strange for me, but I am not a computer or tv tech. :scratch:

I am now using the lateest Fedora 11 PAE-Debug kernel on my AMD 3core (over 2.2gb) 8gb memory connected to my Samsung 40" lcd HDtv. I have a Realtech 7.1 on board sound card that has actually quite surprised me with it's quality. The sound problem started when I was using FC10, but when I upgraded to FC11 I was immediately able to hear sound through my headphones, speakers, and my tv. Then I seemed to pass into an alternate universe or something (trying to be a bit humorous).

Then I installed SKYPE and as usual I had to tinker around a bit to get the microphone to work, but I could hearthe other people in all cases, including through the tv. Finally, I figured I would tinker further with pulseaudio, but while the sound started working through the micrphone it was very low volume and I could not do anything about it.

I then decided to check my memory and noticed it only saw 3 gb instead of 8 gb. I assumed that may be some of the problem and realized I forgot to install the PAE kernel. After doing so and rebooting, I then discovered that I had installed the kmod for nvidia (I forgot to tell you I have a Gforece 9500 GT+), but forgot to install the nvidia driver (DUHHHH) because my screen suddenly only let me have 640x480 or 800x600.

At this point I did check the audio but immediately install the nvidia driver and rebooted properly (outside of the X environment) to install it. Then when I got into fedora again, the video was correct and the audio was actually quite perfect, BUT only through the computer headphones and speakers.

Very oddly, I am now back to the way things were in FC10. I cannot get the sound to pass from my computer to or through my tv. :scratch::(:scratch: I can hear everything, including inbound and outbound communication through Skype, in my headphones. I then connect the audio to the tv through the same connection my headphones used and suddenly there is no sound. :scratch::cry:

Does anyone anywhere have any knowledge as to what the heck is going on here??

Greenfuse 12-15-2009 07:00 PM

Am I to understand that the audio worked differently after installing the new kernel?

Perhaps it does not have quite the same alsa modules as the earlier kernel.

Haver you tried running alsaconf? (as root, from a terminal - needs alsa-utils installed)

Have you checked mixer settings? - running alsamixer from the terminal might be useful for this (again part of the alsa-utils package). See if any of the output channela are down or muted.

All times are GMT -5. The time now is 05:40 AM.