LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 12-06-2003, 11:20 PM   #1
cpv204
Member
 
Registered: Mar 2003
Location: Tribeca, NYC
Distribution: Slackware 9.0, Fedora Core 1
Posts: 111

Rep: Reputation: 15
does anyone have mysql running under Fedora?


I get an error when I'm trying to initialize the database using mysql_install_db:
Didn't find /usr/libexec/mysqld

Indeed, there is no mysqld or mysqld_safe on my whole filesystem. Wondering if anyone who got mysql running can tell me what they did.

Thanks
 
Old 12-07-2003, 10:10 AM   #2
blaroe
Member
 
Registered: Jun 2003
Location: Surrey, England
Distribution: Ubuntu Edgy
Posts: 67

Rep: Reputation: 15
If you installed mysql using the standard Fedora rpm install and if you are running Gnome , you should have access to it through the Systems Settings->Server Settings->Services dialog. Start the service from there and then run the client as normal to set up db's etc.

Worked like a charm for me.

bl
 
Old 12-13-2003, 09:15 PM   #3
cpv204
Member
 
Registered: Mar 2003
Location: Tribeca, NYC
Distribution: Slackware 9.0, Fedora Core 1
Posts: 111

Original Poster
Rep: Reputation: 15
That did it. That Services gui makes it very easy.

I've been puttering around in MySQL for an hour or two. The client connects to the server fine. However, when I rebooted, during the startup messages I see "timeout error occurred trying to start MySQL Daemon" and then MySQL <failed > over on the right side (normally get <OK> for other daemons).

Yet, after booting is finished, I open up a terminal and enter "mysql" and I connect to the server fine. So what's up with that error message during boot? Since I enabled mysqld via the Services gui, I don't really know where to look to troubleshoot this.

Last edited by cpv204; 12-13-2003 at 09:17 PM.
 
Old 12-13-2003, 09:52 PM   #4
Moebius01
LQ Newbie
 
Registered: Nov 2003
Posts: 24

Rep: Reputation: 15
I get the same failed message on startup, but mysql is up and running fine for the test site I put up. I officially have a LAMP installation now. I'm a happy boy.
 
Old 12-14-2003, 03:14 AM   #5
blaroe
Member
 
Registered: Jun 2003
Location: Surrey, England
Distribution: Ubuntu Edgy
Posts: 67

Rep: Reputation: 15
I don't know why the daemon returns a [FAILED] at startup, but there are some elements of the mysqld daemon such as InnoDB that are not setup out of the box.

As root, try looking at the mysqld log files in /var/log. Either with an editor or whatever suits, examine mysqld.log or mysqld.log.* . That might provide some insight.

If you post the log contents here, or on any mysql forum, someone should be able to help interpret them.

Hope this helps!
bl
 
Old 12-14-2003, 06:57 AM   #6
cpv204
Member
 
Registered: Mar 2003
Location: Tribeca, NYC
Distribution: Slackware 9.0, Fedora Core 1
Posts: 111

Original Poster
Rep: Reputation: 15
you were right on the money blaroe. Here's a snip from mysqld.log.1

031213 21:52:57 mysqld started
Cannot initialize InnoDB as 'innodb_data_file_path' is not set.
If you do not want to use transactional InnoDB tables, add a line
skip-innodb
to the [mysqld] section of init parameters in your my.cnf
or my.ini. If you want to use InnoDB tables, add to the [mysqld]
section, for example,
innodb_data_file_path = ibdata1:10M:autoextend
But to get good performance you should adjust for your hardware
the InnoDB startup options listed in section 2 at
http://www.innodb.com/ibman.html
/usr/libexec/mysqld: ready for connections

I'm going to check out the info at innodb.com, but if you have any further comments, I'd appreciate them too. Thanks!
 
Old 12-14-2003, 08:15 AM   #7
blaroe
Member
 
Registered: Jun 2003
Location: Surrey, England
Distribution: Ubuntu Edgy
Posts: 67

Rep: Reputation: 15
That may not be causing the initialisation to fail, but you're on the scent. Normally any critical errors would show up in mysqld.log (I think!) Keep us posted on progress.

If this doesn't solve the init problems, maybe you could check with forums focused on mysql - one I know of is http://www.blogomania.com/forums/.

Good luck!
bl
 
Old 12-14-2003, 08:44 AM   #8
cpv204
Member
 
Registered: Mar 2003
Location: Tribeca, NYC
Distribution: Slackware 9.0, Fedora Core 1
Posts: 111

Original Poster
Rep: Reputation: 15
My mysqld.log file is totally empty, but has the same timestamp as mysqld.log.1 (this morning, 4:02 am).

I don't know exactly how the mechanics of logging work, but I'm guessing that the contents of mysqld.log was copied over to mysqld.log.1 at that time.
 
Old 12-14-2003, 07:43 PM   #9
Moebius01
LQ Newbie
 
Registered: Nov 2003
Posts: 24

Rep: Reputation: 15
I show the exact same Innodb error in my logs. As MySQL is running ok, I'm not too concerned about it, but I'd be curious to see if it speeds my test sites up any. Probably not as the box is running on 128 meg right now (old box and can't come by any cheap ram for it) but worth a try just to see.
 
Old 12-29-2003, 01:36 AM   #10
cgill27
LQ Newbie
 
Registered: Dec 2003
Location: Arlington, TX.
Distribution: Arch Linux; Fedora Core 1
Posts: 4

Rep: Reputation: 0
Wink Here's a temp workaround

I noticed the same startup problems only after I assigned a password to the mysql root user. The problem is in the mysqladmin ping command in the mysql startup script, it apparently doesn't work after assigning the root user a password. So I modified the script and in the mysqladmin ping commands added the "-u root -p 'password' " and the script works fine now. Thats not the best solution but does seem to work.

Craig
 
Old 02-03-2004, 02:53 AM   #11
tommytomato
Member
 
Registered: Nov 2003
Location: Narrogin Western Australia
Distribution: GUI Ubuntu 14.0.4 - Server Ubuntu 14.04.5 LTS
Posts: 951

Rep: Reputation: 32
I have the same prolbem, only happens after i put in a root password.

so that will fix it hey ? where is the file to edit on the system please.


TT
 
Old 02-07-2004, 01:29 PM   #12
DarkstarNL
LQ Newbie
 
Registered: Oct 2003
Location: The Netherlands
Distribution: Debian Sarge
Posts: 22

Rep: Reputation: 15
I know it'll be a little late for this but instead of using the 'root' user in the mysqld init script you can use any other user wich is not in the database just think of one

You can replace the line

if [ -n "`/usr/bin/mysqladmin ping 2> /dev/null`" ]; then
and
if !([ -n "`/usr/bin/mysqladmin ping 2> /dev/null`" ]); then

to:

if [ -n "`/usr/bin/mysqladmin ping -u mysqld 2> /dev/null`" ]; then

and

if !([ -n "`/usr/bin/mysqladmin ping -u mysqld 2> /dev/null`" ]); then

in the /etc/rc.d/init.d/mysqld file

This works for me!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
MySQL , is it running? is it there? Raggit Fedora 7 09-14-2005 02:02 PM
mysql problems running?? kahn Linux - Software 1 02-24-2005 11:35 AM
Fedora Core 3, MySql Server, mysql started mysql ended OkiTek Fedora 30 01-28-2005 09:15 AM
MySQL 4 on Fedora can't install php-mysql kennyg Linux - Software 8 09-21-2004 06:54 PM
running mysql ?? shaahul Linux - Software 1 09-03-2003 02:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 03:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration