-   Fedora (
-   -   Could not init font path element unix/:7100, removing from list! (

jeffreybluml 03-11-2004 11:55 AM

Could not init font path element unix/:7100, removing from list!
Hey linux gurus...

I have been unable to boot my fedora core, and as you can read in the post titled "fedora wont boot, displays nvidia splash screen over and over" I had origianlly thought it was an nvidia driver or card issue. However, when I recently typed "startx" from the command line (in runlevel 3) I found the following error message after it went to the nvidia splash screen and then returned to the command line:

Could not init font path element unix/:7100, removing from list!

Fatal server error:
could not open default font 'fixed'

So I commented out the line

#FontPath "unix/:7100"

in XF86Config and typed startx. Now, the splash screen comes on for only a moment (as it used to) and then it goes the the black X cursor that you see when booting right before you see the boot progress. I almost jumped out of my seat, as I though it was fixed. But after about two seconds it went back to command line, and shows the following error:

Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from list!

/root/.Xclients: line 8: /root/.Xclients-default: No such file or directory
/root/.Xclients: line 8: exec: /root/.Xclients-default: cannot execute: No such file or directory

So, anybody have any ideas? I still a bit of a newbie, and I'm totally stuck here. PLEASE HELP!!!!

jeffreybluml 03-11-2004 12:39 PM

Thanks for helping everyone.

It turns out it was related either to the font path element or the "/root/.Xclients: line 8: /root/.Xclients-default: No such file or directory" error, because I commented out the 'FontPath "unix/:7100" ' from the XF86Config file, and copied my existing .Xclients-localhost..... file to .Xclients-default and EVERYTHING is fine again!!

Still dont understand what happened to cause all this, or what "all this" even was about, but for now I'm glad it's fixed.

This forum is such a great resource! What a lifesaver it has been for a guy trying to dump windows, but who has NO programming experience. Thanks to all!

jharris 03-11-2004 12:40 PM

That kind of error message means that X can't talk to the font server it is expecting to find listening on port 7100. This either means you've not got an X font server (so shouldn't be trying to use it), or it's died.



forrestt 03-11-2004 01:44 PM

To restart if it is dead:

% /etc/init.d/xfs start

Hope this helps.

flyfishin 03-11-2004 02:43 PM


Originally posted by forrestt
To restart if it is dead:

% /etc/init.d/xfs start

Hope this helps.

You can also use the service command to work with the scripts in /etc/init.d . So for xfs it would be:

service xfs [start|stop|restart]

forrestt 03-11-2004 02:48 PM

I guess I'm showing my age :).

flyfishin 03-11-2004 03:11 PM


Originally posted by forrestt
I guess I'm showing my age :).
Refer to is as experience ;). I actually have you by about 2 months in the age department. :)

EmilR 03-23-2004 03:58 AM

Most likelly your harddrive is full


fideli 04-09-2004 12:00 AM


i'm getting that "could not init font path element" on a number of my font directories, and i don't use xfs. the x server still starts, and actually i never realized the issue until one day when i logged in through the console and had to do a "startx" for a few minutes. when i came out i saw what it had output before starting the x server and there were around 7 or 8 directories that it could not init. any ideas?


jeffreybluml 04-09-2004 05:43 AM


I was indeed out of disk space like one of the replies suggested, although it sounds like perhaps this is not your problem. Aside from confirming that the paths causing the trouble actually exist, and have write permissions, I'm not sure what to tell you.

Anyone else?

jon-do 04-10-2004 12:44 AM

I am not sure if it is the same but I had some problems with my font paths, actually I checked my /var/log/messages and I found this "xfs: ignoring font path elements .....'
after doing a search, I found a fix.
I just removed the path to the fonts and problem solved.
This is what I did for each path listed as not found, I typed as root
$ chkfontpath -l
whatever was not found I just removed the path
$ chkfontpath -r <name of font path not found>

kwingate 04-18-2004 03:31 PM

try using port 7110 instead of port 7100. i did an update a while back and this fixed it.

cutecute 04-26-2004 10:03 PM

Thanks very much!! I think i can fix it now, it's the usage of disk is 100% !
ok, now i'm using lynx to browser. it's blessing that this site can be browserd by lynx. now i rm all the file in /tmp/ any will try to startx after posting this reply...

electronick 05-15-2004 02:45 AM

I have such trouble, xfs running, but X can't connect to fontserver. It occured then / (root partition) hasn't free disk space.
Sweep your / or bay new harddisk :), .
#rm ~/.fonts.cache-1. (with old .font.cache-1 doesn't work)
#service xfs restart

awassero 08-18-2004 12:56 AM

i have 30GB free on /

i am having the same issue, when i type startx i receive the error message mentioned.

I dont believe the cause of my issue is disk space. i have a 60GB hdd. I checked with du and im only using 28GB. i checked fdisk and it shows the / slice is mounted to a partition with 58GB.

this issue didnt appear until I transplanted the hdd into a totally different box. everything uninstalled/reinstalled ok as far as i can tell and I have not noticed any issues other than with xserver.


All times are GMT -5. The time now is 10:36 PM.