LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 12-06-2007, 11:13 PM   #1
PhilTR
Member
 
Registered: Jun 2004
Location: Birmingham, AL
Distribution: FC6, FC8, FC11
Posts: 102

Rep: Reputation: 16
Connection Information wrong


I need some help with trouble-shooting a network issue.

I've just upgraded from FedoraCore7 to FedoraCore8 and can not access the internet (I'm on my FC6 box now). I've edited 'etc/hosts' as follows:

#::0 localhost6.localdomain localhost6 (commented out previouly without any problems.)

192.168.0.100 philsfc6.net philsfc6
192.168.0.101 philspclinuxos.net philspclinuxos
192.168.0.102 philsfc8.net philsfc8

When logging out as 'user' the welcome screen identifys the box as 'philsfc8.net' as expected. The terminal prompt is:

'[philtr8@philsfc8 ~]$' again as expected.

Rt clicking on the 'Connection information' icon in the system tray in part shows:

IP Address 169.254.114.250
Brodacast Address 169.254.255.255
Subnet Mask 255.255.0.0
Default Route 0.0.0.0 (set as 192.68.0.1 using the Network GUI)

On this box the correct IP Address shows and Broadcast Address (192.168.0.100 and 192.168.0.255 respectively)

Finally, '/etc/networks' shows:

default 0.0.0.0
loopback 127.0.0.0
link-local 169.254.0.0
#link-local 192.168.0.102 (which didn't have any effect)

I tried changing these values hoping this would correct the IP issue. I did restart network services after saving changes.

I've looked in '/etc/sysconfig/networking/devices/ifcfg-eth0 and found the following:

DEVICE=eth0
BOOTPROTO=none
HWADDR=00:OD:61:3B:72O
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
IPV6INIT=yes
PEERDNS=yes
NETMASK=255.255.255.0
IPADDR-192.168.0.102
GATEWAY=192.168.0.1

'/etc/sysconfig/networking/profiles/default/hosts' is the same as 'etc/hosts and '/etc/.../ifcfg-eth0 is the same as above.

I don't know where else to check. Could someone please help me. Thanks in advance. phil
 
Old 12-07-2007, 02:48 AM   #2
mhearne
Member
 
Registered: Nov 2004
Location: Amarillo, TX
Distribution: Mandriva
Posts: 91

Rep: Reputation: 15
In Mandriva /etc/sysconfig/networking is for loopback. Here is my ifcfg-lo:

NAME=loopback
DEVICE=lo
IPADDR=127.0.0.1
NETMASK=255.0.0.0
NETWORK=127.0.0.0
# If you're having problems with gated making 127.0.0.0/8 a martian,
# you can change this to something else (255.255.255.255, for example)
BROADCAST=127.255.255.255
ONBOOT=yes
BOOTPROTO=none
USERCTL=no
PEERDNS=no


Here is my /etc/sysconfig/network-scripts/ifcfg-eth0:

DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.0.1
NETMASK=255.255.255.0
NETWORK=192.168.0.0
BROADCAST=192.168.0.255
ONBOOT=yes
METRIC=10
MII_NOT_SUPPORTED=yes
USERCTL=yes
IPV6INIT=no
IPV6TO4INIT=no
PEERDNS=yes

If you are not using ipv6, then it should be ipv6init=no. BOOTPROTO should either be static or dhcp.

Here is my /etc/networks:

/etc/networks
# Sample networks file for LSB compliance. Database of network
# names and addresses, used by programs such as route.
# format: networkname networkaddress

And here is my /etc/hosts file:

# generated by drakhosts
127.0.0.1 localhost localhost.localdomain
192.168.0.1 proton.kc5yfl.net proton
192.168.0.250 neutron.kc5yfl.net neutron
192.168.0.251 lepton.kc5yfl.net lepton
192.168.0.252 meson.kc5yfl.net meson
192.168.0.253 graviton.kc5yfl.net graviton
192.168.0.254 quark.kc5yfl.net quark

"127.0.0.1 localhost localhost.localdomain" should always exist in the hosts file, and it should be on every machine in the network. I noticed that you had added a number to localhost, and finally commented it out. You need to broadcast on both tcp as well as udp.

I went to http://www.google.com/linux and searched for "Linux Networking", recieved 1,180,000 results. You should probably start at http://tldp.org/ and search the HOWTO's.

HTH

Last edited by mhearne; 12-07-2007 at 02:52 AM.
 
Old 12-07-2007, 01:40 PM   #3
PhilTR
Member
 
Registered: Jun 2004
Location: Birmingham, AL
Distribution: FC6, FC8, FC11
Posts: 102

Original Poster
Rep: Reputation: 16
mhearne, thanks for your reply.

I do have '127.0.0.1 localhost.localdomain localhost' in my '/etc/hosts' file. I just didn't copy it to the above post. The commented out line was put there when I clean installed FC7. It was there instead of the normal loop-back IP. I added the loop-back by hand and commented out the odd loop-back(?) line. Everything seemed to work fine.

I also converted to static IP's from DHCP assigned IP's. I even got my samba shares working properly as well as printing services. It was then that I decided to upgrade to FC8. I'm going to do my damnedist to get FC8 working as an upgrade. If I can't I'll see about a clean install. If that fails me I'll go back to FC7.

Mandrake's dir layout and dir contents seem to be a bit different from FC8's. Not sure if your config fiies will be helpful. I only pick at linux and so don't know a whole lot about its inner workings.

I'm just puzzled as to where the OS got the info to assign eth0 the IP of '169.254.114.250'. The only file I could find that had anything near that addy was at '/etc/networks' the contents of which I posted above. I tried changing the 'link-local' lines to see what effect that had. I restarted network services but didn't try re-booting. Even with the link-local line reading '192.168.0.102' the connection information remained the same.

I've looked for other config files that might have this '169...' IP in them but w/o any luck. I always thought that the OS looks in '/etc/hosts' to assign the IP for eth0. FC8 seems to be looking somewhere else.
 
Old 12-07-2007, 02:00 PM   #4
PhilTR
Member
 
Registered: Jun 2004
Location: Birmingham, AL
Distribution: FC6, FC8, FC11
Posts: 102

Original Poster
Rep: Reputation: 16
I did a quick whois on '169.254.114.250' and got:

[philtr6@philsfc6 ~]$ whois 169.254.114.250
[Querying whois.arin.net]
[whois.arin.net]

OrgName: Internet Assigned Numbers Authority
OrgID: IANA
Address: 4676 Admiralty Way, Suite 330
City: Marina del Rey
StateProv: CA
PostalCode: 90292-6695
Country: US

NetRange: 169.254.0.0 - 169.254.255.255
CIDR: 169.254.0.0/16
NetName: LINKLOCAL
NetHandle: NET-169-254-0-0-1
Parent: NET-169-0-0-0-0
NetType: IANA Special Use
NameServer: BLACKHOLE-1.IANA.ORG
NameServer: BLACKHOLE-2.IANA.ORG
Comment: Please see RFC 3330 for additional information.
RegDate: 1998-01-27
Updated: 2002-10-14

OrgAbuseHandle: IANA-IP-ARIN
OrgAbuseName: Internet Corporation for Assigned Names and Number
OrgAbusePhone: +1-310-301-5820
OrgAbuseEmail: abuse@iana.org

OrgTechHandle: IANA-IP-ARIN
OrgTechName: Internet Corporation for Assigned Names and Number
OrgTechPhone: +1-310-301-5820
OrgTechEmail: abuse@iana.org

# ARIN WHOIS database, last updated 2007-12-06 19:10
# Enter ? for additional hints on searching ARIN's WHOIS database.
[philtr6@philsfc6 ~]$

Not sure what it means. Anyone have any ideas? Thanks. phil
 
Old 12-08-2007, 07:07 AM   #5
PhilTR
Member
 
Registered: Jun 2004
Location: Birmingham, AL
Distribution: FC6, FC8, FC11
Posts: 102

Original Poster
Rep: Reputation: 16
I've solved my connection issue, somewhat. I turned off 'NetworkManager', NetworkManagerDispatcher', and the 'avahi-daemon'. As I mentioned above I have 'dhcp' services on my router truned off. Finally, I have '192.168.0.1' as my 'Primary DNS' in 'System, Administration, Network, Network Configuration, DNS'. To me this does not seem to be intuitive but, it does not seem to adversley affect system operation. I'm going to continue playing around with these three services to see exactly which one is the culprit. phil
 
Old 12-11-2007, 02:30 AM   #6
sorenchr
LQ Newbie
 
Registered: Jun 2006
Posts: 21

Rep: Reputation: 0
same issue

Hi,
It might be a long shot but do we have the same problem?

http://www.linuxquestions.org/questi...6/#post2986555

If so, do you know what would be the problem?


Cheers
Sore
 
Old 12-12-2007, 08:58 PM   #7
PhilTR
Member
 
Registered: Jun 2004
Location: Birmingham, AL
Distribution: FC6, FC8, FC11
Posts: 102

Original Poster
Rep: Reputation: 16
sorenchr, indeed it does. I also discovered that after running 'Software Updater' I had two copies of avahi one for FedoraCore7 and one for FedoraCore8 (I did an 'upgrade' from FC7 to FC8).

I don't know if I had the two pre update but, I ran 'rpm -e --noscripts' to get rid of the older version. I fact I couldn't get on line untill after stopping them. Only after the update and installing 'synaptic package manager' and running it for the first time did I become aware ot the 'avahi' issue.

I've been out of pocket since and so haven't had the opportunity to systematically restart 'NetworkManager', NetworkManagerDispatcher', and the 'avahi-daemon' to see if the problem persisted and if so which of the services would be the culpit. Once I do I'll post my results. phil

Last edited by PhilTR; 12-12-2007 at 09:02 PM.
 
Old 12-12-2007, 09:23 PM   #8
michaelk
Moderator
 
Registered: Aug 2002
Posts: 17,604

Rep: Reputation: 2337Reputation: 2337Reputation: 2337Reputation: 2337Reputation: 2337Reputation: 2337Reputation: 2337Reputation: 2337Reputation: 2337Reputation: 2337Reputation: 2337
FYI. When a DHCP server fails, automatic private IP addressing (APIPA) allocates addresses in the private range 169.254.0.1 to 169.254.255.254. Clients verify their address are unique on the LAN using ARP. When the DHCP server is again able to service requests, clients update their addresses automatically.

The /etc/hosts file is a just for resolving IP addresses to host names without using a DNS. As already stated eth0 configuration file is ifcfg-eth0.

Looks like something might be amiss with network manager that automatically reconfigures eth0 back to dhcp.

Last edited by michaelk; 12-12-2007 at 09:27 PM.
 
Old 12-12-2007, 11:35 PM   #9
sorenchr
LQ Newbie
 
Registered: Jun 2006
Posts: 21

Rep: Reputation: 0
thanks

Thanks for the info - I guess it would indicate that something has changed in NetworkManager then.
As stated in the other thread it now works for me when disabeling just that service.

Regards
Soren
 
Old 12-15-2007, 05:56 AM   #10
PhilTR
Member
 
Registered: Jun 2004
Location: Birmingham, AL
Distribution: FC6, FC8, FC11
Posts: 102

Original Poster
Rep: Reputation: 16
Since I turned off three services, NetworkManager, NetworkManagerDispatcher and avahi-daemon I restarted each starting with the avahi-daemon. After restarting each service I restarted network services. Bear in mind I have dhcp services disabled using static IP addys in my network config file.

Starting the avahi-daemon and the NetworkManagerDispatcher did not interfear with access to the net. But when I added the NetworkManager into the mix my IP address was changed again to '169.254.114.250' upon restarting network services. This occured even if the dispatcher or avahi-daemon were excluded from the mix.

I noticed that the primary DNS field was blank after stopping the NetworkManager and restarting network services. I had to fill in this field (I'm using the gateway addy for this value) and restart network services before I could access the net. I couldn't leave this field blank.

I'm not sure why the NetworkManager would interfear with IP addy assignment when they're staticlly assigned. Hopefully michael can shed some light here. phil
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
What is wrong with reiserfs? wrong free space mesh2005 Linux - General 1 05-03-2007 07:21 AM
Hiding machine information and root information geletine Linux - Security 6 07-14-2006 07:57 AM
SUSE 10.0 extremely slow internet connection! what is wrong? tamere SUSE / openSUSE 20 02-02-2006 07:30 AM
df command shows wrong information vdemuth Mandriva 3 06-04-2004 02:30 AM
Domain Routing to Postfix from Sendmail = Wrong IP information in Mail Logs! dholingw Linux - Networking 2 05-20-2004 10:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 10:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration