-   Fedora (
-   -   cloned F11 install refuses to boot (kernel hang) (

kz26 06-17-2009 04:04 PM

cloned F11 install refuses to boot (kernel hang)
I installed F11 x86 from the DVD onto a machine using a total of 4 partitions:
1. /boot
2. /
3. /home
4. swap

I then created an image of the first 3 partitions with fsarchiver/Parted Magic and restored it onto a second machine (with different hardware).
Grub was loaded onto the second machine as well without a problem. The new cloned install will get past grub fine but the kernel hangs. After removing 'rhgb quiet' from the boot options, I can see that the last message outputted to the console is something about the PS/2 mouse - this doesn't make sense as the mouse is working perfectly fine.

Additionally, I can still reboot using ctrl-alt-delete so the kernel/CPU must still be responsive.
I have tried troubleshooting the various pieces of hardware, so I'm guessing it's something with the clone. All the cloned filesystems appear to be fully intact; the partition UUID's are all the same. I've even tried changing the UUID's both in grub and /etc/fstab to hardcoded /dev/sdaX , but this does not fix anything.

I'm out of ideas as to what to try next - is there something wrong with the imaging method? Do I need to make changes to accomodate the different hardware? Any ideas or advice would be greatly appreciated. If you need more info, I'll do my best to provide it.

patmcclung 08-01-2009 08:31 AM


I am getting exactly the same output from the F11 cloned initialization you describe.

I have installed a new SATA drive and cloned the F11 system on it. There are 3 partitions /boot / and /home.

I have made the new disk bootable and first BIOS boot priority, installed grub on /boot and made the necessary modifications to the grub device table, UUIDs, etc. and made a new initrd on /boot. and a new /etc/fstab on / with the right stuff.

Grub works fine from the new disk, and with kernel parameters rhgb and quiet removed I get the same output that you describe.

The thing I noticed is that the booting kernel is not seeing the new drive (the one it is booting from). It only sees ata0 (/dev/sda) and ata1 (/dev/sdb). I don't see any entries for sata2 (/dev/sdc).

If I use the super grub cd, I can boot into the original F11 system fine, and the new /dev/sdc is there, (I can mount partitions on it, etc.) All the partitions are shown if I issue the blkid command.

Look at your initialization messages and see if your kernel sees the drive you're booting to.

patmcclung 08-01-2009 10:40 AM

maybe a solution
I think I have a solution to our problem. I results from the fact that F11 has deprecated /etc/modprobe.conf

If you look, you will see that it isn't there. initrd looks for modprobe.conf to find the aliases for your hard disk drivers.

Possible solution is to copy the contents of /etc/modprobe.d/local.conf to /etc/modprobe.conf on your cloned / partition, and then do a new mkinitrd.

I will try this tomorrow and let you know.


patmcclung 08-02-2009 07:09 AM

Solved cloning F11 on my system as follows.
1. Created clone new disk partitions with fdisk and mkfs. make /boot partition bootable.
2. booted a rescue disk, mounted and moved the old partitions to the new partitions with
rsync -vaXSH --numeric-ids (old partition mount point)/ (new partition mount point)
3. modified /etc/fstab on the new disk to appropriate new disk UUIDs (shown by blkid command)
4. On the new disk grub, modified the device table to include the new disk and set appropriate things. Watch out!
changing the bios hard disk boot priority may cause your /dev/sdX settings to change! Changed my new disk from /dev/sdc to /dev/sda!!
5. set bios to boot new disk first.
6. Booted old system with supergrub disk. mounted new disk partitions.
7. copied /etc/modprobe.d/local.conf to /etc/modprobe.conf on both the new and old systems.
8. cd to /boot directory on the new disk.
9. rm initrd-
10. mkinitrd -v --fstab=/mnt/newroot/etc/fstab initrd-
{--fstab=(/etc/fstab) as modified in step 3 above}
11. restarted and booted Fedora 11 new disk via grub normally.

Everything works, but SElinux (permissive mode) is giving me a few avc denials from gnome. Maybe I screwed up
with that --numeric-ids parameter on the rsync partition moves.

Hope that helps you.

Pat McClung

All times are GMT -5. The time now is 09:56 PM.