-   Fedora (
-   -   Changing resolution (

sdpeelejr 04-01-2004 08:10 PM

Changing resolution

Just installed FC1 and I am wondering how I can change the screen resolution? Currently, it will not let me go over 640x480.


wiBo 04-01-2004 10:31 PM

1st: try in control center to change your resolution..
2nd: in your /etc/X11/XF86Config-4 file, which driver did you use in the driver section?

sdpeelejr 04-02-2004 06:13 AM

I think it might be this old monitor. Its pretty old. It will let me change it, but when I restart, it is still 640x480.


aaa 04-02-2004 07:14 AM

Run xf86cfg or xvidtune or redhat-config-xfree86

sdpeelejr 04-02-2004 03:15 PM

Okay, I changed the resolution to 1024x768, but it only works there at 256 colors, which I do not like because the colors are distorted. Is this my monitor?

pantspi 04-02-2004 03:41 PM

if you have nvidia chip go and download drivers
or go to and you find what you want

wiBo 04-02-2004 03:43 PM


Originally posted by pantspi
if you have nvidia chip go and download drivers
or go to and you find what you want

isn't ?

LordMorgul 04-02-2004 04:51 PM

There are nVIDIA driver RPMs supplied by the folks over at livna, but the url could be more specific.

These install the drivers and libraries by relocating them which removes some conflicts with Mesa. There are also several scripts included which are quite handy. This is a superior way to install the drivers for Fedora machines.

Nevertheless, having problems setting up a monitor to go over 640x480 is not directly related to not having these dirvers. It is likely to be problems with the monitor refresh rates specified in the config file, which defaults as /etc/X11/XF86Config on all Fedora machines (XF86Config-4 is obselete from RH9, but the config can actually have any name you want, this is just the default).

If the original problem persists, post the contents of the config file that pertain to the monitor, i.e. all the below sections, and some specifics about your hardware so that it can be determined if you have this stuff right!

Section "Monitor"
Section "Device"
Section "Screen"

sdpeelejr 04-02-2004 08:14 PM

So, my problem could be the video driver?

Thanks for your help....

sdpeelejr 04-03-2004 11:39 AM

Here is a little more detail -

I can change the resolution, then it tells me to logout and restart the X server.

I do that, but when I log back in, its still at 640x480, but with I go to RedHat > System Settings > Display, it shows that it is at 800x600, but it is still at 640x480.

I've tried looking for the video driver for the video card which is a Cirrus Logic GD544x, but I cannnot seem to find it.

Any further diagnostics?

Thanks to all

sdpeelejr 04-03-2004 08:57 PM

Anyone? :newbie:

sdpeelejr 04-04-2004 01:46 PM


I configured the monitor the correct monitor - MAG Innovision DX17F - instead of the Generic CRT. It still will not change resolutions successfully! This is killing me :( It shows that it is on a resolution higher than 640x480, but is still on 640x480!

Here is a visual of what I mean -

Here is the contents of /etc/X11/XF86Config

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "MAG InnoVision DX17F"
HorizSync 30.0 - 64.0
VertRefresh 50.0 - 90.0
Option "dpms"

Section "Device"
Identifier "Videocard0"
Driver "cirrus"
VendorName "Videocard vendor"
BoardName "Cirrus Logic GD544x"

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 8
Modes "1152x864" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"

Section "DRI"
Group 0
Mode 0666

Thanks to all

sdpeelejr 04-05-2004 08:45 AM

am i just being ignored now? :confused:

usnay12345 04-06-2004 05:08 PM

That config file looked reasonable to me.
I don't have experience with FC1, but I have been having the same problem on several RH9 machines.

One machine was an RH9 upgrade install over RH 7.3. Of all the RH9 installs, this is the only one where X correctly used a higher-than-640x480 resolution right away, and also the only one where the ctrl-alt-keypad_plus key worked. nVidea GeForce2 MX400, using the driver which came with X 4.3.

Second install was on an empty Toshiba Satellite laptop, with some kind of ATI chipset. After the RH9 install, it initially had the same problem you have. The RH9 install only put mode 640x480 in the /etc/X11/XF86Config , and adding the higher-res modes, as you already have, partially solved the problem on that machine. The GUI resolution change dialog now really works, but ctrl-alt-keypad_plus is still ignored.

Two installs of RH9 on empty desktop machines still have the same problem your FC1 install has. Their /etc/X11/XF86Config files look like yours, except that they have Matrox G400 video cards. They use the Matrox drivers which came with X 4.3.

Also have an RH 7.2 machine which did not have this problem. But I installed a second monitor and updated closed-source video driver from Matrox Web site. One of those actions, or the combination of them, caused that machine to become unable to change video modes with ctrl-alt-keypad_plus (fortunately, it's stuck in 1280x1024). I had hoped to resolve this machine's problem by installing FC2, when it becomes available, but this thread makes me think that might not help.

My best guess is that the problem may be somehow related to the new-with-RH9 BlueCurve GUI layer, which didn't get applied to (or activated on?) the one RH9 machine which was an upgrade from RH7.3. Has anyone seen this stuck-in-low-res problem with a distro which is neither RedHat, nor an outgrowth of RedHat (like Fedora is)?


newbrier 04-09-2004 01:31 PM

Follow Up

I am having the exact same problem with Fedora Core 1 - were you able to resolve the issue? if so how?



All times are GMT -5. The time now is 10:59 PM.