-   Fedora (
-   -   Can't get X forwarding working with SSH. (

pdeman2 06-02-2006 04:14 PM

Can't get X forwarding working with SSH.
I've used sshd on a number of different operating systems, but only with Fedora have I had an X forwarding issues. I've configured the sshd_config file to allow for X forwarding. Whenever I try to run a graphical program on my Fedora server, it either just doesn't work or it says something like "could not initialize the graphical user interface".

I've looked at everything in the sshd_config file, and I can't seem to find the problem.

Thanks in advance.

Brian1 06-02-2006 05:14 PM

How are you connecting? Command line or gui app?
In command line I use the -Y to enable X over the ssh session.
ssh -Y username@IP_address


pdeman2 06-03-2006 12:36 PM

I always use the CLI. For the command, I've always used -X on everything to enable X. I tried using -Y and I get the same result I did with -X.

pdeman2 06-04-2006 02:01 PM


spooon 06-04-2006 05:09 PM

What is the output of "echo $DISPLAY" on your local computer? What is the output of "echo $DISPLAY" on the remote computer when you log in through SSH? Does your problem occur with only some programs, or all X programs?

pdeman2 06-04-2006 05:17 PM

On both the local and the remote machine echo $DISPLAY shows: localhost:10.0

I've had this issue with every X program I've tried.

pdeman2 06-05-2006 08:30 PM

I don't pretend to know anything about this, but is it possible it has to do with xauth?

pdeman2 06-08-2006 07:37 PM


Crito 06-09-2006 01:42 AM

Don't have a solution to your problem, but I just ssh'd into my FC5 box from SuSE 10.1 with X forwarding and ran a couple apps (tvtime blew up BTW... was worth a try, lol.) So it works for me. I have firewall and selinux disabled though, if that makes any difference. ;)

pdeman2 06-09-2006 04:27 PM

Well, I just took this to No luck yet, but it's a new thread.

Thanks for the help.

Crito 06-09-2006 05:34 PM


Originally Posted by pdeman2
I've configured the sshd_config file to allow for X forwarding.

Well, if it seems to be working for everyone else (even with firewall and selinux enabled) then it's likely something you did to the sshd_config file, IMHO. I didn't have to do anything to it for X forwarding to work.

pdeman2 06-09-2006 10:06 PM

Well, the first time I tried to get X working, I was using the original configuration. By saying I configured it to allow X forwarding, I really meant that the config file said X forwarding was enabled.

pdeman2 06-13-2006 03:08 PM

OK, I'm bumping this. I really can not find a solution.

pdeman2 06-14-2006 03:01 PM


ride153 06-15-2006 01:39 PM

Try freenx i use it to access my linux box when a gui is needed. if i only need a console then i just use ssh that way.

All times are GMT -5. The time now is 03:52 PM.