-   Fedora (
-   -   Can't compile nvidia nforce drivers in AT kernel (

kalvnhobbz 01-25-2004 02:12 PM

Can't compile nvidia nforce drivers in AT kernel

First, allow me to curse Nvidia for their stupid drivers that
cannot be included in the default source tree >:^[ It seems
that all of the problems I have had with this new nForce board
are purely related to getting the stupid drivers to work...

Anyway, I'm attemping to follow Jarod's guide for doing a MythTV
install on Fedora Core. I am at stage 7 of the guide, right after
I installed the new AT kernel and rebooted. As per the guide, I
am trying to rebuild the Nvidia drivers against the new kernel
and no matter which build method I try (using the rpmbuild that
worked earlier in the guide or just trying to build the tarball
by hand) I keep getting unresolved symbols.

Things to note:

Since the network on the box in question is not working, I'm
transcribing all this info by hand, thus there may be a typo or

The rpmbuild --rebuild from step #5 worked fine (using the stock
Fedora kernel).

I could not do the apt-get for the kernel in step #7, so I
downloaded the latest RPM and installed the source and kernel
via RPM -Uvh.

Nvidia: nvidia_nforce_10_0261src.rpm (from nvidia's site)

Example error from the "rpmbuild --rebuild nvidia_nforce_10_0261src.rpm":
depmod: *** Unresolved symbols in /lib/modules/2.4.22-1.2163.nptl_32.rhfc1.atBOOT/kernel/drivers/net/nvnet.o

I get the same error from a manual build when I do a make install.

Anyway, this is a virgin install that has followed Jarod's guide
except for the rpm-instead-of-apt-get I mentioned above. Hopefully
that's enough info, but if I can provide something else, just let
me know.

Does anyone know what's going on here? Anything other than the
fact that the Nvidia driver install process sucks, that is ;^)

This describes exactly the same problem I'm having installing the ethernet nForce drivers for my SN41G2 - i did use apt-get, and i've tried older AT kernel versions as well and no luck. Any ideas?

GraemeK 01-26-2004 03:44 AM

i got the same errors also. i gave up and justed a 3com card instead and left the nforce nic for windoze.


kalvnhobbz 01-26-2004 08:44 AM

i'm not sure what i did, but i switched back to booting the AT kernel and for some reason the NIC worked. this is after trying rpmbuild and rpm several times already....

course now i have the problem of getting the line-in working on the sn41g2.

All times are GMT -5. The time now is 09:43 PM.