-   Fedora (
-   -   Can Yum download and install Ndiswrapper? Is there another wireless alternative?? (

rtoney5 11-02-2007 10:40 AM

Can Yum download and install Ndiswrapper? Is there another wireless alternative??
I'm just about to give up on going wireless with Fedora 7. I tried many times to download it manually, only to find more convoluted instructions on how to install ndiswrapper. Tried searching Yum to have it download and install it, but it says it cant find it. From what I see on different posts in google, once ndiswrapper is installed you can open it from your panel and just plug in your wireless configuration. That I can do, but how do you simply install it on Fedora 7 so that it appears in the Panel or Desktop?? Is there some other alternative? I have a USB wg111t Netgear wireless adapter. With all of the problems I see people post for wireless issues, why didn't Fedora make ndiswrapper a part of the main desktop??

Lenard 11-02-2007 11:23 AM

Yes, it fact after adding a third party repo like freshrpms it is as simple as:

rpm -ivh

yum install dkms-ndiswrapper

ranger_nemo 11-02-2007 11:28 AM

The easiest way to install ndiswrapper is to use the Livna repo in yum. Go here... and install the repo rpm, then yum install ndiswrapper.

> ...why didn't Fedora make ndiswrapper a part of the main desktop??
For the same reason they didn't configure-in MP3 support.

rtoney5 11-02-2007 11:35 AM

Ok I'll try them both...

Lenard 11-02-2007 01:12 PM

No the easiest way is freshrpms, no need to keep re-installing ndiswrapper and additional drivers every time the kernel is updated. With the freshrpms version the dkms-ndiswrapper automatically installs ndiswrapper on boot.

rtoney5 11-05-2007 12:09 PM

Ok I tried the freshrpms download and install. But after reeboting I could not see ndiswrapper installed anywhere. I do see a dkms auto started or something like that on the boot up screen. Even tried the command "yum install dkms-ndiswrapper", but it did not work. What is the exact path again on the "rpm -ivh" link?? I might have downloaded the wrong one, couldn't figure out the freshrp....fc.noarch piece of the link.
By the way.... I haven't tried the wireless on Damn Small Linux yet, but how come they have an NDISWRAPPER on their MYDSL extension gui? Comes right up there, why not Fedora?

Lenard 11-05-2007 01:34 PM

Check if they are installed;

rpm -qa freshrpms-release dkms-ndiswrapper

If they are then you are set, the only things you have to do is configure the wireless device;,installation/

Start at the Install Windows driver section and make sure you have a line entry in the /etc/modprobe.conf file like: alias wlan0 ndiswrapper

Also look around this forum about blacklisting the bcm43xx driver.

rtoney5 11-05-2007 09:18 PM

Well I tried the rpm -qa freshrpm thing, but ndiswrapper was not in the modprobe.conf file. Everytime I goto the directory where the ndiswrapper is /home/userMe/Download/ndiswrapper-1.48/utils and try to run ndiswrapper -i wg11t.inf it says ndiswrapper is not a vaild command. I'm officially giving up on this thing. It should not be this hard. Why they can't make a simple gui or something that will install the darn program in the menu and just press the button to configure, I don't know. Thanks for your help anyway. I'll just have to run an rj45 through my walls and closet from my router downstairs. Problem solved...

Lenard 11-06-2007 07:15 AM


/home/userMe/Download/ndiswrapper-1.48/utils and try to run ndiswrapper -i wg11t.inf it says ndiswrapper is not a vaild command.
You have confused yourself a tiny bit, delete this dirctory. Remember you just installed nidwrapper using yum and this was an rpm file. The ndiswrapper utility is found in /usr/sbin/, so as root type something like;

/usr/sbin/ndiswrapper -i /path/to/the/file/wg11t.inf
or from where wg11t.inf is loacted; /usr/sbin/ndiswrapper -i wg11t.inf

rtoney5 11-06-2007 04:06 PM

Ok I'll give it one more try when I get home today...

rtoney5 11-06-2007 08:25 PM

Ok, installed the ndiswrapper, but how do I configure it now. Nowhere in the menus does it say to ocnfigure the wep .etc. I thought there was a gui to type all of this stuff in... I rebooted cause I couldn't figure out the modprobe ndiswrapper thing.

Lenard 11-07-2007 07:42 AM

You have Network Manager, Network Configuration and wpa_supplicant_GUI for this, all should be available from the menu. I'm old school and do not use these tools instead I create/edit the files as needed, so I cannot help much with the GUI tools.

Old School way;

Inure the /etc/modprobe.conf file has a line entry: alias wlan0 ndiswapper

Create/edit the /etc/sysconfig/network-scripts/ifcfg-wlan0
Sample file;


Create/edit the /etc/sysconfig/network-scripts/key-wlan0 file for WEP encryption
Sample file;

# for HEX uppercase letters only
# for plain text or ascii case sensitive

Edit the /etc/wpa_supplicant/wpa_supplicant.conf file for WPA encryption
Sample file is already on your system.

This forum has numerous examples and other threads which cover this topic, use this forum's search tool to find them.

rtoney5 11-21-2007 12:42 AM

Sorry, I got tied up with other things. Ok, added the 2 files you suggested and updated the essid with the one that I use for windows and my wep encryption key. Every time I try to activate the wireless USB device, it says that the device is not present. But when i type ndiswrapper -l, it says the drivers are installed. Also when I type lsusb, one of the numbers show up match the numbers that are on the list of the ndiswrapper -l list. Not sure what i'm missing here. I was able to successfully use Ubuntu wirelessly with nidswrapper, just having trouble configuring Fedora7 right now. I have the moonshine version. What do you suggest I do now?

PTrenholme 11-21-2007 09:00 PM

This isn't the question you asked, but Fedora 8 makes the process much simpler. When I did a fresh install of F8 on my laptop, all I can recall needing to do to get my wireless system running was to install the correct drives so the device was active after a boot, and then right-click on the network icon, select my access point from the drop=down list, and enter the password.

Of course on F7 it's almost that easy as well, although I seem to remember that I needed to do a system-config-network before the device was finally available.

rtoney5 11-26-2007 03:18 PM

Hi Lenard:
Still no joy on my problem with wlan0 wireless usb not being recognized. Any other suggestions?

All times are GMT -5. The time now is 02:44 AM.