Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Fedora This forum is for the discussion of the Fedora Project.


  Search this Thread
Old 04-06-2005, 07:07 PM   #1
LQ Newbie
Registered: Jan 2005
Distribution: Fedora Core 3
Posts: 13

Rep: Reputation: 0
Can't mount data cds in FC3

Whenever I try to load a data cd (But audio cds still will work) via cli or gui I get the following error:
/dev/hda: Input/output error
mount: block device /dev/hda is write-protected, mounting read-only
/dev/hda: Input/output error
mount: I could not determine the filesystem type, and none was specified

Until earlier today while fiddling around with Age of Empires 2 in Cedega data cds were automatically mounted and a icon appeared on my desktop, I found a command that allows me to mount a cd via root in the terminal but that isn't much of a solution.

Here's my fstab:

# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
/dev/hdb                /media/cdrom            auto    pamconsole,exec,noauto,managed 0 0
/dev/hda                /media/cdrecorder       auto    pamconsole,exec,noauto,managed 0 0
/dev/fd0                /media/floppy1          auto    pamconsole,exec,noauto,managed 0 0
EDIT: Now that I've tried a bunch of other cds it seems that it's just certain discs that won't load like my PS1 backups and my EverQuest cd (A original). The EverQuest cd gives me a different error message:
mount: block device /dev/hda is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/hda,
or too many mounted file systems

I know these cds are just fine, they work just fine on my Windows computer and my PS2. Why is Linux having trouble reading just these particular discs? I had no such problems with them when I was running SuSE 9.1

Last edited by TheBelush; 04-06-2005 at 09:21 PM.
Old 04-07-2005, 09:56 AM   #2
Senior Member
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
Try a few things for diagnostics and post the output.

1) From the command prompt with the “bad” CD in the CD-RW drive:

#umount /media/cdrecorder
#mount -t auto /dev/hda /media/cdrecorder

This assumes that /media/cdrecorder exists. If not, us mkdir to create it or something like /mnt/cd.

2) Try the same thing in the (other) CD-ROM drive.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I burn data cds for mp3-diskman? linmix Linux - Hardware 6 10-28-2005 03:46 PM
can't mount audio cd, FC3 (data cd okay) linuxdork Fedora 8 03-12-2005 05:17 AM
Burning Data and Iso Cds on Fedora wasabi Fedora 6 06-13-2004 02:58 AM
cannot read data cds ac404 Linux - Hardware 1 03-15-2004 12:59 PM
Data cds detected but not audio.. sh1ft Slackware 5 03-09-2004 10:25 PM > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 07:19 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration