-   Fedora (
-   -   can't boot windows, just Linux FC12. (

trien27 03-07-2010 08:50 PM

can't boot windows, just Linux FC12.
I can't boot into Windows XP, just Linux. I can't input the encrypted password unless I'm in Linux. I get this message:
Unable to mount device
Error locking device: cryptsetup exited with exit code 255:device-mapper: remove ioctl failed: Device or resource busy. No key available with this passphrase.

I put in the encrypted password, then after su as root,
Linux is still locking LVM 2 which is Windows XP.

I was just trying to get into Windows XP to update some software, but this happens.


Glennzo 03-08-2010 04:32 AM

If you can't boot into Windows after a fresh install of Fedora then likely grub is pointing to the wrong partition. Typically, the Windows stanza in the grub menu, after a fresh install, is something on the order of

title Other
rootnoverify (hd0,0)
chainloader +1

Most likely it needs to be

title Other
rootnoverify (hd0,1)
chainloader +1

trien27 03-08-2010 06:50 PM

changed it from (0,0) to (0,1)
I meant I changed it from rootnoverify (hd0,0) to rootnoverify (hd0,1)....

Very close but still no cigar... yet.

It does go into the other LVM but... there's an error message:

Error 13: Invalid or unsupported executable format
Press any key to continue..._

Pressed any key, but same screen with same error message pops up. So, here I am coming back here, to post the results.

trien27 03-08-2010 06:58 PM

Remove encrypted passphrase?
I guess I have to reinstall Fedora 12 again? but without encryption passphrase enabled?! Maybe that could solve this headache?

I used to be when I boot it'll go and have the LUKS in the startup screen, then I'd put in the passphrase, then I'd let it load then I'll be able to choose Linux or Windows, and it'll work. But now I can't type in the passphrase UNTIL AFTER I'm in Fedora?!

Will getting rid of encrypted passphrase this way turn Linux into Windows[an unstable system where you can hack or crack into anytime]?


foottuns 03-08-2010 07:12 PM

install Fedora again without the encryption and try to encrypt your harddisk with TrueCrypt, maybe this will help you, since you wanna to encrypt your harddisk.

trien27 03-09-2010 08:53 PM

I tried all suggestions: reinstalled without encryption, changed (hd0,0) to (hd0,1) for Other [Windows LVM] but still Windows XP won't come up, just the same error message I've posted before or it'll just go back to the startup screen.

foottuns 03-10-2010 07:21 AM

you have to install first XP and after that you can install Fedora....

trien27 03-10-2010 09:17 PM

I have both systems already loaded onto separate hard drives?!

Now, system won't boot & load with grub menu, but instead with startup screen where I have to click F12, then Secondary drive, before it loads with grub, but now i can only load FC12, not Windows?!

From grub menu, if I choose, Other to get into Windows, it'll go, but ends with Windows start menu with options: Load Windows normally, Load Windows with Safemode, last known working Windows. Doesn't matter what i pick, it'll restart and go back to the splash screen with Dell, then I'll have to make a selection at Start up menu to choose hard drive, etc... AGAIN & AGAIN?! Again?

Thanks again.

yancek 03-10-2010 09:59 PM

I think it would help if you would boot Fedora, enter a terminal and run the command (as root): fdisk -l (lower case Letter L) and post that partition information here.

Also, post the contents of the /boot/grub/grub.conf file.

trien27 03-10-2010 10:42 PM

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x07f207f2

Device Boot Start End Blocks Id System
/dev/sda1 1 6374 51199123+ 7 HPFS/NTFS
/dev/sda2 * 6375 6400 204800 83 Linux
/dev/sda3 6400 9729 26744237+ 8e Linux LVM

Disk /dev/sdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xc8c2c8c2

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 7649 61440561 7 HPFS/NTFS
/dev/sdb2 7650 9729 16707600 f W95 Ext'd (LBA)
/dev/sdb5 7650 9729 16707568+ 7 HPFS/NTFS

Disk /dev/dm-0: 26.3 GB, 26310868992 bytes
255 heads, 63 sectors/track, 3198 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-0 doesn't contain a valid partition table

Disk /dev/dm-1: 1073 MB, 1073741824 bytes
255 heads, 63 sectors/track, 130 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-1 doesn't contain a valid partition table

trien27 03-10-2010 10:44 PM

my grub file
# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,1)
# kernel /vmlinuz-version ro root=/dev/mapper/VolGroup-lv_root
# initrd /initrd-[generic-]version.img
title Fedora (
root (hd0,1)
kernel /vmlinuz- ro root=/dev/mapper/VolGroup-lv_root LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet
initrd /initramfs-
title Other
rootnoverify (hd0,1)
chainloader +1

yancek 03-11-2010 09:22 AM

You have two hard drives and windows partitions on both. You have windows on sda1, sdb1 and sdb5. Which drive do you have your system files for xp on? If they are on sda1, your entry for xp should be:

title xp
rootnoverify (hd0,0)
chainloader +1

You don't have xp set as active but do have the Linux partition set active (noted with the *) in fdisk output. Linux doesn't need that, xp does.

If your xp system files are on the second drive, your system should boot with this entry:

title xp
rootnoverify (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1

You won't need the "makeactive" here as this partition is set active.

trien27 03-11-2010 08:38 PM

Location of Windows XP
Here's what I should have on each:
sda1 = Linux
sdb1 = Windows


map (hd0) (hd1)
map (hd1) (hd0)

Is this line necessary?
I'll restart and see what happens.

Edit: I tried your suggestion and it works, therefore, I won't change a thing.

Thanks a lot.

All times are GMT -5. The time now is 12:36 PM.