-   Fedora (
-   -   Build to wrong kernel (make install, etc.) (

Bob Jones 09-05-2007 02:53 AM

Build to wrong kernel (make install, etc.)
Hi all - I believe my kernel is messed up because I can not seem to build packages to the correct kernel.

I updated my kernel a couple days ago to: All went for all I could see. I run em2880 for a USB hdtv prostick and I went to reinstall the package (per instructions at:; as I normally do, but the "make" command tried to install to the following directory:


Notice that the end of the "kernel" version is 1-32.fc6 - NOT 2.42.fc6. I thought maybe something was going wrong with the em2880 drivers and firmware so I concentrated most of my time there.

However, I do not think his is the problem. I recently upgraded kernels again to: This time my nvidia drivers did not install correctly (normally I have to reboot, remove the old files; reinstall the new files and reboot again for the nvidia drivers to work). During the first reboot, I saw an automatic message that the nvidia drivers were already being installed. Before I got to the welcome screen I received an error indicating that the "x server could not start" - or something along those lines. This is normal after a kernel upgrade . . . so I just remove the old nvidia drivers and insert new ones therafter; reboot and everything works fine like I said above.

This time the drivers did not install correctly and I cannot get the nvidia drivers to load. My guess is that the nvidia drivers are building against the kernel and not the newest kernel. I also get the same error above when I try to install the em2880 drivers.

Does any one know how to change "make" to install to the correct kernel version?

Let me know if there is any other information I can provide. Any help would be greatly appreciated.

Thanks - BJ

Lenard 09-05-2007 03:59 AM

Confirm that your kernel-devel and kernel-headers packages match your running kernel;

uname -a
rpm -qa 'kernel*' | sort

If no then do something like: yum update kernel-devel kernel-headers

Bob Jones 09-18-2007 01:27 AM

Yeah - I was all up-to-date. Not exactly sure what was going on . . . but I had a second installation of Fedora (F7) on a second hard drive. I just manually deleted the contents of the drive when I booted into FC6 and everything seemed to work fine. Weird.

All times are GMT -5. The time now is 12:00 AM.