LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 06-04-2006, 12:15 PM   #1
salmanal
Member
 
Registered: Jan 2005
Location: Syracuse, NY
Distribution: Debian 8 KDE
Posts: 247

Rep: Reputation: 30
Booting Interactively and saying NO to the following:


After running FC 5 for a few days, I came closer to what failed in the Boot Process.

Kernel
2.6.15-1.2054

When I say, "yes" to all - no boot

When I say, "no" to the following, it boots normally.

avahi-daemon, firstboot, and sshd.

I read in another forum that ATI Video cards can be a problem.

I have an ATI Radeon R100 on an Envision LCD monitor.

Thanks for the assistance,

-s
 
Old 06-04-2006, 12:24 PM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
I notice that you're running an old kernel; have you applied maintenance?

yum -y update yum
yum -y update
 
Old 06-04-2006, 10:53 PM   #3
salmanal
Member
 
Registered: Jan 2005
Location: Syracuse, NY
Distribution: Debian 8 KDE
Posts: 247

Original Poster
Rep: Reputation: 30
Now running Kernel 2.6.16-1.2122_FC5

My system is now Updated; and, once I returned home, I just let the system start on it's own- doesn't completely boot.

I tried Interactively saying, Y only to sshd - system stopped.

Tried interactively saying Y only to Firstboot - blue screen.

Tried interactively saying Y only to avahi-daemon - stsyem stopped.

Successful boot was by saying N to avahi-daemon, firstboot, and
sshd. I feel "back to square one," but at least I can boot.
 
Old 06-05-2006, 12:11 AM   #4
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
Can you define "system stopped" and "blue screen"?
 
Old 06-05-2006, 01:19 AM   #5
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 2,074

Rep: Reputation: 429Reputation: 429Reputation: 429Reputation: 429Reputation: 429
Quote:
Originally Posted by salmanal
Successful boot was by saying N to avahi-daemon, firstboot, and sshd.
sshd and avahi-daemon are networking services which should really only be running if you're running a server, anyway. Perhaps you should disable those in your startup.

You should also do the same with the firstboot service, which is really only provided to assist configuration the first time you boot the system.

None of these have anything to do with your ATI card.
 
Old 06-05-2006, 05:54 PM   #6
vinbob
Member
 
Registered: May 2005
Location: Fareham, UK
Distribution: HP-UX 11i, Fedora, Ubuntu, Debian, RHEL, OEL, CentOS
Posts: 75

Rep: Reputation: 17
I've had the same issue recently, seemed as though yum is pairing up the wrong livna Xorg fglrx driver with the latest livna ATI kernel module.
Maybe that will teach me not to be an update whore as it did work OK.


You could try just disabling the ATI config by running the following as root;

ati-fglrx-config-display disable


Me? I got rid of the proprietory ATI drivers (I'll wait for the new version due sometime this month) and I've kept open source driver for now.

e.g.

su -
yum remove kmod-fglrx*

(Yum will prompt to remove the dependant Xorg driver, say yes)


If you need OpenGL acceleration try installing an older version of the livna kmod-fglrx package.


HTH

Last edited by vinbob; 06-05-2006 at 06:47 PM.
 
Old 06-26-2006, 06:48 PM   #7
salmanal
Member
 
Registered: Jan 2005
Location: Syracuse, NY
Distribution: Debian 8 KDE
Posts: 247

Original Poster
Rep: Reputation: 30
Disabled sshi-daemon, sshd, and firstboot as startup

and I still have trouble starting the system.

I booted interactively again to confirm those services
were not starting. Now after I start the last service
on my screen ( service local), the system freezes on that window.

When I let the system stat without my intervention,
I get "Input not supported."

I'm sorry to be do long in responding, I was too afraid to make any changes on the system until a calendar event
took place.

I'd like to disable the ATI Driver for my video card,
is there a way to start the system to do maintenance
as in MS Windows "Safe Mode?"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Must boot interactively salmanal Fedora 3 06-02-2006 12:07 AM
Logging in as Root Interactively chrissanders Linux - Newbie 16 11-22-2005 02:53 PM
changing password non-interactively fili Linux - General 3 11-05-2004 06:10 AM
Remove files non-interactively ar1 Linux - Newbie 3 06-02-2004 06:32 PM
sending telnet commands non-interactively JustinHoMi Linux - Networking 4 09-29-2001 01:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 09:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration