LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 10-29-2006, 05:07 PM   #1
Txabuzer
LQ Newbie
 
Registered: Aug 2005
Location: Lake Forest, Ca.
Distribution: PCLinuxOS
Posts: 24

Rep: Reputation: 15
Boot Fedora from Kubuntu


In the past Ive always used lilo on the mbr to boot multiple distro's.
I did it the cheesey way, by putting grub on the root partition of the second linux distro and pointing lilo to that partition.
Now I'd like to use grub for both linux's.
Kubuntu's grub is the one I'm using, and I assume its on the MBR

My set up is:
HDA1 Kubuntu root
HDA2 Extended
HDA3 Fedora Boot
Hda4 Fedora
HDA5 Kubuntu swap
HDA6 Kubuntu home

I installed fedora 6 but I'm looking at the fedora 5 bible and it has a grub entry like this:

# grub.conf generated by anaconda
#boot=/dev/hda
default=0
timeout=5
splashimage=(hd0,4)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.15-1.1955_FC5)
root (hd0,4)
kernel /vmlinuz_2.15-1.1955_FC5 ro root=LABEL=/
initrd /initrd-2.6.15-1.1955_FC5.img

So if I add:

title Fedora Core (dafault fedor 6 kernel_FC6)
root (hd0,2) is it 2?
kernel /vmlinuz_default fedora 6 kernel_FC6 ro root=LABEL=/
initrd /initrd-default FC6 kernel_FC6.img

To the grub,conf file in kubuntu will it work ?
P.S. I would have tried this on my own but I dont know what the Fedora 6 kernel number is.
 
Old 10-29-2006, 06:15 PM   #2
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 62
That should work - I don't know what the default kernel in Fedora 6 is, but have a look in Fedora's /boot, and it should be there.

--Ian
 
Old 10-29-2006, 08:28 PM   #3
Txabuzer
LQ Newbie
 
Registered: Aug 2005
Location: Lake Forest, Ca.
Distribution: PCLinuxOS
Posts: 24

Original Poster
Rep: Reputation: 15
Thanks for the reply
I think I've found the kernel no. from a screen shot on a how to install fedora 6 web site, since I cant boot fedora I dont know how to get into any files.
The kernel they showed was 2.6.18-1.2798.fc6 if anyone knows different please let me know.
I had another question though, I dont seem to have a /boot/grub/grub.conf file on kubuntu, I dont know if this file is only generated when you have more than one operating system to boot at the time of install or if I have to edit some other file that's taken grub.conf's place.
 
Old 10-29-2006, 08:42 PM   #4
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 62
On Kubuntu, the grub file is /boot/grub/menu.lst.

I suggest that you mount your fedora boot partition (eg: mount -t ext3 /dev/hda3 /media) and then ls the contents. Add the relevant files to the Grub config on Kubuntu.

I hope this helps
--Ian
 
Old 10-30-2006, 12:41 PM   #5
Txabuzer
LQ Newbie
 
Registered: Aug 2005
Location: Lake Forest, Ca.
Distribution: PCLinuxOS
Posts: 24

Original Poster
Rep: Reputation: 15
Thanks for the mount command it worked great and I was able to get a list of the fedora boot files:


file:///media/config-2.6.18-1.2798.fc6
file:///media/grub
file:///media/initrd-2.6.18-1.2798.fc6.img
file:///media/lost+found
file:///media/symvers-2.6.18-1.2798.fc6.gz
file:///media/System.map-2.6.18-1.2798.fc6
file:///media/vmlinuz-2.6.18-1.2798.fc6

file:///media/grub/splash.xpm.gz

and these are the changes I made to menu.list on kubuntu:

## ## End Default Options ##

title Ubuntu, kernel 2.6.17-10-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/hda1 ro quiet splash
initrd /boot/initrd.img-2.6.17-10-generic
quiet
savedefault
boot

title Fedora 6, kernel 2.6.18-1.2798.fc6
root (hd0,2)
kernel /boot/vmlinuz-2.6.18-1.2798.fc6 ro root=LABEL=/
initrd /boot/initrd-2.6.18.2798.fc6.img

title Ubuntu, kernel 2.6.17-10-generic (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/hda1 ro single
initrd /boot/initrd.img-2.6.17-10-generic
boot

title Ubuntu, memtest86+
root (hd0,0)
kernel /boot/memtest86+.bin
quiet
boot

### END DEBIAN AUTOMAGIC KERNELS LIST
I've changed /boot/vmlinuz and /boot/initrd to /media/vmlinuz and /media/initrd to just /vmlinuz and /initrd.
and I changed the last half of the kernel line from ro root=LABEL=/ to ro root=/dev/hda3
and I'm still getting Error 15 file not found, so I dont know if I didnt do something right when I installed fedora or if the options on the kernel or initrd line have changed.
Any Ideas
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Yet, Another Kubuntu Boot Problem Freddy the Cat Linux - Desktop 3 08-15-2006 12:38 PM
accessing fedora lvm on Kubuntu Dapper cerealdaemon Ubuntu 1 04-26-2006 02:49 AM
new kubuntu boot looks terrible paddy Ubuntu 7 02-16-2006 11:25 AM
Boot Problems - Kubuntu No772153 Linux - Newbie 1 01-22-2006 04:19 PM
GRUB - kubuntu won't boot notmatt Linux - General 3 08-03-2005 09:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 09:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration