LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 03-31-2018, 01:37 AM   #1
Neyzan
Member
 
Registered: Jul 2010
Location: Athens, Greece
Distribution: Slackware, Arch, Fedora.
Posts: 90

Rep: Reputation: 3
Blueman requires authentication twice when logging into account


When I log into my user account Blueman asks twice for authentication. First with the message "Networking requires privileges" and then with the message "Setting Rf Kill State requires privileges".
I'm trying to find a way to have my user authenticated by default, which I'm assuming can be done by adding the user to some group, but I cannot seem to find which one. "lp" group was suggested by some posts, but my user is added to that one and the double authentication (triple, if you count the original login to the user account) persists.
An option could always be to deactivate authentication for Blueman entirely and for all users, but I would prefer to avoid that.

I'm using Fedora 27 with LXQt 0.11.1.
 
Old 04-04-2018, 05:00 AM   #2
voleg
Member
 
Registered: Oct 2013
Distribution: RedHat CentOS Fedora SuSE
Posts: 337

Rep: Reputation: 51
Been there.
Add yourself to "wheel" group. Probably you've already did that for other reason.
Then create new file /etc/polkit-1/rules.d/81-blueman.rules with follwing content:
Code:
polkit.addRule(function(action, subject) {
  if (action.id == "org.blueman.rfkill.setstate" && subject.local && subject.active && subject.isInGroup("wheel")) {
      return polkit.Result.YES;
  }
  if (action.id == "org.blueman.network.setup" && subject.local && subject.active && subject.isInGroup("wheel")) {
      return polkit.Result.YES;
  }
});
If you do not want make deal with wheel, fix code to other group name.
 
2 members found this post helpful.
Old 04-08-2018, 08:27 AM   #3
Neyzan
Member
 
Registered: Jul 2010
Location: Athens, Greece
Distribution: Slackware, Arch, Fedora.
Posts: 90

Original Poster
Rep: Reputation: 3
@voleg, thanks! this did indeed solve the issue.

Now I have another issue with blueman, since the kernel 4.15.14 upgrade, you can see it here.
 
Old 09-01-2018, 02:43 PM   #4
thecarlosfilipe
LQ Newbie
 
Registered: Feb 2018
Posts: 4

Rep: Reputation: Disabled
Smile

Quote:
Originally Posted by voleg View Post
Been there.
Add yourself to "wheel" group. Probably you've already did that for other reason.
Then create new file /etc/polkit-1/rules.d/81-blueman.rules with follwing content:
Code:
polkit.addRule(function(action, subject) {
  if (action.id == "org.blueman.rfkill.setstate" && subject.local && subject.active && subject.isInGroup("wheel")) {
      return polkit.Result.YES;
  }
  if (action.id == "org.blueman.network.setup" && subject.local && subject.active && subject.isInGroup("wheel")) {
      return polkit.Result.YES;
  }
});
If you do not want make deal with wheel, fix code to other group name.

Hello, @voleg! I would just like to thank you for your tip too. I had the same problem and thanks to your help I was able to solve it here. Thanks!
 
  


Reply

Tags
blueman, fedora, groups


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Blueman - the future releases will require PolicyKit authentication: which group is preferable? yars Slackware 1 05-25-2016 01:10 AM
Authentication failure with Blueman applet and cell phone. camorri Slackware 1 05-29-2015 06:36 PM
[SOLVED] Linux Ent 5 only root logging in.not other users logging authentication failure error ravikavala Linux - General 1 09-30-2014 03:46 AM
blueman requires pulseaudio in 64 current ivandi Slackware 10 06-28-2012 11:36 PM
Prevent user account from logging in but allow su to account DejaCpp Linux - General 4 07-26-2006 11:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 10:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration