LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 06-19-2005, 12:49 PM   #1
dubya
Member
 
Registered: Mar 2004
Location: Kitchener, Ontario, Canada
Posts: 386

Rep: Reputation: 30
Bad line in fstab


Hey,

I hope everyone's installations of FC4 are going smoothly.

I've had one glaring problem with my installation. It seems the fstab file wasn't created properly. Whenever I boot or use the mount -a command, I get this message:
Code:
[mntent]: line 9 in /etc/fstab is bad; rest of file ignored
Here is my fstab file:
Code:
LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
/dev/devpts             /dev/pts                devpts  gid=5,mode=620  0 0
/dev/shm                /dev/shm                tmpfs   defaults        0 0
LABEL=/home             /home                   ext3    defaults        1 2
/dev/proc               /proc                   proc    defaults        0 0
/dev/sys                /sys                    sysfs   defaults        0 0
/dev/hda2               /mnt/windows            ntfs    uid=tom,ro      0 0
LABEL=r KDEDvdrecord    swap                    swap    defaults        0 0
So, obviously it's the line "LABEL=r..." that causes the problem. It looks odd to me and there's no other line that indicates where my swap space is.

I'm not too familiar with using fstab files so if anyone knows how I can fix it, please help; I would appreciate it very much. Thanks in advance.
 
Old 06-19-2005, 01:14 PM   #2
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
change LABEL=r KDEDvdrecord to /dev/hdx. x is the partition number where swap will be mounted. If you dont know run fdisk -l as root and post the output.
 
Old 06-19-2005, 03:49 PM   #3
dubya
Member
 
Registered: Mar 2004
Location: Kitchener, Ontario, Canada
Posts: 386

Original Poster
Rep: Reputation: 30
Thanks, that seemed to do it!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[mtent] line 7 in /etc/fstab is bad (CD Drives wont Mount) shof515 Linux - Hardware 1 11-24-2005 09:57 AM
Whats wrong with this line of fstab Boffy Linux - General 4 02-25-2005 05:32 PM
Weird fstab line dom_lochet Linux - Newbie 3 02-10-2005 07:23 AM
WARNING: Bad format on line 10 of /etc/fstab thetwin Linux - Newbie 22 03-05-2003 01:55 AM
Adding line to fstab in Linux 7.1 CyberSteve Linux - Newbie 1 02-03-2002 07:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 08:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration