-   Fedora (
-   -   Azureus NAT error on port 6881 (

dealerman 08-10-2005 11:20 PM

Azureus NAT error on port 6881
Got Azureus installed and can't seem to get port 6881 to work. I've researched thoroughly and disabled SELinux, firewall, and triple-checked my IPTable rules. The standard bittorrent is still working just fine. Any advice would be greatly appreciated.

v00d00101 08-11-2005 03:27 AM

Its possible:

Your isp is blocking port 6881.
You havent added the port to your router/firewall (if you have one).
Your iptables rules are wrong.

Check the router and iptables possibilities first, and then try changing the azureus port thats used to something in the 50000-60000 range.

You could also try asking your question on #azureus-users @ , there are a lot of people with experience in dealing with these types of problems. Chances are it can be ironed out very quickly.

d00bid00b 08-18-2005 09:17 AM

Not that it is any consolation to you dealerman, but I am experiencing the exact same problem using Azureus via my OpenBSD firewall, despite some very good advice from a few people who tried to debug the issue with me, examining and changing pf rules, etc.
I've concluded that the port is being blocked by my ISP because I'd be damned if I can get it working without spitting out a "NAT error" message!! I wonder if Azureus is confined to port 6881 and whether changing that port would by-pass the ISP's blocks?

Any ideas on subverting an ISP's block?

edit: typo

dealerman 08-21-2005 10:42 AM

d00bid00b, wish I knew the answer to that, but I do know that my ISP isn't blocking any ports for torrents (not sure if they're blocking port 25 for the mail though). A couple of things I did try were older versions of Azureus (oldest I could find was I've heard that newer versions had some bugs, but even the older version gives me the same $#@!. I tried opening up more UDP ports in hopes of finding a free one, with no luck. The one glimmer of hope I did experience was after installing, the config wizard selected UDP port 56324 (or something close), and it told me the port was busy instead of NAT error. I've given up for now, I'll just continue to use the standard client which seems to be working without any problems.

All times are GMT -5. The time now is 04:21 PM.