LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 05-15-2007, 08:21 PM   #1
mdorries
LQ Newbie
 
Registered: May 2007
Location: Illinois
Distribution: Fedora Core 6
Posts: 13

Rep: Reputation: 0
Attempted Dual Boot of XP and Fedora. Now MBR will boot straight to Linux.How to fix?


Hello,

I attempted to create a dual boot system of XP and Fedora Core 6. I have got it designated so that on my C drive is XP and my H drive is Fedora. I think I missed a step during the installation guide I had and what happened as far as I can tell is that GRUB(?) took over as the boot loader and I want XP to be the boot loader. I have the XP boot.ini file edited so it can boot to Fedora but how do I have the MBR select the XP boot loader over GRUB? Any help is greatly appreciated because currently the only way I can boot to XP is through a third party booter.

On a separate related question. During the Fedora install I got to the Boot Loader Configuration and accidentally selected the second option instead of Fedora so when selected the default it won't load. I can select Fedora from the menu but it's an inconvenience. How can I switch this to load Fedora by default?

If you need any system information or anything else just let me know.

Thanks for any help provided!

-Mike
 
Old 05-15-2007, 09:37 PM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
This may be helpful:

Some nitpicks on the terminology: The MBR does not select a bootloader. You make a choice as to what bootloader to put in the MBR. I infer that you put GRUB there--but it should have detected the Windows install and set up the GRUB config file.

When you say you edited boot.ini, did you put an instance of GRUB on the C drive also? What specific procedure were you following?

Since you can boot into Fedora, run "cat /boot/grub/menu.lst" and post the results here. Also "fdisk -l" (Run these as root)
 
Old 05-16-2007, 04:23 PM   #3
mdorries
LQ Newbie
 
Registered: May 2007
Location: Illinois
Distribution: Fedora Core 6
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by pixellany
This may be helpful:

Some nitpicks on the terminology: The MBR does not select a bootloader. You make a choice as to what bootloader to put in the MBR. I infer that you put GRUB there--but it should have detected the Windows install and set up the GRUB config file.

When you say you edited boot.ini, did you put an instance of GRUB on the C drive also? What specific procedure were you following?

Since you can boot into Fedora, run "cat /boot/grub/menu.lst" and post the results here. Also "fdisk -l" (Run these as root)
I managed to fix my problem. What I did was re-install Fedora. The problem was the first time I did detect Windows but I changed that detection so instead of looking at sda1 it now looked to sdc2 and that messed it up. But now it works using GRUB to boot both.

As for the the procedure I was using. There was a method I saw posted on these forums on how to do it. It said to copy the boot.lnx file to the c drive and add that option to the boot.ini file. I can't remember the exact URL to this post though.

Also I can get into Fedora but I can't for the life of me figure out where to run those command lines. It's been 3 years since I've used Linux and it just isn't clicking back yet. If you know of any tuturials I can use to reacquaint myself that would be great because I need to find a way to install a driver for my wireless card.

Thanks again!

-Mike
 
Old 05-17-2007, 08:35 AM   #4
james.farrow
Member
 
Registered: Mar 2003
Location: UK Darlington
Distribution: Fedora Freebsd Centos
Posts: 288

Rep: Reputation: 31
What type of wireless card is it??
 
Old 05-17-2007, 05:20 PM   #5
mdorries
LQ Newbie
 
Registered: May 2007
Location: Illinois
Distribution: Fedora Core 6
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by james.farrow
What type of wireless card is it??

It's a linksys WMP54G. I think I found a driver but I'm not 100% sure. If anybody knows of one that will work and easy instructions on installation that'd be great.

Also a new problem has come up with my dual booting. When I boot into Fedora the time will be off. I go to correct it and then when I get into XP that time will be off by 4 hours (ahead) and can't figure out what's causing it. Anybody else have this come up?
 
Old 05-18-2007, 02:43 PM   #6
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Quote:
Originally Posted by mdorries
<snip>Also a new problem has come up with my dual booting. When I boot into Fedora the time will be off. I go to correct it and then when I get into XP that time will be off by 4 hours (ahead) and can't figure out what's causing it. Anybody else have this come up?
That can happen if you've told Fedora that your system is running on UTC whilst XP assumes that you're using you local time zone setting. I'm not sure if you can change the XP assumption, but you can sync Fedora with the XP setting with the system-config-time command.
 
Old 05-18-2007, 03:09 PM   #7
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
I have two different Windows XP and four Linux installations on my desktop computer, the time was always screwed up, some of the Linux installations change the actual bios time setting. I have the two Windows, bios, Fedora and two Mandrake/Mandriva showing the correct time now, but when I try to set the proper time in Debian testing, everything goes out of wack again. I even have ntpdate or similar installed in Debian but I'm not on-line all the time as I use a modem, so time is set to use the hardware clock. It's an inconvenience I live with, I have a clock on the wall just above the monitor to correct it as I spend most of my time in the best GNU/Linux ever "Debian".
 
Old 05-27-2007, 07:22 AM   #8
zeca_pedra
Member
 
Registered: Nov 2003
Location: Funchal, Madeira, Portugal
Distribution: Linux Mint 13
Posts: 37

Rep: Reputation: 15
easy as this

Boot from your Windows XP cd or dvd!
Let windows load the drivers and everything else just as if you were about to install it!
When it arrives to the screen where you're asked to install windows by pressing enter or repair windows installation by pressing the R key, choose this one:
* Repair Windows installation by pressing R key

You will be lead to a black screen where you choose the partition to repair ( C: , normally).

Type in that coomand line interface the following command:

fixmbr

Press Enter

and that's it!
I assume that you already know how to have linux booting from the Windows NT Bootloader but, if not, just ask

:-)

PS - This is very frequent to happen! Although with Debian and Ubuntu the installer allways let me choose where to install Grub (I allways install it to the / - root partition ), I had that same problem with Suse and Mandriva, these distros never «respected» my choice. Can't say why!

Quote:
Originally Posted by mdorries
Hello,

I attempted to create a dual boot system of XP and Fedora Core 6. I have got it designated so that on my C drive is XP and my H drive is Fedora. I think I missed a step during the installation guide I had and what happened as far as I can tell is that GRUB(?) took over as the boot loader and I want XP to be the boot loader. I have the XP boot.ini file edited so it can boot to Fedora but how do I have the MBR select the XP boot loader over GRUB? Any help is greatly appreciated because currently the only way I can boot to XP is through a third party booter.

On a separate related question. During the Fedora install I got to the Boot Loader Configuration and accidentally selected the second option instead of Fedora so when selected the default it won't load. I can select Fedora from the menu but it's an inconvenience. How can I switch this to load Fedora by default?

If you need any system information or anything else just let me know.

Thanks for any help provided!

-Mike
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Boot Fedora Core 6 & XP, How can I make the MBR start XP first? mdorries Fedora 3 05-18-2007 11:38 AM
Dual boot (Booting Windows from Linux MBR) gkrishn Linux - Newbie 17 02-22-2006 11:51 AM
Can't get linux (Disto SUSE 8.2 and XP to dual boot, it goes straight into Linux unrealhippie Linux - Distributions 15 05-07-2004 11:49 AM
MBR with WinXP and Linux Dual Boot Ruined...! truhuska Linux - Newbie 7 04-30-2004 12:49 AM
Dual boot, linux MBR on floppy question? Dobie Linux - Newbie 1 12-15-2003 11:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 11:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration