-   Fedora (
-   -   ATI DRIVERS WORK NOW! Kernel 2.6.11 (

antidelldude 05-28-2005 11:16 AM

EDIT: I wrote this months ago. I'm happy for those people that did get it working. Unfortunatly because linux rapidly changes from month to month so do the installation procedures for various things. I have not yet even tried to install the ATI drivers on the newest Fedora for I am still running the version when I wrote this how-to. I will fully update my install and find the best possible way to install ATI drivers (as bad as they still may be Under linux) and I will then post a new how-to.

I have done it people. I have Gotton ATI's newest drivers to work on the newest update of fedora core 3. I now can use cedega to play games that were once choopy and horrible but are now just like playing them on windows. If you want to find out what I did read on.

1) Log on as root

2) Right-Click on this link and save link as ATI'S WEBSITE

3) Save it to roots home directory and name it something easy to remember like ati.rpm

4) Open a terminal, navigate to where you saved it, and type "rpm -Uvh --force ati.rpm" It will try to force, then it will fail.

5) Next thing you need to do is in the same terminal type "yum install gcc" (If you don't know how to setup yum head over to or just post in this thread asking)

6) Once that is installed, do what step 4 says then continue here. You then need to go download 2 patches from This Website. Again right click and save link as.

7) Then in the terminal type "cd /lib/modules/fglrx/build_mod/"

8) Then type "patch -p0 </path to patch file/p1.patch" (if spelled coorectly it should take about 3 seconds for each patch)

9) Then type "patch -p0 </path to patch file/p2.patch"

10) Then type "sh"

11) When finished at the bottom of the output it will ask you to navagte to a different spot and run "sh"

12) When that is finished type "fglrxconfig" and choose all the default options.

13) Guess what guys and gals, restart the computer, log in, open up a terminal and run "glxgears" If your over all fps is over 2000 (which it should be) you have successfully installed the newest, and so far the best ati drivers I have seen.

14) Now for the Cedega part. Head over to Trans-Gaming, sign up, download point 2 play, have point 2 play download the recent cedega version and microsoft fonts. You're Done.

The games I have had success with so far is Warcraft III Reign of Chaos and Half-Life 2. Just make sure you run your game in a window of 1024x768 and resize your desktop to that window size also an you're good.

If you want to use cedega to play games I would definatly recommend ubuntu over fc3 bcause for some reason it rarely crashes and games run smoother than I had them running in fc3.

Good luck!
Any questions just post here and i'll do my best to answer them. This fix may work for other distros with yum but I have not tried any others except Fedora Core 3 fully yum updated from the livna libraries.

musicman_ace 05-29-2005 03:07 AM

Have you submitted this as an LQ tutorial? There is a submission button in the tutorials page.

antidelldude 05-29-2005 08:26 AM

Just posted there under hadware help. Totally didn't realize that there was a tutorial section. Thanks. Only reason I did it in the forum in the first place though is so people could ask questions.

ethics 05-29-2005 02:26 PM

Worked flawlessly for me, tux racer (i only got it for testing FPS!!) runs properly now.

I had to make the make files executable first with chmod, if you're submittign as a tutorial might ant to add that

antidelldude 05-29-2005 03:22 PM

Thats what I was hoping for. Someone to get some use out of it. If you use the "sh" command you shouldn't have to chmod anything. If you do the ./ then you would have to make executable. If you used the "sh" command and you still had to make them executable i'll add that to the tutorial. Thanks.

asdf_6667 06-03-2005 11:38 AM

ATI FireGL 8800 with Fedora core 3

Yesterday, i've installed fedora core 3 on may machine equipped with a FireGL 8800 board.

I've downloaded the ATI driver from ati's website for X.ORG 6.8 (fglrx_6_8_0-8.12.10-1.i386.rpm), attenpting to install it following the step-by-step procedure found on this thread (by antidelldude, and thx!). I start the driver installation by typing rpm -Uvh --force ati.rpm and the console say failed dependencies and the installation exit. At the step that tells to cd to /lib/modules/fglrx/build_mod/ the console say missing file or directory (or something like that)... i've verified manually by nautilus if the fglrx directory exist, but he is really missing! I can't install the patches found on ""....

What's wrong??? (I'm almost new to linux and appreciate help!)

Thx in advance!

(scuse my bad english!)

mkoljack 06-03-2005 12:27 PM

ATI Drivers
Hi antidelldude--

There are so many how to's with the ati drivers and none of them have worked for me. This is what I get as glxgears output with the "radeon" driver. Of course no 3d, which stinks. I'm using Fedora Core 3. What are your thoughts? I just don't want to screw up what works for everything else. I'm totally nervous that I wouln't be able to undo any potential mess??? Also, I have a fully updated complete FC3 install with nothing installed from livna. What do you mean by updated with livna??

2485 frames in 5.0 seconds = 497.000 FPS
2412 frames in 5.0 seconds = 482.400 FPS
2846 frames in 5.0 seconds = 569.200 FPS
2493 frames in 5.0 seconds = 498.600 FPS
2837 frames in 5.0 seconds = 567.400 FPS
2841 frames in 5.0 seconds = 568.200 FPS
11447 frames in 5.0 seconds = 2289.400 FPS
41047 frames in 5.0 seconds = 8209.400 FPS
41515 frames in 5.0 seconds = 8303.000 FPS
36486 frames in 5.0 seconds = 7297.200 FPS
41625 frames in 5.0 seconds = 8325.000 FPS
41792 frames in 5.0 seconds = 8358.400 FPS
36968 frames in 5.0 seconds = 7393.600 FPS
41753 frames in 5.0 seconds = 8350.600 FPS



antidelldude 06-03-2005 02:17 PM

Basically that over 8000 fps you are getting means there should be 3d. To make sure of this what does this command return.

glxinfo | grep direct

It should return Direct Rendering : yes

And what I mean by livna is the server that yum accesses when it updates your computer. If you updated the server with up2date i can see if you're running into problems or if you used other files from other servers. Let me know what happens. Try tux racer and if it is playable. It comes with fc3 pre-installed. But if you have tried various other posts and have failed with those you may have some vacant files sitting around on your computer that will need to be taken care of.

asdf_6667 06-03-2005 02:40 PM

does anybody will reply me??
hi, i've posted a previous message in this thread... please help me!!



antidelldude 06-03-2005 05:01 PM

Sorry bout that dude. I was never e-mailed about your post. Anyways, The only reason it would say failed dependencies would be that the GCC compiler was not installed correctly or a newer version is needed.

Try this:

Open up a terminal and type

yum install gcc

It should automatically process all dependencies for the compiler and ofcoarse the compiler itself. I hope that is the neded software for the ATI drivers to compile.

This also is mentioned in my guide.
4) Open a terminal, navigate to where you saved it, and type "rpm -Uvh --force ati.rpm" It will try to force, then it will fail.

5) Next thing you need to do is in the same terminal type "yum install gcc" (If you don't know how to setup yum head over to or just post in this thread asking)

asdf_6667 06-05-2005 12:46 AM

thanks!!! it works!
Thank you! i've installed the missing libraries, and now it works fine!

Mirag3 06-15-2005 04:36 PM

hey maybe i made a big mistake, but the rpm didnt fail, I think it may be because i already had gcc installed (i compile a whole ton of stuff). My question is if i can roll back the rpm install or something. Also, the patches dont install even though im sure i spelled it right (the terminal just freezes and i gotta do ctrl-c).

antidelldude 06-16-2005 04:46 PM

Sure looks like you had gcc already installed. As for the patches. Pay close attention. When the terminal freezes like that it means that something was spelled wrong. Thats what happened to me.

Mirag3 06-16-2005 11:18 PM

Sorry man, but i dont think it works for me, what kernel are you using, i got 2.6.11-1.27smp. I think i spelled everything right, and it still just freezes up heres my code (i saved it in my home dir):

Installed: gcc.i386 0:3.4.3-22.fc3
Dependency Installed: glibc-devel.i386 0:2.3.5-0.fc3.1 glibc-headers.i386 0:2.3.5-0.fc3.1 glibc-kernheaders.i386 0:2.4-9.1.87
Dependency Updated: cpp.i386 0:3.4.3-22.fc3 glibc.i686 0:2.3.5-0.fc3.1 glibc-common.i386 0:2.3.5-0.fc3.1 libgcc.i386 0:3.4.3-22.fc3
[root@localhost andy]# rpm -Uvh --force ati.rpm
Preparing...                ########################################### [100%]
  1:fglrx_6_8_0            ########################################### [100%]
[root@localhost andy]# cd /lib/modules/fglrx/build_mod/
[root@localhost build_mod]# patch -p0 /home/andy/p1.patch

Cypionate 06-16-2005 11:26 PM

I have a ati mobile 7500 graphics card in my IBM t42 and I can't get drivers to ever work for it. Any suggestions would be welcomed although I think I'm beat for now.

All times are GMT -5. The time now is 05:36 PM.