-   Fedora (
-   -   Apache + mod_ldap seg faulting - what am I doing wrong? (

patniemeyer 02-06-2009 12:47 PM

Apache + mod_ldap seg faulting - what am I doing wrong?
I have a brand new Fedora 10 system on which I have just installed apache and mod_ldap for use with SVN (using yum). I had the benefit of copying the Apache config from a working machine, so I thought that this would be easy.

However when I try to access the resources it fails and I get a notice about a seg fault in the error_log, e.g.:

[notice] child pid 1661 exit signal Segmentation fault (11)

If I comment out the Require ldap-group line in my config (and presumably it then doesn't use ldap) then all works fine, so I think the problem is in my ldap install.

I have looked around for a core file and also turned up Apache to debug log level, but I do not see any further information. I am wondering if yum is not aware of some dependency or if I'm missing some config that I'm unaware of.

Can anyone give me any pointers on how to proceed with debugging this problem?


patniemeyer 02-08-2009 03:03 PM

A bit more information - I was able to use ldapsearch (the CLI tool from the mozldap package) to execute the query from this machine. So I don't think there is any obvious connectivity issue or missing open ldap install. It just seems to be related to apache mod_ldap or apache config.

patniemeyer 02-23-2009 10:42 AM

Someone better at this than me found that installing apr_util_ldap was the solution.

Sounds like Apache probably should not come via yum with mod_ldap by default because of this dependency. Or at minimum it should do something smarter than segfault when it's not present.

brunojcm 03-05-2009 04:12 PM

bug report

I've found the same problem a few days ago, this thread saved me!

I tried to report the bug and discovered that it has already been reported, here:

You can vote to get this issue solved in fedora 10. In rawhide it`s been resolved.
You can also solve it running, as root:
yum install apr-util-ldap


Bruno Medeiros

All times are GMT -5. The time now is 06:53 PM.