-   Fedora (
-   -   acpi-cpufreq device not found? (

lordSaurontheGreat 11-09-2006 10:06 AM

acpi-cpufreq device not found?
This is a rather odd problem. Whenever I try and enable cpu frequency scaling, I get the following:


[root@localhost grub]# modprobe acpi-cpufreq
FATAL: Error inserting acpi_cpufreq (/lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko): No such device

I'm pretty much stumped. I'm runing an Intel Pentium-M ULV 1.0GHz i686 processor. However, some quality time with the terminal and yum shows that the "kernel.i386" version is installed. Should I change to the i686 version? Is there some kmod package I need? My kernel version is 2.6.18, so I don't think there's a issue with that.

Thanks for any help.

snecklifter 11-09-2006 01:29 PM

You need to be sure your processor supports it. According to:

you can have a look at:

$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies


$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors

which gives feedback from the processor hardware as to what it supports and doesn't.

Have you tried

# modprobe cpufreq_ondemand

instead? This is the module that governs my cpu frequency in FC6.


lordSaurontheGreat 11-10-2006 12:48 AM

I know that my CPU supports it since it worked all the time in Gentoo and Kubuntu.

I tried modprobe cpufreq_ondemand, and that worked without error messages, however, the CPU frequency scaling applet for Gnome doesn't seem to work still (which is how I want to control the frequency scaling, since that'd be easier - I'm trying to keep my system more GTD, rather than my personal Linux playground).

Thanks for your help though. I'm sure I'm getting closer to the solution with your suggestion of cpufreq_ondemand

noxious 11-10-2006 08:06 PM

Yes, you need the 686 kernel. I had the exact same problem with FC6 - it, by default, installed the 586 kernel. Deleted that, and without reboot, installed the 686 kernel. Works with reboot.

glussier 11-10-2006 08:57 PM

If you want to know if you have the i586 or i586 kernel installed, in a console:


rpm -q kernel --qf '%{ARCH}\n'
If you want to replace the 586kernel with the i686 kernel, in a console


su -
yumdownloader kernel-2.6.18-1.2798.fc6.i686
rpm -Uvh --replacefiles --replacepkgs kernel-2.6.18-1.2798.fc6.i686.rpm

lordSaurontheGreat 11-13-2006 03:24 PM

I found better luck with


# yum install kernel-2.6.18-1.2798.fc6.i686
Installing now, going to see how it works.

lordSaurontheGreat 11-13-2006 04:07 PM

Switching to the i686 kernel worked.

A small hitch for future reference: the i586 kernel that was installed was slightly more up to date than the replacement i686 kernel. After it finished downloading (btw: an easier download would be "$ yum kernel.i686") it quit because the installed was more recent than the replacement. Going to /var/cache/yum/core/packages and then using "$ rpm --force --install kernel-{VERSION}.{ARCH}.rpm" worked.

Thanks for the help! I really appreciate it!

frenchn00b 08-22-2009 09:12 AM


I am having the same issue, running kmuto backported last version of debian.


modprobe -i acpi
FATAL: Error inserting acpi_cpufreq (/lib/modules/2.6.30-1-686/kernel/arch/x86/kernel/cpu/cpufreq/acpi-cpufreq.ko): No such device

p4-clockmod is giving too

no such device

All times are GMT -5. The time now is 06:52 PM.