-   Fedora (
-   -   403 error when NamedVirtualHost is enabled - *not* SELinux related (

gharvey 05-04-2009 01:40 PM

403 error when NamedVirtualHost is enabled - *not* SELinux related
Hi all,

I get a 403, access denied whenever I switch on NamedVirtualHost in Apache2 on my newly installed Fedora 10 laptop. All is fine until I uncomment the NamedVirtualHost line, then it alls goes wrong. 403 for everything!

I Googled a load this afternoon and turned up several mentions of this being related to SELinux. I did the advised chcon stuff, as detailed here:

That had no effect, so I disabled SELinux completely for the time being. Also no effect.

The website is Drupal and it's using Drupal's default .htaccess file (which I've never had a problem with before). Config looks like this:


<VirtualHost *:80>
  ServerName drivingforce             
  DocumentRoot /home/gharvey/workspace/driving-force/trunk/www
  ServerAdmin ""
  <Directory /home/gharvey/workspace/driving-force/trunk/www>
    Options Includes FollowSymLinks
    AllowOverride All

Worked on my old LAMPP installation and works on my CentOS 5 dev server. But not on Fedora 10, and I've no idea why?! =(

Edit: Also tried a test site with a simple "Hello world!" index.html file and no .htaccess. Plus someone in IRC suggested this, which I also tried - neither worked:


chcon -R unconfined_u:object_r:httpd_sys_content_t:s0 workspace

gharvey 05-04-2009 04:33 PM

Tried this as well:

Didn't work. Also tried symlinking the workspace directory in my home directory to /var/www/html/workspace - also didn't work.

Interestingly, moving my workspace directory to /var/www/html/workspace *did* work, so it's clearly something to do with Apache having permissions outside of /var/www or having access to /home/* ... and not because of SELinux.

The UserDir stuff sounded promising, but yielded no results. :(

Still looking for answers.

Edit: commented our the mod_userdir module entirely and restarted Apache - same problem, so UserDir cannot be the cause either.

All times are GMT -5. The time now is 10:06 PM.