-   Fedora (
-   -   3Com Nic Not Connected (

BittaBrotha 11-03-2003 10:11 PM

3Com Nic Not Connected
I just installed Test3 on my home system and everything seems to be going great but the cable modem connection. It seems to have the correct Nic listed, which is a 3com 3c59x card, but not getting data to come through. When I type ifconfig, I see eth0 is up, but no IP numbers.

I typed lsmod and it show the nic listed. When I try to ping, I get error msg, Unknown host. I've tried putting in Static IP numbers and Dynamic(DHCP), still nothing connects.

Everything else seems to have been picked up by RH and working fine. I don't know why the net connection not working though. It is hooked up to a Dlink 4 port router.

But from what I see, it is very good looking distro. I kinda like it so far. I haven't tried doing much of anything else, such as compiling kernels etc etc etc.

Any suggestions/ideas?


Scruff 11-04-2003 12:56 AM

Is the 3com your only nic? If not, check to be sure which eth0/1 is configured for lan/internet access, and which nic is recognised as 0 or 1. I had this problem in Slackware with multiple nic's.

BittaBrotha 11-04-2003 01:09 AM

It is the only Nic and it does work with my other distros.

Here's what I get when I type the route command:

Destination Gateway Iface * lo * lo
Debian * eth0
* eth0
It seems something not right with RH routing. While in RH, when I type ifconfig command, I do see eth0 is UP but no IP numbers.

How can I fix this?


carstenson 11-04-2003 08:30 AM

Routing is not an issue at this point. You need an ip address on your interface. Check /etc/sysconfig/network-scripts/ifcfg-eth0. Among others, there should be an IPADDR= line.

cropcircle 11-07-2003 01:13 PM

You are probably experiencing a bug with Kudzu and the 3Com network driver.

See the following URL :

If this is the case, you can try disabling "kudzu" as a workaround :

- Change to the root user with the command "su -"
- Disable Kudzu in the runlevels 3, 4 and 5 with the command "chkconfig --level 345 kudzu off"
- Reboot the system.

Note : Kudzu is a program which detects and configures new and/or changed hardware on a system.

popa 11-07-2003 04:47 PM

Thanks I'm gonna give that a shot. Just out of curiousity though ... Would the command to turn it back on be "chkconfig --level 345 kudzu on" ?

cropcircle 11-07-2003 05:06 PM

Yes, "chkconfig --level 345 kudzu on" turns Kudzu back on for runlevel 3, 4 and 5.

If you want to check which services are running in - for example - runlevel 5, you can use the following command :

chkconfig --list |grep "5:on"

There is also a graphical tool called "redhat-config-services" - accessible from the menu and from the commandline - which can enable or disable certain services for each runlevel.

All times are GMT -5. The time now is 02:10 AM.